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Preface

Thank you for selecting MONITOUCH TECHNOSHOT (hereafter referred to as “TS”).
For correct setup of the TS, you are requested to read through this manual to understand more about the product.
For details on other operating procedures for the TS, refer to the following related manuals.

For details on devices including PLCs, inverters, and temperature controllers, refer to the manual for each device.

Manual Name Contents Reference No.
TS Reference Manual [1] Explains the functions and operation of the TS. 1204NE
TS Reference Manual [2] 1205NE
TS2060 Connection Manual [1] Explains the connection and communication parameters for the TS2060 and 

controllers in detail.
2204NE

TS2060 Connection Manual [2] 2205NE
TS2060 Connection Manual [3] 2206NE
TS2060 Hardware Specifications Explains hardware specifications and precautions when handling the TS2060. 2207NE
TS1000 Smart Connection Manual [1] Explains the connection and communication parameters for TS1000 Smart 

and controllers in detail.
2213NE

TS1000 Smart Connection Manual [2] 2214NE
TS1000 Smart Connection Manual [3] 2215NE
TS1000 Smart 
Hardware Specifications

Explains hardware specifications and precautions when handling TS1000 
Smart.

2216NE

Notes:

1. This manual may not, in whole or in part, be printed or reproduced without the prior written consent of Hakko Electronics 
Co., Ltd.

2. The information in this manual is subject to change without prior notice.
3. Windows and Excel are registered trademarks of Microsoft Corporation in the United States and other countries.
4. All other company names or product names are trademarks or registered trademarks of their respective holders.
5. This manual is intended to give accurate information about MONITOUCH hardware. If you have any questions, please 

contact your local distributor.



TS Types and Model Names

The notations used in this manual and the corresponding models are as shown below.
Notation Model

TS TS2060i, TS2060, TS1100Si, TS1070Si, TS1070S
TSi TS2060i, TS1100Si, TS1070Si
TS2060i TS2060i
TS2060 TS2060
TS1000 Smart TS1100Si, TS1070Si, TS1070S
TS1000S



Available Functions

Note that functions available differ depending on the TS model. For details, refer to the related chapters.

Functions Described in TS Reference Manual 1
: Available  : Conditionally available  : Not available

TS Reference Manual 1 TS2060i TS2060 TS1100Si
TS1070Si TS1070S RemarksChapter Description

2 Overlap Normal overlap Superimposing not possible
Call-overlap
Multi-overlap
Global overlap

3 Switch Switch
Scroll bar
Slider switch

4 Lamp Lamp
5 Data Display Numerical data display

Character display
Message display
Table data display

6 Entry Numerical data entry
Character input (including 
Japanese conversion function)

7 Trends Historical display : Storage device not usable
Real time display

8 Alarm Historical display : Storage device not usable
Real time display

9 Graph Bar graph
Pie graph
Closed area graph
Panel meter

Numerical data display
Alarm (Area color)

Scale setting extended
: Landscape orientation only
: Landscape orientation only
: 128 colors, landscape 

orientation only
Statistic bar graph
Statistic pie graph

10 Time Display Time display
Calendar

11 Graphics Graphics
12 Message Message mode

Displaying comments
13 Others Data block area

Memory card mode : Storage device not usable
Memo pad

14 Item 
Show/Hide 
Function

Item show/hide function

15 Recipes Recipe
16 Print Hard copy : Serial connection only

Printing data sheets
Connecting to a Sato MR-400 
barcode printer

17 Barcode Barcode (one-dimensional, 
two-dimensional)

: Serial connection only



Functions Described in TS Reference Manual 2 (this manual)
: Available  : Conditionally available  : Not available

System Setting
: Available  : Conditionally available  : Not available

TS Reference Manual 2 TS2060i TS2060 TS1100Si
TS1070Si TS1070S RemarksChapter Description

1 Image Display JPEG : 32k/64k colors only
Network camera

2 Operation Log Operation log
3 Security Security
4 Ethernet 

Communication 
Function

Screen data transfer
PLC communication
Transferring data between TS 
units (macro)
DLL communication
MES interface function
E-mail notification
FTP server
Remote desktop window 
display

: 32k/64k colors, landscape 
orientation only

Web server
VNC server : 32k/64k colors, landscape 

orientation only
5 Storage device Storage device
6 Language 

Changeover
Language selection : Storage device not usable

7 Tag Tags
8 Device Memory 

Map
Device Memory Map

9 Ladder Transfer Ladder transfer via USB
Ladder transfer via Ethernet
Serial ladder transfer

Item TS2060i TS2060 TS1100Si
TS1070Si TS1070S Remarks

Color 64K-Color w/o blinking
32K-Color
128-Color
256 colors w/o blinking
Monochrome 16-grayscale
Monochrome

Font Type Bitmap font
Stroke font
Gothic font
Windows font

Hardware Settings Ladder monitor
Function Switches Global function switches : When using soft function 

switchesLocal function switches
TechnoShot 
Settings

VGA center display



Notes on Safe Usage of MONITOUCH
In this manual, you will find various notes categorized under the following levels with the signal words “DANGER” and “CAUTION”.

Note that there is a possibility that items listed with  may have serious ramifications.

DANGER Indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury.

CAUTION
Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury and could 
cause property damage.

• Never use the output signal of the TS for operations that may threaten human life or damage the system, such as signals used in 
case of emergency. Design the system so that it can cope with a touch switch malfunction. A touch switch malfunction may result in 
machine accidents or damage.

• Turn off the power supply when you set up the unit, connect new cables, or perform maintenance or inspections. Otherwise, 
electrical shock or damage may occur.

• Never touch any terminals while the power is on. Otherwise, electrical shock may occur.
• The liquid crystal in the LCD panel is a hazardous substance. If the LCD panel is damaged, do not ingest the leaked liquid crystal. If 

leaked liquid crystal makes contact with skin or clothing, wash it away with soap and water.
• Never disassemble, recharge, deform by pressure, short-circuit, reverse the polarity of the lithium battery, nor dispose of the lithium 

battery in fire. Failure to follow these conditions will lead to explosion or ignition.
• Never use a lithium battery that is deformed, leaking, or shows any other signs of abnormality. Failure to follow these conditions will 

lead to explosion or ignition.
• Switches on the screen are operable even when the screen has become dark due to a faulty backlight or when the backlight has 

reached the end of its service life. If the screen is dark and hard to see, do not touch the screen. Otherwise, a malfunction may occur 
resulting in machine accidents or damage.

• Tighten the screw on the mounting fixtures of the TS unit to an equal torque of 4.43 lbf-in (0.5 N·m). Excessive tightening may cause 
distortion, damage, and incorrect touch switch activation, leading to machine damage and accidents. Insufficient tightening may 
cause the unit to fall down, malfunction, or short-circuit.

• Check the appearance of the unit when it is unpacked. Do not use the unit if any damage or deformation is found. Failure to do so 
may lead to fire, damage, or malfunction.

• For use in a facility or as part of a system related to nuclear energy, aerospace, medical, traffic equipment, or mobile installations, 
consult your local sales representative. 

• Operate (or store) the TS under the conditions indicated in this manual and related manuals. Failure to do so could cause fire, 
malfunction, physical damage, or deterioration.

• Observe the following environmental restrictions on use and storage of the unit. Otherwise, fire or damage to the unit may result.
- Avoid locations where there is a possibility that water, corrosive gas, flammable gas, solvents, grinding fluids, or cutting oil can 

come into contact with the unit. 
- Avoid high temperatures, high humidity, and outside weather conditions, such as wind, rain, or direct sunlight.
- Avoid locations where excessive dust, salt, and metallic particles are present.
- Avoid installing the unit in a location where vibrations or physical shocks may be transmitted.

• Equipment must be correctly mounted so that the main terminal of the TS will not be touched inadvertently. Otherwise, an accident 
or electric shock may occur.

• Check periodically that terminal screws on the power supply terminal block and fixtures are firmly tightened.  Loosened screws may 
result in fire or malfunction.

• Tighten the terminal screws on the power supply terminal block of the TS uniformly to the specified torque. Improper tightening of 
screws may result in fire, malfunction, or other serious trouble.

• The TS has a glass screen. Do not drop the unit or impart physical shocks to the unit. Otherwise, the screen may be damaged.
• Correctly connect cables to the terminals of the TS in accordance with the specified voltage and wattage. Overvoltage, overwattage, 

or incorrect cable connection could cause fire, malfunction, or damage to the unit.
• Always ground the TS2060. The FG terminal must be used exclusively for the TS2060 with the level of grounding resistance less than 

100 Ω. Otherwise, electric shock or a fire may occur.
• Do not use a positive ground for the 24-V power supply to the TS1000 Smart. If a positive ground is used and an external 

communication device such as a computer is connected, the 24-V power supply may short circuit and cause damage. If a positive 
ground is unavoidable, refer to “Positive Grounding” in the TS1000 Smart Hardware Specifications.

• Prevent any conductive particles from entering the TS. Failure to do so may lead to fire, damage, or malfunction.
• Do not attempt to repair the TS yourself. Contact Hakko Electronics or the designated contractor for repairs.

CAUTION

DANGER

CAUTION



[General Notes]
• Never bundle control cables or input/output cables with high-voltage and large-current carrying cables such as power supply cables. 

Keep control cables and input/output cables at least 200 mm away from high-voltage and large-current carrying cables. Otherwise, 
malfunction may occur due to noise.

• When using the TS in an environment where a source of high-frequency noise is present, it is recommended that the FG shielded 
cable (communication cable) be grounded at each end. However, when communication is unstable, select between grounding one or 
both ends, as permitted by the usage environment.

• Be sure to plug connectors and sockets of the TS in the correct orientation. Failure to do so may lead to damage or malfunction.
• If a LAN cable is inserted into the MJ1 or MJ2 connector, the device on the other end may be damaged. Check the connector names 

on the unit and insert cables into the correct connectors.
• Do not use thinners for cleaning because it may discolor the TS surface. Use commercially available alcohol.
• If a data receive error occurs when the TS unit and a counterpart unit (PLC, temperature controller, etc.) are started at the same time, 

read the manual of the counterpart unit to correctly resolve the error.
• Clean the display area using a soft cloth to avoid scratching the surface. 
• Avoid discharging static electricity on the mounting panel of the TS. Static charge can damage the unit and cause malfunctions. 

Discharging static electricity on the mounting panel may cause malfunction to occur due to noise.
• Avoid prolonged display of any fixed pattern. Due to the characteristic of liquid crystal displays, an afterimage may occur. If prolonged 

display of a fixed pattern is expected, use the backlight’s auto OFF function.
• The TS is identified as a class-A product in industrial environments. In the case of use in a domestic environment, the unit is likely to 

cause electromagnetic interference. Preventive measures should thereby be taken appropriately.

[Notes on the LCD]
Note that the following conditions may occur under normal circumstances.

• The response time, brightness, and colors of the TS may be affected by the ambient temperature.
• Tiny spots (dark or luminescent) may appear on the display due to the characteristics of liquid crystal.
• There are variations in brightness and color between units.

• Do not repair, disassemble, or modify the TS. Hakko Electronics Co., Ltd. is not responsible for any damages resulting from repair, 
disassembly, or modification of the unit that was performed by an unauthorized person.

• Do not use sharp-pointed tools to press touch switches. Doing so may damage the display unit.
• Only technicians are authorized to set up the unit, connect cables, and perform maintenance and inspection.
• Lithium batteries contain combustible material such as lithium and organic solvents. Mishandling may cause heat, explosion, or 

ignition resulting in fire or injury. Read the related manuals carefully and correctly handle the lithium battery as instructed.
• Take safety precautions during operations such as changing settings when the unit is running, forced output, and starting and 

stopping the unit. Any misoperations may cause unexpected machine movement, resulting in machine accidents or damage.
• In facilities where the failure of the TS could lead to accidents that threaten human life or other serious damage, be sure that such 

facilities are equipped with adequate safeguards.
• When disposing of the TS, it must be treated as industrial waste.
• Before touching the TS, discharge static electricity from your body by touching grounded metal. Excessive static electricity may 

cause malfunction or trouble.
• Insert an SD card into the unit in the same orientation as pictured on the unit. If an SD card is accidentally inserted in the wrong 

orientation, the SD card or the slot on the unit may be damaged.
• Never remove a storage device (SD card or USB flash drive) when the storage device is being accessed. Doing so may destroy the 

data on the storage device. Only remove a storage device when the Main Menu screen is displayed or after pressing the [Storage 
Removal] switch.

• Do not press two or more positions on the screen at the same time.  If two or more positions are pressed at the same time, a switch 
located between the pressed positions may be activated.

• Be sure to remove the protective sheet that is attached to the touch panel surface at delivery of the TS2060 before use. Use with the 
protective sheet attached may result in incorrect recognition of touch operations.

CAUTION
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1.1 JPEG Display
1.1.1 Overview

JPEG File Display
• Display JPEG files saved to a storage device.
• JPEG files with a resolution up to 1024 × 768 can be displayed.

• There are three ways to load JPEG files.
- Filename specification
- File number specification (fixed)
- File number specification (PLC device memory)

Network Camera Image Display
• Display network camera snapshot images saved to a storage device.
• Two methods of specifying a file number and designating a file number from the PLC are available.

PLC

D100=5 D100=2

Error Error

Take a 
snapshot

Factory
JPEG

Ethernet
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1.1.2 Detailed Settings
Operation Select

*1 Display example

Item Description
Target Select Select a display target.

JPEG Display a JPEG file prepared in advance.
Filename: JPxxxxx.jpg (xxxxx: 00000 to 32767)
Any filename (maximum of 64 one-byte numerals or uppercase alphabetic characters)

Video Snap Display a video snapshot image.
Filename: VDxxxxx.jpg (xxxxx: 00000 to 32767)

Select File Select the file specification method.
File No. Specify the “xxxxx” part of “JPxxxxx.jpg” or “VDxxxxx.jpg” with a file number from 0 to 

32767.
File Name Specify a filename. Maximum of 64 one-byte numerals or uppercase alphabetic characters
Device *1 Set the device memory address that specifies the “xxxxx” part of “JPxxxxx.jpg” or 

“VDxxxxx.jpg” with a file number from 0 to 32767.
This allows the JPEG file to be changed in RUN mode.

Display Operation Fit to display area *2 Unselected: Actual size
Selected: Automatically enlarge or reduce the display according to the size of the 

display area.
The level of display detail can be specified at $s1008 when enlarging or reducing the 
display.

$s1008 Detail Speed
0 Coarse Fast
1 Fine Slow

PLC

D100 = 2 D100 = 0

JP00000 . JPG JP00001 . JPG JP00002 . JPG

JPEG JPEG
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*2 Display example
- Checkbox: unselected

The image is displayed at its original size with respect to the top left corner of the display area. If the JPEG image is larger than the 
display area, the part of the image outside the display area is not shown. Note that the color of the display area is visible when the JPEG 
image is smaller than the display area. It is recommended that users match the display area color with the background color of the 
image.

- Checkbox: selected
The image is enlarged or reduced with respect to the top left corner of the display area. The image is enlarged or reduced using the 
same factor for width and length.

Use a color that matches the background color.

Same size

Size is smaller than the displayed image

Size is larger than the displayed image

Reduction

Enlargement
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*1 Display example
- When the [+100] switch is pressed while file No. 800 is displayed, a search is conducted for file No. 900 or later and the file is displayed.

When a search has been conducted to No. 32767, it is continued moving back to No. 0.

Item Description
Additional Parts List Displays a list of JPEG display switches.

Parts can be added to the list using the [Add Parts] button.
Target file

+ Block Display the JPEG file corresponding to the next file number.
JPxxxxx.jpg
VDxxxxx.jpg− Block Display the JPEG file corresponding to the previous file number.

File Call Load the JPEG file corresponding to the specified file number.
File Delete Delete the JPEG file that is currently displayed. VDxxxxx.jpg
JPEG Search Set an increment or decrement value to use to search for and display a 

JPEG file *1. JPxxxxx.jpg
VDxxxxx.jpgScroll Bar (Horizontal) Scroll the displayed JPEG horizontally.

Scroll Bar (Vertical) Scroll the displayed JPEG vertically.
Adjust Position Displays the window for adjusting the placement position of each part.

The size of parts can also be changed.
Select from catalogs Set the part design from the catalog.
Parts Design Set the design and color of parts.
Edit Selected Parts Configure the part selected in the [Additional Parts List] or preview pane.

+100 -100 +100-100

Function: Search for the 
JPEG file and display
Increment/Decrement: 
-100

(1) No. 800 = JP00800.jpg is displayed.
(3) A search is conducted and No. 900 

= JP00900.jpg is displayed.

Function: Search for the 
JPEG file and display
Increment/Decrement: 
100

(2) Press the [+ 100] switch.
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- When the [−100] switch is pressed while file No. 800 is displayed, a search is conducted for file No. 700 or prior and the file is displayed.
When a search has been conducted to No. 0, it is continued moving back to No. 32767.

Show/Hide
Set the show and hide settings of graphic items.

Detail

For details, refer to “14 Item Shown/Hide Function” in the TS Reference Manual 1.

Item Description
Coordinate Start X/Start Y Set the placement position and size of the display area.

Width/Height
Others Process Cycle Set the cycle for the TS to read PLC data.

File No. Output Device Output the file number of the currently displayed image.
ID Set an ID number.

-100 -100 +100+100

(1) No. 800 = JP00800.jpg is displayed.
(3) A search is conducted and No. 700 

= JP00700.jpg is displayed.

(2) Press the [-100] switch.
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1.1.3 JPEG File Location
The JPEG display function loads and displays the files in the following location.

Display Target Filenames File Location
JPEG JPxxxxx.jpg (xxxxx: 00000 - 32767)

xxxxxxx.jpg (maximum of 64 one-byte numerals or 
uppercase alphabetic characters)

(access folder)\JPEG folder

Video Snap VDxxxxx.jpg (xxxxx: 00000 - 32767) (access folder)\SNAP folder
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1.2 Network Camera
1.2.1 Overview

• Images from network cameras can be displayed on the TSi unit. Only the TSi unit supports this function because cameras 
are connected using an Ethernet connection.

• Camera operation
Using a command device memory or an operation switch on the screen allows network cameras to be easily controlled 
from a remote location.

Note that some network cameras cannot be controlled remotely. See the specifications of your network camera.

Example: Monitoring the conditions in the factory

Factory A

Ethernet

Factory B

Network camera

Factory A Factory B
Factory B

Ethernet
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• Snapshot function
The currently displayed image can be saved to a storage device as a JPEG file when the bit of a command device memory 
changes to ON or by double-tapping the display area.

1.2.2 System Requirements
Applicable Models

Available Network Cameras or Sensors

*1 No image is displayed upon initial connection.
To display an image, sensor memory PI10000-00 (Trigger) must be change from “0” to “1” (leading edge). When accessing sensor 
memory from the TSi unit, select [System Setting] → [Hardware Setting] → [Maker: BANNER].

1.2.3 Required Settings
V-SFT Settings

• Settings in network camera display items → “1.2.4 Detailed Settings” page 1-9

Network Camera Settings
• AXIS models → “1.2.5 AXIS Settings (Example: AXIS 214PTZ)” page 1-13
• Panasonic models → “1.2.6 Panasonic (Example: BB-HCM580)” page 1-18
• BANNER models → “1.2.7 BANNER (Example: PresencePLUS P4 OMNI)” page 1-28

PASS POWER
READY

FAIL ERROR
TRIGGER

Ethernet

Vision sensor

Double-tapping the display area 
saves an image to the “SNAP” 
folder on the storage device.

MONITOUCH Models Connection Port Remarks
TS2060i
TS1100Si
TS1070Si

LAN (built-in) Not available with CUR-03

Manufacturer Type Protocol
Axis

MOTION-JPEG
(video)

HTTP protocol communication 
(TCP/IP)Panasonic BB series

BL series
BANNER PresencePLUS P4 OMNI Bitmap

(still image) *1 Dedicated protocol
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1.2.4 Detailed Settings
Device Setting
Manufacturer: AXIS and Panasonic

*1 For details on setting IP addresses, refer to the user’s manual of the network camera.

Item Description
Network Camera Setting Configure the settings of a network camera.

Maker Select the manufacturer of the network camera.
AXIS, Panasonic

IP Address *1 Specify the IP address of the network camera.
Port No.
(Panasonic only)

Specify the port number of the network camera.
1 to 65535 (default: 80)

Unit Setting Configure the settings of the TSi unit.
Port No. Specify the port number of the TSi unit. The three consecutive port numbers from the 

specified port number are used.
1024 to 65535 (default: 50000 to 50002)

Use authentication setting Select this checkbox to use basic authentication for the network camera.
This enables user ID and password settings. For details, refer to your network camera settings.

User ID
Password

Enter the user name and password registered in the network camera settings.
For details, refer to your network camera settings.

Manufacturer Model Remarks
Axis 214PTZ Use AXIS’s dedicated tool when changing the default IP address.

Default: 192.168.0.90
Panasonic BB-HCM580 Use the CD-ROM provided with the network camera when changing the 

default IP address.
Default: Automatic setup
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BANNER

*1 For details on setting IP addresses, refer to the user’s manual of the network camera.

*2 Setting Examples
- When [Snap file naming] is “AUTO”, [Maximum Number of Saves] is “10”, and [Action when Limitation is Exceeded] is “Overwrite”

Snapshot files ranging from “VD00000.jpg” to “VD00009.jpg” are created in sequence. When the file “VD00009.jpg” is created, the 
previous files will be overwritten from “VD00000.jpg”.

- When [File Name] is “Specify” and [File No.] is “30”
The file “VD00030.jpg” is created and always overwritten.

*3 When screen data contains both [AUTO] and [Specify] selected for [Snap file naming], enter a value for [Specify] in the 255 to 32767 
range so that files created according to [AUTO] do not overwrite the file created according to [Specify]. When [AUTO] is selected, the file 
number saved last is stored in system memory address $s932.

Item Description
Network Camera Setting Configure the settings of a network camera.

Maker Select the manufacturer of the network camera.
BANNER

IP Address *1 Specify the IP address of the network camera.
Port No. Specify the port number of the network camera.

20000 to 20009 (default: 20000)
Unit Setting Configure the settings of the TSi unit.

Port No. Specify the port number of the TSi unit.
Fixed to “1969”

Snap Setting *2 *3 Save the displayed image as a JPEG file by double-tapping on the display area.

Save location: (storage device)\DAT0000\SNAP
File Name Set the filename to use when saving a snapshot.

AUTO (1 to 255):
Save using sequential numbers from “VD00000.jpg”.
Set the action to perform when the maximum number of snapshots is reached using [Snap 
File Setting].

Specify (0 to 32767):
Save using the specified file number. If the specified file already exists, it is overwritten.

Snap File Setting Configure snapshot file settings.

Manufacturer Model Remarks
BANNER PresencePLUS P4 OMNI Use the CD-ROM provided with the network camera when changing the default IP 

address.
Default: Automatic setup

VD00000.jpg
VD00001.jpg
VD00002.jpg

VD00008.jpg
VD00009.jpg

Sequential 
numbering

When reaching the limit number, 
the files are overwritten from the 
first file.
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Contents

*1 AXIS, BANNER: Cannot set to 192 * 144
*2 Panasonic, BANNER: Cannot set to 90, 270

Item Description
Size *1 Set the size of the display area.

160 * 120, 192 * 144, 320 * 240, 640 * 480
Rotation Angle *2 Set the rotation angle of the image output from the network camera. Select an angle appropriate for the 

mounting orientation of the network camera.
0, 90, 180, 270
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*1 Note that some network cameras cannot be controlled remotely. See your network camera specifications. (No BANNER products support 
these functions.)

*2 If the [Delay] → [ON repeat] setting is configured in the switch settings window, the function performed by the switch is repeated while 
the switch is held down.

Show/Hide
Set the show and hide settings of JPEG display items.

Detail

Item Description
Additional Parts List Select an operation switch. *1 *2

Step Left Pan the camera left.
Step Right Pan the camera right.
Step Up Tilt the camera up.
Step Down Tilt the camera down.
Zoom In Zoom in on the camera image.
Zoom Out Zoom out of the camera image.
Focus Far Focus the camera on a distant point.
Focus Near Focus the camera on a nearby point.
Pause Pause video display.
Restart Resume video display.

Parts Design Set the design and color of parts.
Edit Selected Parts Configure the part selected in the [Additional Parts List] or preview pane.
Adjust Position Displays the window for adjusting the placement position of each part.

The size of parts can also be changed.

Refer to “14 Item Shown/Hide Function” in the TS Reference Manual 1.

Item Description
Coordinate Start X/Start Y Specify the coordinates of the display area.
ID Set an ID number.
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1.2.5 AXIS Settings (Example: AXIS 214PTZ)
Access from the Computer
1. Start up Microsoft Internet Explorer on your computer.
2. Enter the IP address of the network camera in the address field.

3. The following dialog is displayed when using basic authentication. Enter a registered user name and password, and click 
the [OK] button.
If basic authentication is not used, proceed to step 4.
For details on basic authentication, refer to page 1-15.

4. The [Live view] window is displayed.

http://xxx.xxx.xxx.xxx
Network camera IP address
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Network Camera Settings
Checking and changing the IP address
1. Display the [Setup] window.

* If basic authentication is not used, pressing the [Setup] button displays the dialog box shown in step 3 of “Access from the 
Computer” page 1-13. Enter a user name and password.

2. On the menu on the left of the screen, click [Basic Configuration Instructions] → [2. TCP/IP].
3. Check and change the network camera IP address, subnet mask, and gateway settings as required.

4. Click the [Save] button to save any changes.

HTTP settings
1. Display the [Setup] window.

* If basic authentication is not used, pressing the [Setup] button displays the dialog box shown in step 3 of “Access from the 
Computer” page 1-13. Enter a user name and password.

2. On the menu on the left of the screen, click [System Options] → [Security] → [HTTPS].
3. Select “HTTP” for the options under [HTTPS Connection Policy]. (“HTTP” is selected as default.)
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Basic authentication settings
Basic authentication is provided to permit or prohibit access from guest users.
Use basic authentication to prohibit access from guest users.

1. Display the [Setup] window.
* If basic authentication is not used, pressing the [Setup] button displays the dialog box shown in step 3 of “Access from the 

Computer” page 1-13. Enter a user name and password.
2. On the menu on the left of the screen, click [Basic Configuration Instructions] → [Users].
3. If the checkmarks are not selected for the options under [User Settings], basic authentication is required for the network 

camera.

* When using basic authentication, make the following settings in the V-SFT software. As shown below, select the [Use 
authentication setting] checkbox and enter a registered user ID and password in the [Network Camera Display] window. 
For details on registered user names and passwords, refer to “Checking and registering user names and passwords” page 
1-16.

4. If basic authentication is not necessary, select the [Enable anonymous viewer login (no user name or password required)] 
checkbox under [User Settings] and click the [Save] button.

* When performing camera lens operations from the TSi unit or PLC, select the [Enable anonymous PTZ control login (no 
user name or password required)] checkbox and click the [Save] button. For details, refer to “Operating the Camera Lens 
from the TSi Unit” page 1-17.
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Checking and registering user names and passwords
1. Display the [Setup] window.

* If basic authentication is not used, pressing the [Setup] button displays the dialog box shown in step 3 of “Access from the 
Computer” page 1-18. Enter a user name and password.

2. On the menu on the left of the screen, click [Basic Configuration Instructions] → [Users].
3. If users have been registered, they are displayed under [User List].
4. To add a new user, click the [Add...] button. To modify an existing user, click the [Modify...] button.

5. The [User Setup] window is displayed.
Enter the desired name for [User name] and enter the same password for [Password] and [Confirm password].

6. Click [OK] to accept the settings.

Check [Administrator] for [User group].
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Operating the Camera Lens from the TSi Unit
The camera lens can be operated using switches and command device memory addresses on the TSi unit.

With basic authentication
Display the [User Setup] window* and select the [Enable PTZ control] checkbox.

* For details on how to display the [User Setup] window, refer to “Checking and registering user names and passwords” 
page 1-16.

Without basic authentication
Display the [Users] window*. Select both checkboxes under [User Settings] and click the [Save] button.

* For details on how to display the [Users] window, refer to “Basic authentication settings” page 1-15.
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1.2.6 Panasonic (Example: BB-HCM580)
Access from the Computer
This network camera can be accessed from a computer using the CD-ROM included with the network camera or via a web 
browser.

* Select the method using the CD-ROM when setting up the network camera for the first time.

CD-ROM
1. Load the CD-ROM included with the network camera into your computer.
2. The [Network Camera] window is displayed. Click [Search for Cameras] to search for the network camera connected to the 

computer.

3. If the following message appears, click [OK].

4. When the target network camera is found, information regarding the network camera, such as MAC address and IP 
address, is displayed in the [Easy Setup] window. Click [Access Camera] *.

* If the IP address of the network camera does not exist in the network group of the computer, click the [Network Settings] 
button. In the window to be displayed, change the IP address of the network camera so that it belongs to the network 
group of the computer.
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5. When connecting a factory-default network camera to your computer, the [Initial Authentication Setting] screen appears.
Register a user name and password for the administrator. (If a user is already registered, proceed to step 6.)
For details, refer to the user’s manual of the network camera.

6. The authentication dialog box is displayed. Enter an administrator-level user name and password and click [OK].
* When [Permit access from guest users] is checked on the [Administrator] page, the [Top] tab window is displayed. Click 

the [Login] tab. For details, refer to “Authentication settings” page 1-22.

7. The [Top] tab window is displayed.
(This tab window is displayed when login authentication is performed with an administrator-level user name and 
password. When a general or guest user logs in, the menus in the displayed tab window vary slightly.)

The password registered in this step is required for access to the network camera.
Take appropriate measures to avoid forgetting the password.
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Web browser (Microsoft Internet Explorer)
1. Start up Microsoft Internet Explorer on your computer.
2. Enter the IP address and port number of the network camera in the address field.

* When using the factory-default port number of 80, the entry of the port number may be omitted.

3. The authentication dialog box is displayed. Enter an administrator-level user name and password and click [OK].
* When [Permit access from guest users] is checked on the [Administrator] page, the [Top] tab window is displayed. Click 

the [Login] tab. For details, refer to “Authentication settings” page 1-22.

4. The [Top] tab window is displayed.
(This tab window is displayed when login authentication is performed with an administrator-level user name and 
password. When a general or guest user logs in, the menus in the displayed tab window vary slightly.)

http://xxx.xxx.xxx.xxx
Network camera IP address

:Port number/
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Network Camera Settings
Checking and changing the IP address

* Login with an administrator-level user name and password is required to proceed to the following tab window 
settings.

1. Click the [Setup] tab.
2. Check that [Network (IPv4)] is selected in the [Basic] menu at the left of the window. Next, go to the [Connection Mode] 

area and click [Static].

3. Configure the network camera port number*, IP address, subnet mask, and gateway settings.
* The default port number is 80. Enter a port number between 1 and 65535.

* Also enter the port number for [Port No.] in the [Network Camera Display] window in V-SFT. Refer to page 1-9.

4. Click [Save] to save the settings made in the previous steps.
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The IP address can be checked or changed using the CD-ROM included with network camera or via the [Network Settings] 
button in the [Easy Setup] window.

Authentication settings
Authentication settings are provided to permit or prohibit access from guest users.
These settings disallow access to guest users.

* Login with an administrator-level user name and password is required to proceed to the following tab window 
settings.

1. Click the [Setup] tab.
2. Click [Administrator] at the left of the screen.
3. In the [General Authentication] area, select either [Permit access from guest users] or [Do not permit access from guest 

users].

Permit access from guest users This option allows anyone to access the network camera without a registered user name and 
password.

Do not permit access from guest users Whenever access to the network camera is attempted, the authentication dialog box appears. 
Access is granted to the network camera by entering a registered user name and password.
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* When the [Do not permit access from guest users] checkbox is selected, configure the following settings in the V-SFT 
software. As shown below, select the [Use authentication setting] checkbox and enter a registered user ID and password 
in the [Network Camera Display] window. For details on registered user names and passwords, refer to “Checking and 
Registering User Names and Passwords” page 1-26“.

4. Click [Save] to save the settings made in the previous steps.
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Registering and changing the settings of general users
When users other than the administrator need access to the network camera, general user registration is required.

* Login with an administrator-level user name and password is required to proceed to the following tab window 
settings.

New general user registration
1. Click the [Setup] tab.
2. Click [General User] on the left of the screen.
3. Click [Create].

4. The [New General User Registration] page is displayed. Configure the settings as specified below.

5. Click [Save] to save the settings made in the previous steps.

The password registered in this step is required for access to the network camera.
Take appropriate measures to avoid forgetting the password.
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Changing guest user settings
The following settings can be configured when the [Permit access from guest users] checkbox is selected.
Configure the functions available when the network camera is accessed without authentication with a user name and 
password in the following tab window.

1. Click the [Setup] tab.
2. Click [General User] on the left of the screen.
3. Check that [Guest User] is selected and then click [Modify].

4. The [Modify Guest User] page is displayed. Configure the settings as specified below.

5. Click [Save] to save the settings made in the previous steps.
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Checking and Registering User Names and Passwords

In a case when the [Do not permit access from guest users] checkbox is selected in the [General Authentication] area, the user 
name and password registered for the administrator or a general user in the network camera setting tab window must be set 
in the V-SFT software.
For details on the authentication settings, refer to “Authentication settings” page 1-22.

* Login with an administrator-level user name and password is required to proceed to the following tab window 
settings.

Administrator
1. Click the [Setup] tab.
2. Click [Administrator] at the left of the screen.
3. Check the settings in the [Input User Name and Password] area.
4. If any changes are made to these fields, click [Save] to save the changes.

General users
1. Click the [Setup] tab.
2. Click [General User] on the left of the screen.
3. Select the target user name from the [User ID List].
4. Click [Modify].

When a password has already been registered, the [Password] field is blanked out.
Take sufficient care when managing passwords. If you forget the password, a password newly registered is 
usable for authentication.
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5. Check the settings in the [Input User Name and Password] area.

6. If any changes are made to these fields, click [Save] to save the changes.

Image Display Settings
* Login with an administrator-level user name and password is required to proceed to the following tab window 

settings.

1. Click the [Setup] tab.
2. Click [Image Display] at the left of the screen.
3. Configure the settings as specified below.

* Note that these settings will be overwritten while the TSi unit is communicating with the network camera. Because 
overwriting is likely to be time-consuming, it is recommended to configure these settings in advance.

4. Click [Save] to save the settings made in the previous steps.
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1.2.7 BANNER (Example: PresencePLUS P4 OMNI)
Access from the Computer
When accessing a sensor from a computer, use the “PresencePLUS” dedicated sensor software.
The CD-ROM provided with the sensor includes this software. Load the CD-ROM into the computer and install the software.
For details on the installation procedure, refer to the manual issued by BANNER.

1. Start the “PresencePLUS” software.
2. The [System Setup] window is displayed. When a connected sensor is found, the information on the sensor, including IP 

address and MAC address, appears in the window. Select the desired sensor listed under [Sensor Neighborhood] with the 
cursor and click [Change Sensor IP Address].

3. The [Select Ethernet Adapter] window is displayed. Select the Ethernet adapter of the computer and click [Next].



1.2    Network Camera

1-29

1

2

3

4

5

6

7

8

9

10

4. The [Set Sensor IP Address] window is displayed. Change the sensor’s IP address and subnet mask settings as necessary 
and click [Finish].

5. Click [OK] in the [System Setup] window to close the window.
6. When a connection between the computer and the sensor is established, the monitor screen is displayed on the 

computer.

The sensor is reset in this step.

* Make sure that the computer network 
group and the sensor IP address are on 
the same network.
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Sensor Settings
Port number setting
1. Click the [Tools] menu button.
2. Click the [Analysis] tab → [Communication].

3. The [Communication Tool] menu opens. Enter an arbitrary name for [Name] and select [Image] under [Select].

4. In the [Connection(s)] section, select an Ethernet socket number. The sensor port number corresponding to the selected 
socket number is used for connection with TSi unit.
To see more information on each Ethernet socket number, display the [Connection Detail] window by clicking [View 
Settings].

Socket No. Port No. (Fixed)
Ethernet socket 1 20000
Ethernet socket 2 20001
Ethernet socket 3 20002
Ethernet socket 4 20003
Ethernet socket 5 20004
Ethernet socket 6 20005 * The sensor port number corresponding to each 

Ethernet socket number is fixed.Ethernet socket 7 20006
Ethernet socket 8 20007
Ethernet socket 9 20008
Ethernet socket 10 20009
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5. In the [Resolution] section, select the size of the image to be displayed on the TSi unit.

* The size of images captured with the sensor is based on 640 x 480 pixels (default). When changing the size, refer to the manual issued by 
BANNER.

6. Click [Next] to exit the menu.
* Repeat steps 2 to 5 when connecting multiple TSi units. (Maximum of 10 sensors.) Only one TSi unit can be connected per 

sensor port number.

RUN
1. Click the [Run] menu button.

2. The [Save Inspection] window is displayed. Select “Sensor” for [Save in].
Enter an [Inspection Number] and [Inspection Name] for registration and click [Save].

Resolution Description *
1:1 Display at actual size (640 × 480 pixels)
4:1 Display at a half of the size (320 × 240 pixels) of the width and height of 1:1 resolution
16:1 Display at a quarter of the size (160 × 120 pixels) of the width and height of 1:1 resolution
64:1 Display at an eighth of the size (80 × 60 pixels) of the width and height of 1:1 resolution

Example
Inspection Number: 3
Inspection Name: LINE.ins
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3. Click the [Select] tab in the [Run] menu, go to [Hardware Input], and select the name that was entered for [Inspection 
Name] in step 2.

4. Click the [Monitor] tab → [Start].

The settings in the [Run] menu are complete.
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1.2.8 Restrictions
All Manufacturers

• The display size depends on the resolution of the network camera or sensor. If a display area placed on the screen is 
smaller than the resolution of the network camera or sensor, captured images displayed in the area are partially cut off.

• Captured images from multiple network cameras cannot be simultaneously displayed on the same layer (screen, overlap 
etc.). If multiple camera images are placed, only the first area displayed will be active. Displaying camera images from 
multiple network cameras or sensors is possible by switching between screens.

• In the case where an overlap containing a network camera/sensor display is called up while a network camera/screen 
display is shown on the screen, only the display on the overlap will be active.

AXIS and Panasonic
• The focus and brightness of images captured by a network camera are automatically adjusted.
• With no basic authentication, size and rotation settings configured for a network camera on the screen are invalid. The 

previously configured size and rotation settings take effect for the display of images captured with the network camera.

BANNER
• Focus and brightness of sensor images are not automatically adjusted. Sensors do not support these automatic 

adjustments.
• The resolution of snapshot files saved on the TSi unit depends on the [Snap Setting] set for the network camera or sensor.
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2.1 Overview
2.1.1 Operation Log

Operation Overview
The operation log function stores screen operation history records (operation logs) in the SRAM area. When the SRAM area 
becomes full, logs can be output to a storage device such as an SD card or a USB flash drive.
In the event of an error, these stored logs allow previous operations to be examined in order to determine the cause of the 
error. Also, when used in conjunction with the security function, operator names can also be recorded.

Operation Log Viewer
Operation history records (operation logs) stored in the SRAM area can be displayed on MONITOUCH using the operation log 
viewer.
The details of operations that were performed when an error occurred can be easily examined in order to determine the cause 
of the error.

For details on the log viewer, refer to “2.5 Operation Log Viewer”page 2-9.

SD

SD
35.2

DATA ENTRY

0 . +/- ENT

1 2 3 CLR

4 5 6 DW

7 8 9 UP

SD
1 4

2 5

3 6

MENU

10.5

DATA ENTRY

0 . +/- ENT

1 2 3 CLR

4 5 6 DW

7 8 9 UP

SRAM

1 Power ON

2 Screen changeover

3 Numerical data entry

Screen 0

Screen 5

1 20160601085506 Start
2 20160601090320 Screen change  Entry screen  05   
3 20160601090510 Update of the displayed 5 data items   

Numerical data display  DEC   10.5   35.2

Tap

Log details are displayed.
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Log Storage
When the SRAM area becomes full, logs are written to a storage device. In addition to the logs stored in the SRAM area, the 
log files output to a storage device can also be displayed in the log viewer.
Log files written to a storage device are in binary format. The dedicated “LogToCsv” tool can be used to convert such log files 
to CSV files so their contents can be viewed.

SD
1 4

2 5

3 6

MENU

OPELOG.BIN

Operation log viewer

Tap the file change switch to switch the 
display from data in SRAM to backup data 
on the SD card.

Binary files are backed up to the SD card according to the 
time they were output and saved.

Binary format files in SRAM are 
output to the SD card.

A dedicated “LogToCsv” tool can be used to convert log files to CSV files.
For details, refer to “2.6.3 Importing Log Data to Computer (Conversion to CSV Files)” page 2-13.
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2.2 Using the Operation Log Viewer
2.2.1 Conceptual Operation

2.2.2 Setting Procedure
1. Click [System Setting] → [Other] → [Operation log Setting]. The [Operation log setting] window is displayed.
2. Select the [Use operation log function] checkbox and select the checkboxes of the relevant items under [Log objects].
3. Set any other relevant settings and select the [Operation log viewer] checkbox.

Specify a screen number (default: 9999) to which the operation log viewer is to be registered.

4. Click [OK].
5. Place the switch used to read the operation log viewer screen ([Function: Screen]).

* When [Switch] is selected under [Log objects], the [Save operation log] checkbox must be selected in the settings window 
of any switches targeted for logging. (Default: selected)

This completes the necessary settings. The screen program can be transferred to MONITOUCH.

Operation log viewer

Press a switch

The operation log viewer is displayed.
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2.3 Applicable Items
2.3.1 Applicable Items and Saving

Applicable Items and Timing of Saving
The table below shows the items that can be saved to operation logs and when saving to SRAM takes place.

*1 Logging does not take place when transferring system programs of MONITOUCH.
*2 Logs can be saved for switches when the [Save an operation log] checkbox is selected in the [Detail] settings of the item’s settings 

window. (Default: selected)

*3 Table data display is not supported.

Items Timing of Saving
Start When power is turned ON
Transfer When transferring a screen program or the I/F driver *1

Mode changeover When changing between RUN mode and local mode
Screen changeover When changing between screens
Language changeover When changing between languages
Switch When a switch with any of the following functions is pressed. *2

Data display update *3 When updating numerical data/character displays in entry mode (Write/↓/↑ keys)
Storage Writing Error When an error occurs during writing to a storage device

* 1024 words are used in SRAM. The words in use are added and displayed at [Unit Setting] → 
[SRAM/Clock Setting] → [Operation log storage point].

Log destruction When newly storing log data after clearing the SRAM area due to the reasons below:
• SRAM data corruption
• Failure to output to storage device

With output device memory Momentary, Set, Reset, Alternate, Momentary W, Word 
Operation

Function Standard Screen, overlap display, multi-overlap display, reset, storage 
device formatting (buffer), storage device removal, language 
changeover

Entry Delete (alarms only)
Memory Card Card format, transfer card → PLC, transfer PLC → card
Digital switch Digital switch +, digital switch −
JPEG File deletion
Security Login/Logout
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Saved Items (Titles)
The following item types are saved.

Start

Details of items are as follows:

Transfer

Details of items are as follows:

Mode Changeover

Details of items are as follows:

Saved Item (Title) Description Max. No. of Characters 
(Bytes)

No. Log No. -
Date Log acquisition date -
Time Log acquisition time -
Scrn_No Screen number (0 to 9999) -
User_ID User ID registered in security settings 8
Level Security level (0 to 15) -
Action (Differs depending on the log item. For details on the saved content for each item, 

refer to the sections below.)
-

Function (Differs depending on the log item. For details on the saved content for each item, 
refer to the sections below.)

-

Comment Comments on screens and parts 32
Type Display format of numerical data displays -
Prev_Val Value before change -
Chg_Val Value after change -

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - - - - - - -

Action Start

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - - - - - -

Action Transfer
Function Screen program

Driver, expansion program

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - - - - - -

Action Mode changeover
Function Change to RUN mode

Change to Local mode
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Screen Changeover

Details of items are as follows:

Language Changeover

Details of items are as follows:

Switch

Details of items are as follows:

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - -

Action Screen changeover
Comment The comment entered in the [Screen Setting] → [Screen Setting] window is stored. 

When no comment is entered, the [Comment] field is blank.

Prev_Val Stores the screen number before changeover.
Chg_Val Stores the screen number after changeover.

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - - -

Action Language changeover
Prev_Val Stores the language number before changeover.
Chg_Val Stores the language number after changeover.

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - -

Action Switch operations (Mom)/(Set)/(Rst)/(Alt)/(Word)/(Sample)/(Alm)
Function Standard Screen

Overlap display, multi-overlap display
Word operation
Reset
Storage device formatting (buffer), storage device removal
Language selection

Entry Delete (alarms only)
Memory Card Transfer card → PLC, transfer PLC → card

Card format
Digital switch Digital switch +, digital switch -
JPEG File delete
Security Login, logout

Comment The text entered in the [Char. Prop.] window → [OFF] tab in the switch settings window is 
stored.
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Data Display Update (Numerical Display, Character Display)

Details of items are as follows: (Log output is not supported for table data displays.)

Storage Writing Error

Details of items are as follows:

Log Destruction
A log is saved when the SRAM area is cleared and newly saving logs because of SRAM data corruption or failure to output to 
the SD card. The log contains the data items below.

Details of items are as follows:

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val

Action Data Display Update
Function Numerical display

Character display
Comment Outputs the comment in the numerical data display’s and character display’s settings 

window.

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - - - - -

Action Writing error detection
Function Power OFF

Card removal
Comment The directory path of the drive or file where an error has occurred is output.

• Error when accessing SD card: “Drive name:\Directory Information”
Example: For built-in socket: “C:\Directory Information”

• Error when accessing files: “Drive name:\Full path”*
Example: When an error occurred during writing of “REC0000.CSV” in recipe 

mode
C:\DAT0000\RECIPE\REC0000.CSV

* When the number of characters exceeds 32 one-byte characters (16 two-byte 
characters), the top of the pathname is omitted and displayed as “..”.
Example: C:\..\RECIPE\REC0000.CSV

No. Date Time Scrn_No User_ID Level Action Function Comment Type Prev_Val Chg_Val
- - - - - - - -

Action Log destruction
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2.4 Detailed Settings
Configure the detailed settings at [System Setting] → [Other] → [Operation log Setting].

*1 The required amount of SRAM is automatically secured based on the [SRAM save number] setting.

*2 Control Device

Item Description
Use operation log function Select this checkbox to use the operation log function.
Log objects Select the checkboxes of the items to save to operation logs.

For details, refer to “2.3 Applicable Items” page 2-4.
SRAM save number *1 Set the number of logs to be stored in the SRAM area. (100 - 512)
Storage Connection Target Select how to connect the storage device to which operation logs will be output.
Action to be taken when store target 
capacity is not enough

Select the action to take when the storage device is full.

Control Device *2 Set the device memory for outputting log data to the storage device.
Screen registration Select this checkbox to use the operation log viewer. Select a screen number to which an 

operation log viewer (= component part) is to be registered.

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Control device 
memory

Reserved for system Storage output bit
0 → 1 (edge): Output SRAM log data to storage device
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2.5 Operation Log Viewer
This section explains the log viewer screen.

Showing/Hiding Logs
Tap the [Select logs] switch in the operation log viewer. The following window is displayed.
Logs not to be displayed can be hidden by turning off the corresponding switches.

Example: Hiding logs other than [Transfer] and [Switch]

Changing the display 
page
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Showing/Hiding Items and Changing Width (No. of Characters) 
and Date/Time Format
Tap the [Setting] switch in the operation log viewer. The following window is displayed.

• Unnecessary items can be set to “Hide”.

• The width ([Letter counts]) can be changed as needed.

Changing the 
display page

Example: Hiding the [User_ID], [Level], and [Type] items

Changing the 
display page
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• The display format of the date and time ([Date] and [Time]) can be changed.

Changing the 
display page



2  Operation Log

2-12

2.6 Log Data
2.6.1 Output Timing

Log data is first output to SRAM. Subsequent log data in SRAM may be output to a storage device depending on the 
condition of SRAM. This section explains the timing of output.

SRAM
For information on the output timing of each item, refer to “Applicable Items and Timing of Saving” page 2-4.

Storage Device
Log data in SRAM is output to the storage device at the following timings.

• When the area defined by [SRAM save number] in the [Operation log setting] window is full
• When the “card output bit” defined for [Control Device] in the [Operation log setting] window turns ON
• When a switch with [Storage Removal] set for [Function] is pressed

2.6.2 Details of Output (File Type)
SRAM
Log data is stored in the SRAM area in binary format. A maximum of 64 KB of the SRAM area is used for log data and up to 
512 logs can be stored. The SRAM data is cleared after output to a storage device.

Storage Device
The directory and file type when outputting to a storage device is as follows.

Directory Filename
Access folder\OPELOG\YYMMDD OPELOG_hhmmss.BIN

Year, month, and day Hour, minutes, and seconds

BITMAP

OPELOG

DAT0000

OPELOG_103005.BIN
OPELOG_141002.BIN
OPELOG_204250.BIN

160501

160502
160503

Access folders
Storage Device

Operation logs
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2.6.3 Importing Log Data to Computer (Conversion to CSV Files)
A log file output to a storage device can be converted to a CSV file for viewing using the dedicated “LogToCsv“ tool.
“LogToCsv.exe“ is installed when V-SFT version 6 (Ver. 6.0.8.0 or later) is installed.
If the version of your V-SFT version 6 is an earlier one, download “LogToCsv.exe“ from Hakko Electronics’ website and install.

File Conversion Procedure
1. Click the start button and start “LogToCsv“ from [All Programs] → [V-SFTV6].

2. Click the [Open] button for [Source file] and select the log file to convert. (Extension: *.bin)

3. Click the [Open] button for [Target file] and specify the location for storing the CSV file and the filename.

4. Click the [Convert] button. A conversion complete message is displayed and the CSV file is output to the specified 
location.

Select the “*.bin” extension.
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5. Open the CSV file.
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2.7 System Device Memory
• The following describes the system device memory associated with operation logs.

Device Memory Description Remarks
$s1050 Storage device processing flag ← TS

$s1051 Storage device processing completion flag ← TS

$s1052 Storage device processing error flag

* Errors that occur related to operation logs are “write errors”.
For details on the inserted state of storage devices, refer to $s1030/1035.

← TS

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0

MSB

Hard copy
0: Not processed
1: Processing

Reserved for system (setting: 0)

LSB

Sampling
0: Not processed
1: Processing

Operation logs
0: Not 
processed
1: Processing

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0

MSB

Hard copy
0: Not completed
1: Completed

Reserved for system (setting: 0)

LSB

Sampling
0: Not completed
1: Completed

Operation logs
0: Not completed
1: Completed

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0

MSB

Hard copy
0: Normal
1: Error

Reserved for system (setting: 0)

LSB

Sampling
0: Normal
1: Error

Operation logs
0: Normal
1: Error
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• The following describes the system device memory associated with the operation log viewer.

* When the log data in SRAM is displayed, 0 is stored at both addresses $s1365 and $s1366.
When a log file on a storage device is displayed, the files and folders stored on the storage device are numbered 
sequentially, starting at 1, from the file with the most recent date stamp.
The following illustrates the numbering of files and folders.

Addresses Description Remarks
$s1365 File number of currently displayed log data

← TS
$s1366 Log folder number being displayed

BITMAP

OPELOG

DAT0000

OPELOG_103005.DB
OPELOG_141002.DB
OPELOG_204250.DB

160501

160502
OPELOG_091050.DB
OPELOG_113821.DB

Folder number
File number

Storage Device

2

1

3
2
1

2
1
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3.1 Overview
Security
Registering user IDs and passwords at the required security levels in advance enables operators to control the display and 
operation of screens in accordance with their corresponding security level.

* Security levels are set on a scale from 0 to 15.

Screen Security Levels
A security level can be set for each screen. An attempt to switch to a higher-security screen will automatically display the login 
screen. The target screen can be displayed by entering a user ID and password at a level equivalent to or higher than the level 
required for the target screen.

For details on the location of settings, refer to “Screen Settings” page 3-6.

Security Level Priority Description
0 Low Screen display and operation permitted at level 0 (no security)
1 Screen display and operation permitted at levels 0 and 1

: :

15 High Screen display and operation permitted at all levels from 0 through 15

MENU
Level 0

Level 5

MENU
Level 0

Change to screen 1

Screen 0: Level 0

Screen 1: Level 5

The login screen appears due to 
the difference in security level.

After operator B (security level 10) logs in, 
the specified screen is displayed.

After operator A (security level 2) 
logs in, the message “Level does not 
match.” is displayed.

Pressing [CANCEL] returns to the 
previous screen.



3  Security

3-2

Item Security Levels
Security levels can be set for each item on the screen, such as switches and data displays.
Once security levels are specified for screen items, these items can be shown or hidden based on the security level selected 
when an operator logs into the system. Also, switches can be configured with an interlock setting.

Showing/Hiding Items

Prohibiting Switch Operations

For details on the location of settings, refer to “[Show/Hide] Settings in the Settings Window of Each 
Part” page 3-7.

For details on the location of settings, refer to “[Interlock] Settings in the [Switch] Settings Window” 
page 3-8.

Login

Login

Items at level 10 or lower are shown.

Operator A
Security level 2

Operator B
Security level 10

Login

Level 1 items
Level 10 items

Items at level 2 or lower are shown.
Items at level 3 or higher are hidden.

Items at level 10 or lower are operative.Items at level 3 or higher are inoperative.
Items at level 2 or lower are operative.

Operator A
Security level 2

Operator B
Security level 10

Level 1 items
Level 10 items

Login

Login

Login
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Login, logout
The security level can be changed by logging in or out with the screen that is automatically displayed when a screen change 
occurs as well as by a switch operation.

Login
The security level can be changed using a switch with [Log In] set for [Function].

* Login is prohibited for users with a security level lower than that of the currently displayed screen. If such an attempt is 
made, the message “Level does not match.” appears.

For details on settings, refer to “3.4 Login/Logout” page 3-9.

Level 1

Level 4

NG

OK

The login screen is displayed.
Enter a user ID and password with security 
level 4.

Press the [Login] switch.

An error message is 
displayed.
Pressing [Cancel] returns to 
the previous screen with the 
security level unchanged at 
level 1.

The security level is raised to level 4 
and the previous screen is 
displayed again.

Login

Login
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Logout
The security level is set to zero (0) when a switch with [Log Out] set for [Function] is pressed.

* When logout is executed, the security level is set to zero (0); however, the same screen remains displayed even after 
logging out.
To change over the screen at the time of a logout, log out on a lower-security screen or use the SET_SCRN macro 
command (for screen number change) together with a logout.

Level 4

Level 0

Logout

Security level 4

Logout

Security level 0
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3.2 Security Settings
Location of settings: [System Setting] → [Other] → [Security Setting].

*1 When the currently displayed screen is switched to a lower-security screen, the security level may be maintained or automatically lowered, 
depending on the selected option.

Item Description
Use security function Select this checkbox to use the security function.
UserID
Password
Level

Register user IDs, passwords, and security levels using the [Add], [Delete], and [Change] buttons.
A maximum of 64 users can be registered.
Use eight or less one-byte alphanumeric characters. Input is case-sensitive.

* The same user ID cannot be registered more than once. However, the same password can be registered 
for different user IDs.

Maintain original security 
level when opening lower 
security level screen(s) than 
original security level *1

Select the operation to perform when a screen change occurs.
Unselected

When switching to a screen with a lower security level, the currently valid security level is also lowered to 
the level of the target screen. When switching to a higher-security screen next, the operator is prompted 
to enter a password.

Selected
The same security level is maintained until the level is changed when another user logs in with a different 
security level or when the user logs out.

Screen registration
Login

Register a login screen.
Default: Unregistered, maximum screen number

MENU
Level 0

Level 5

Security level 5 Security level 0

Screen 1: Level 5 Screen 0: Level 0

• Level lowered

Security level 5 Security level 5• Level maintained

* The operator must log in again in order to switch to a higher-security screen.

* The security level is maintained until a login or logout is performed.
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3.3 Security Level Settings
The security level can be set at the following three locations. The setting procedure at each location is different.

• Screen settings (page 3-6)
• [Show/Hide] settings in the settings window of each part (page 3-7)
• [Interlock] settings in the [Switch] settings window (page 3-8)

Screen Settings
Screen switching can be prohibited according to security level.

Location of settings
[Screen Setting] → [Screen Setting] → [Main] tab window → [Security Level] setting
Security level: 0 to 15
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[Show/Hide] Settings in the Settings Window of Each Part
Screen items can be shown or hidden according to their security level.

Applicable items
The following items can be configured with security level settings.

• Switches, lamps
• Numerical data displays, character displays, message displays (excluding table data displays)
• Graphs, statistical graphs, closed area graphs
• Linked parts
• Grouped items (including graphic items)

Location of settings
In the setting window of each part, set the security level at [Show/Hide] → [Show/hide according to the condition] → 
[Security Level].
Security level: 0 to 15
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[Interlock] Settings in the [Switch] Settings Window
The operation of switches can be prohibited according to their security level.

Location of settings
In the switch settings window, set the security level at [Interlock] → [Security Level].
Security level: 0 to 15
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3.4 Login/Logout
The security level can be changed by logging in or out with the screen that is automatically displayed when a screen change 
occurs as well as by a switch operation.

Location of Settings
Configure the following settings at [Parts] → [Switch] → [Function].

Item Description
Function Log In

Display the login screen registered at [System Setting] → [Other] → [Security Setting].

Log Out
Change the security level to zero (0).

The screen does not change after logging out. When logging out on a low security level screen or using a 
switch, use in conjunction with the SET_SCRN macro (for screen number change) to change the screen when a 
user logs out.
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3.5 System Device Memory ($s)
The following system device memory are associated with the security function.

Device Memory Description
$s1360 Stores the current security level (0 to 15) specified when an operator logs into the system.
$s1361

Stores the user ID of the operator who is currently logged into the system.
$s1362
$s1363
$s1364
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4.1 Preface

4.2 TSi Unit IP Address Settings

4.3 Screen Program Transfer

4.4 PLC Communication

4.5 Transferring Data Between TSi Units (Macro)

4.6 DLL Communication

4.7 MES Interface Function

4.8 E-mail Notification

4.9 FTP Server

4.10 Remote Desktop

4.11 Web Server

4.12 VNC Server
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4.1 Preface
4.1.1 List of Functions

The TSi features the following Ethernet functions.
An IP address for the TSi unit must be configured in order to use the Ethernet functions. Refer to “4.2 TSi Unit IP Address 
Settings” page 4-2.
Other settings differ depending on the function to be used.

*1 For details on selecting TCP/IP and UDP/IP for PLC communication, refer to the TS2060 Connection Manual or the TS1000 Smart 
Connection Manual.

*2 The network table settings must be configured in the screen program settings.
*3 When using the SEND command, the network table settings must be configured in the screen program settings.

Function
TS2060i TS1100Si/TS1070Si TS2060/TS1070

Refer to
LAN CUR-03 LAN CUR-03 LAN CUR-03

Screen program transfer page 4-6
Simulator

PLC communication *1 TCP/IP TS2060 Connection 
Manual
TS1000 Smart 
Connection Manual

UDP/IP

Ladder transfer “9 Ladder Transfer”

Macro *2 EREAD/EWRITE V8 Series Macro 
Reference ManualMES/SEND

DLL communication HKEtn20.dll *3 DLL Function 
Specifications

VCFAcs.dll
FTP server page 4-45
E-Mail page 4-40
Network camera 1.2 Network Camera
Remote desktop page 4-54
Web server page 4-69
VNC server page 4-80
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4.2 TSi Unit IP Address Settings
An IP address for the TSi unit must be configured in order to use the Ethernet functions. There are two ways to configure the 
IP address of the TSi unit: setting using the V-SFT editor or setting using Local mode on the unit.

4.2.1 Setting Using the V-SFT Editor
Set the IP address in the screen program.

1. Select [System Setting] → [Ethernet Communication] → [Local Port Address]. The [IP Address Setting] window is 
displayed.

2. Select the [Set IP] checkbox and configure each setting.

* For details on these settings, refer to page 4-4.

3. Click [OK].
4. Transfer the screen program to the TSi unit.
5. Check the IP address via the [Main Menu] on the unit.

Item Description
Select IP Address from Network Table This setting is available when the IP address of the TSi unit has been registered in the 

network table. Select a network table number from 0 to 99 to set the IP address.
IP Address * Set the IP address for the TSi unit.
Default Gateway * Set the default gateway.
Subnet Mask * Set the subnet mask.

When this checkbox is not selected, the subnet mask is automatically assigned based on 
the first byte of the IP address.
When the IP address is “172.16.200.185”, “255.255.0.0” is set.
When IP address is “192.168.1.185”, “255.255.255.0” is set.

Port No. * Set a port number (1024 to 65535). (except for “8001”)
Send Timeout Set a timeout period for transmitting macro commands EREAD, EWRITE, SEND, MES or 

Ethernet DLL functions.
Retrials 0 to 255

Set the number of retries to be performed when a timeout occurs.
Device Protect

Internal Device
Memory Card Device

Select these checkboxes to write-protect the corresponding device memory from PCs or 
other stations.
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4.2.2 Setting the IP Address via the Main Menu
Set the IP address via the Main Menu.

1. Press the [SYSTEM] function switch on the unit to display the MODE menu.
2. With the MODE menu displayed, press the [F1] switch. The Main Menu screen is displayed on the unit.

3. Press the [Main Menu] switch at the upper left corner of the screen to display the menu.
4. Press the [Ethernet] switch to display the [Ethernet] screen.

5. Press the [Ethernet] switch, press the [EDIT] switch, and then configure each setting.

6. Press the [Setting Finished] switch to confirm the setting. Check the IP address on the [Ethernet Information] screen.
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4.2.3 Ethernet Terminology
IP Address
This address is used for recognizing each node on the Ethernet network and must be unique.
An IP address is 32-bit data that consists of a network address and a host address, and is classified as A to C depending on the 
network size.

Notation
Data consisting of 32 bits is divided into four segments in decimal notation and each segment is delimited with a period.

Example: The following class C IP address is represented as “192.128.1.50”.
11000000  10000000  00000001  00110010

Unusable IP addresses
• “0” is specified for the first byte, e.g. 0.x.x.x
• “127” is specified for the first byte (which is reserved as the loop back address), e.g. 127.x.x.x
• “224” or more is specified for the first byte (which is reserved for multi-casting or experiments), e.g. 224.x.x.x
• The host address consists of only “0” or “255” (broadcast address), e.g. 128.0.255.255, 192.168.1.0

Port No.
Multiple applications run on each node and communications are carried out for each application between the nodes. 
Consequently, it is necessary to have a means to identify the application that data should be transferred to. The port number 
works as this identifier. While the range of port numbers is 0 to 65535, the lower port numbers of 0 to 1024 are generally 
reserved for other uses. When assigning port numbers, use numbers higher than 1024.

TSi port numbers
The following port numbers are used on the TSi unit. When changing any port number, select an unused number from the 
range of 1024 to 65535.

Port No. Setting Range Function Location of Settings
20 Fixed FTP server -
21
80 Fixed Web server -
502 502,

1024 - 65534
Modbus slave (TCP/IP) -

1024 - 1025 1024 - 65534 Ladder transfer via 
Ethernet

[System Setting] → [Hardware Setting] → [Ladder Transfer]

1969 1024 - 65535 Network camera (BANNER) -
5900 Fixed VNC server -
8001 Fixed Screen program transfer *1 Screen program transfer *1

8020 1024 - 65535 Simulator (Ethernet) -
8050 1024 - 65535 Remote desktop window 

display
[System Setting] → [Other] → [Remote Desktop Table Setting] → [Local 
Port No.]

10000 1024 - 65535 Ethernet macros
EREAD, EWRITE, SEND, 
MES

Set in the editor
“Setting Using the V-SFT Editor” page 4-2

Set on the unit
“Setting the IP Address via the Main Menu” page 4-3Ethernet DLL functions

HKEtn20.DLL
VCFAcs.DLL

10001 - 10008 1024 - 65535 8-way communication [System Setting] → [Hardware Setting]→ [Communication Setting] → 
[Port No.]

10021 - 10028 1024 - 65535 8-way communication MITSUBISHI ELECTRIC L series (built-in Ethernet) connections only
A port number that is 20 higher than the port number set at [System 
Setting] → [Hardware Setting] → [PLC Properties] → 
[Communication Setting] → [Port No.] is secured automatically.

50000 - 50002 1024 - 65535 Network camera
(AXIS/Panasonic)

-

0

1 0

1 1 0

Class A Network address 
(7 bits)

Host address (8 bits)

Host address (24 bits)

Network address (14 bits) Host address (16 bits)

Network address (14 bits)

Class B

Class B
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*1 When transferring screen programs over the Internet, specify the router port number in the [Transfer] window of the V-SFT software.

Default Gateway
A gateway and a router are used for communication between different networks.
The IP address of the gateway (router) should be set to communicate with the node(s) on other networks.

Subnet Mask
A subnet mask is used for dividing one network address into multiple networks (subnets).
A subnet is assigned by specifying a part of the host address in the IP address as the subnet address.

Unusable subnet masks
• When all bits are set to “0”, e.g. 0.0.0.0
• When all bits are set to “1”, e.g. 255.255.255.255

64000 1024 - 65535 Multi-link2 (Ethernet), 
1:n multi-link2 (Ethernet)

[System Setting]  → [Hardware Setting] → [Multi-link2 (Ethernet)]
Port No. Setting Range Function Location of Settings

255. 255. 255. 0

1 0

11111111 11111111 11111111 00000000

Class B Host address (16 bits)

Network address Subnet address

Network address (14 bits)

Host address

Subnet Mask
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4.3 Screen Program Transfer
Screen programs can be uploaded and downloaded using Ethernet communication.

4.3.1 Transfer Procedure
Downloading (PC → TSi)
1. Click [Transfer] → [Download]. The [Transfer] menu is displayed.

2. Select [Screen Data] for [Transfer Data].
3. Check the [Communication Port] setting.

• If Ethernet is set and the IP address is correct, proceed to the next step.
• If [Serial Port] or [USB] is set, click the [Communication Setting] button and select [Ethernet] under [Communication 

Port].

4. Click [PC →] to start the transfer.

LAN

MONITOUCH

V-SFT

MONITOUCH
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4.4 PLC Communication
• High-speed communication with the Ethernet port of the PLC can be performed at 100 Mbps or 10 Mbps.

• The TSi unit can open up to eight ports for communication, which means that the unit can simultaneously communicate 
with up to eight types of PLCs.

• When multiple PLCs of the same model are connected, a single port on the TSi unit can be used to perform 1:n 
communication with these PLCs.

For details on PLC communication, refer to the TS2060 Connection Manual or the TS1000 Smart 
Connection Manual.

For details on LAN ports available with the TSi unit, refer to “4.1.1 List of Functions” page 4-1.

LAN

TSi

Ethernet

LAN

・・・
・・・
・・・
・・・

・・・
・・・
・・・
・・・

・・・
・・・
・・・
・・・

・・・
・・・
・・・
・・・

run

ｓｔｏｐ

PROGRAMMER PROGRAMMER PROGRAMMER PROGRAMMER

Port2Port1 Port3 Port4 Port5 Port6 Port7 Port8

TSi

Manufacturer A Manufacturer B Manufacturer C Manufacturer D Manufacturer E Manufacturer F Manufacturer G Manufacturer H

Manufacturer A

Ethernet

LAN
Port1

TSi
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4.5 Transferring Data Between TSi Units (Macro)
• Communication can be performed and data shared between TSi units on the same LAN using the “EREAD” and “EWRITE” 

macro commands.

• Network table
Register the IP address of the counterpart unit in the [Network Table Edit] window in order to specify the destination 
using a macro.
Click [System Setting] → [Ethernet Communication] → [Network Table].

4.6 DLL Communication
• Ethernet access functions (that support UDP/IP) for executing device memory read and write operations with respect to 

TSi units from a server and CF card access functions for executing read and write file operations on a storage device are 
provided.
By creating an application on a server using an environment such as Visual C++ 6.0 and Visual Basic, data can be 
collected from TSi units and transferred to the server.

For details on macros, refer to the Macro Reference Manual.

For details on LAN ports available with the TSi unit, refer to “4.1.1 List of Functions” page 4-1.

• Network table editing
Register the IP address of the 
counterpart unit.

LAN

TSi TSi

For details on DLL functions, refer to the V Series DLL Function Specifications.

For details on LAN ports available with the TSi unit, refer to “4.1.1 List of Functions” page 4-1.

LAN

VB, VC

Ethernet DLL
CF Card DLL

550

TSiServer
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4.7 MES Interface Function
4.7.1 Overview

• The TSi supports the MES interface function.

• The MES interface function enables the TSi to add, search, and delete data on databases.
Production control from a PC in the office is made simple by using real-time production information transmitted from the 
factory to the database.

• The TSi sends commands to V-Server on the PC connected via Ethernet. V-Server sends the commands as SQL statements 
to ODBC, and ODBC accesses the database.

MES: Manufacturing Execution System
MES provides information necessary to optimize production activities (such as quality, yield, time of delivery, and cost) 
throughout processes from order receipt until product completion. Based on real-time information obtained from the 
manufacturing floor, MES serves as a bridge linking management and production, for the purpose of improving 
management in manufacturing.

ODBC: Open DataBase Connectivity
ODBC is the interface between an application (V-Server) and the database.
Because ODBC accommodates the differences in specifications between databases, users only need to create programs 
based on the ODBC-specified procedure in order to access those databases.

Ethernet

V-Server

ODBC

Office

Factory

Macro commands

SQL 
statements

Addition and search
Database

MacrosMacros

TSi TSi

V-Server

ODBC
SQL Server

Oracle

MSDE

DB1

DB2

DB3

Data source name

AAA

BBB

CCC

Database name

DB1

DB2

DB3
Links

Application

Database
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• The TS2060i can be set two IP addresses by using the CUR-03 communication unit so that different networks can be 
established respectively in the factory and the office. System configuration is therefore made simple in the existing 
facilities.

• Separate management through multiple V-Servers is enabled.

Ethernet

Ethernet

V-Server

IP 192.168.1. x

IP 211.13.204. x

ODBC

Office

Factory

Built-in LAN

Database

CUR-03

TS2060i

Ethernet

V9

V-Server

ODBC

V-Server

ODBC

Office

Factory

Management of 
daily work report

Management of 
production information

Database Database

Macros

TSi
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4.7.2 System Configuration
System configuration that includes the MES interface function is shown below. This section describes the settings required on 
the TSi unit and PC.

Required Settings
TSi
Configure the required settings for the TSi in the screen program.

1. Network table editing (page 4-12)
2. IP address settings for the TSi unit (page 4-2)
3. MES setting (page 4-13)
4. Macro programming (page 4-16)

Server PC
1. V-Server installation (page 4-22)
2. Database installation and table creation (page 4-23)
3. ODBC settings (page 4-35)

Ethernet

V-Server

ODBC

V-SFT

Database

Download

• Network table
• MES settings
• Macros

Server PC

TSi
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4.7.3 TSi Unit Settings
Network Table Editing
Register the IP address and port number of the PC installed with V-Server in the network table.

1. Click [System Setting] → [Ethernet Communication] → [Network Table]. The [Network Table Edit] window is displayed.

2. Double-click a number in the [No.] column to display the [Network Table No. Setting] window and configure the 
following settings.

3. Click [OK]. The settings are registered to the network table.
4. If multiple PCs are connected, perform the above registration steps for each PC.

Item Description
Port Name Set the name of the PC.
IP Address Set the IP address of the PC.
Port No. Specify the port number of V-Server. (Default: 8005)

* The port number can be checked in V-Server software via [File] → [V-server Detail Setting] → [Port No.].

Send Timeout
Retrials
Device Protect
Default Gateway
Subnet Mask

Setting these items is not required when registering the IP address of the PC.
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MES Settings
Click [System Setting] → [Other] → [MES Setting]. The [MES Setting] window is displayed.

Common settings

Item Description
No. Switch between MES setting numbers (0 to 255).

Skip Unregistered No. Click this button to skip unregistered numbers when switching between MES setting numbers.

Copy Copy data associated with the current MES settings to the specified destination.
Delete Delete the current MES settings.
Comment Enter a comment describing the MES settings. Maximum of 16 one-byte characters (8 two-byte 

characters.)
Data source Name Specify the data source name of the database. 32 bytes maximum
Login Name Specify a login name used for accessing the database. 32 bytes maximum
Password Specify a password used for accessing the database. 32 bytes maximum
Table Name Specify the name of the table in the database. 128 bytes maximum
Required No. of Word Count for 
Macro Command

This area shows the number of words used for each macro command based on the current settings. A 
number of words more than the maximum of 2,000 is highlighted in red. Adjust the number of 
registrations, length of line names, and number of words so that 2,000 words are not exceeded.

Write
Read
Search 
condition

Add Display the [Detailed setting] window. Enter a line name as targeted for writing and the data type in this 
window.
256 maximum

Change Display the [Detailed setting] window. Change the registered settings.
Delete Delete the registered settings.
Import Import a CSV file into the current MES settings.
Export Export the current MES settings into an CSV file.

Number of words used for Write, 
Read and Search condition

With [ ]: Valid_
Without [ ]: Invalid (always “0”)

Macro commands

Words in total for each macro command
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[Write] tab window
The [Write] tab window is used for adding data to the database.

[Read] tab window
Configure settings for searching the database.

Item Description
Line Name Specify the name of the line to which you will add data. 128 bytes maximum

* The line name must not begin with a one-byte numeral.
* The following characters cannot be used: ~ - ! , { % } ^ ’ & . ( / ) ` space

Device use Specify the data for writing. 256 bytes maximum
• With device memory specification: Set the device memory address to store the data for writing.

• Without device memory specification: Set a constant or fixed string of text.
Data Type
Length
Bytes

Set the data type of the data for writing, data length, and number of bytes.

Item Description
Max Record Specify the maximum number of records to display in the search results. 65536 maximum
Line Name Specify the line name targeted in searching. 128 bytes maximum

* The line name must not begin with a one-byte numeral.
* The following characters cannot be used: ~ - ! , { % } ^ ’ & . ( / ) ` space

Data Type
Length
Bytes

Specify the data type, data length, and number of bytes of the data targeted in searching.

Sort Set an option for sorting the search results.
Non / Up / Down

Device Memory Input Type Text Processing
PLC1 - PLC8 Depends on the input type of each PLC.
Internal DEC LSB → MSB

Data type Length Bytes
DEC- 1 words/2 words -
CHAR 128 word 256 bytes maximum
BCD 1 words/2 words -
FLOAT 2 word -

Data type Length Bytes
DEC- 1 words/2 words -
CHAR 128 word 256 bytes maximum
BCD 1 words/2 words -
FLOAT 2 word -
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[Search condition] tab window
Configure settings for searching the database. This tab is also used to delete data from the database.

Item Description
Line Name Specify the line name targeted in searching. 128 bytes maximum

* The line name must not begin with a one-byte numeral.
* The following characters cannot be used: ~ - ! , { % } ^ ’ & . ( / ) ` space

Search Condition Set the search conditions. When searching based on multiple conditions, use AND.

Device use Specify the data targeted for searching. 256 bytes maximum
• With device memory specification: Set the device memory address to store the data for searching.

• Without device memory specification: Set a constant or fixed string of text.
Data Type
Length
Bytes

Specify the data type, data length, and number of bytes of the data targeted in searching.

Search condition Remarks
Equal (=)
Not equal (!=)
Big (> value)
Small (< value)
Upper (>= value)
Under (<= value)
Include character string Wildcard (%) usable

Example: AA%: Text beginning with AA to be searched
Update Extract records that do not match the data for searching from the 

specified line name.
These records are then replaced as the data for searching.

Device Memory Input Type Text Processing
PLC1 - PLC8 Depends on the input type of each PLC.
Internal DEC LSB → MSB

Data type Length Bytes
DEC- 1 words/2 words -
CHAR 128 word 256 bytes maximum
BCD 1 words/2 words -
FLOAT 2 word -
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Macros
The MES interface function uses the following five types of macros.

MES macro command list

MES CHECK (F1, F2, F3)
Function: V-server start check

This macro is used to check whether V-Server at the location specified in table No. [F2] is running. The returned value 
specified in [F3] is stored in the memory at the return address of [F1].

Device Memory Used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)

Range

Operation Example
MES CHECK ($u0000, 10, 1)

The above macro checks whether V-Server is running on the PC registered to network table number 10. If V-Server is 
running, a return value of “1” is stored at the return address of $u0000.

Supplementary information
• Execute the macro after setting a value other than the returned value at the return address.
• The execution type of the macro can be set using $s514. For details, refer to page 4-21.

When a macro command is executed, if “1” (other than “0”) is set for $s514 while V-Server is not running, no response is 
given from V-Server and the TSi unit will enter the standby state. It is recommended to execute this command when “0” is 
set for $s514.

• The result of the macro execution is stored in the device memory address $s515. For details, refer to page 4-21.
• The returned value will not be placed at the [F1] return address immediately. Monitor the [F1] return address using an 

event timer macro, etc.
• If an error occurs when writing the result (return value, data retrieved by a search) of accessing database, the result and 

log data is not output to the TSi unit.

Category Command Name Mnemonic Description Refer to

MES MES

MES CHECK (F1, F2, F3) V-server start check page 4-16
MES WRITE (F1, F2, F3) Adding data to the 

database
page 4-17

MES READ (F1, F2, F3) Searching the database page 4-18
MES DEL (F1, F2, F3) Deleting data from the 

database
page 4-19

MES UPDATE (F1, F2, F3) Updating the database page 4-20

Internal PLC1 - 8 Constant
F1
F2
F3

Value
F0 MES CHECK
F1 Return address
F2 0 to 99: Network table number
F3 0 to 65535 (-32768 to 32767): Return value

MES setting No. 1
Network table No. 10
Return address
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MES WRITE (F1, F2, F3)
Function: Adding data to the database

This macro is used to add the data set on the [Write] tab window under MES setting No. [F3] to the database. The data is 
added using V-Server at the location specified in table No. [F2]. The result is stored at the [F1] return address.

Device Memory Used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)

Range

Operation Example
MES WRITE ($u0000, 10, 0)

The above macro adds data to the database of the PC specified in network table No. 10. The data to be added 
depends on the settings made for MES setting No. 0. When the data update is completed normally, a return value of 
“0” is stored at the return address of $u0000.

Supplementary information
• The execution type of the macro can be set using $s514. For details, refer to page 4-21.
• The result of the macro execution is stored in the device memory address $s515.

-40: The [Write] tab window setting is not made in the specified MES setting number, or any setting error is found.
For details on other error numbers, refer to page 4-21.

• The returned value will not be placed at the [F1] return address immediately. Monitor the [F1] return address using an 
event timer macro, etc.

• The primary key for V-Server must be set to the database table. (page 4-32)
• If an error occurs when writing the result (return value, data retrieved by a search) of accessing database, the result and 

log data is not output to the TSi unit.

Internal PLC1 - 8 Constant
F1
F2
F3

Value
F0 MES WRITE
F1 Return address Return value

0: Normal termination
-1: Ended in error

F2 0 to 99: Network table number
F3 0 to 255: MES setting No.

MES setting No. 0
Network table No. 10
Return address
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MES READ (F1, F2, F3)
Function: Searching the database

This macro is used to search the line set on the [Read] tab window for MES setting No. [F3]. The search is performed 
based on the specified search conditions via V-Server at the location specified in table No. [F2]. The result is stored at the 
[F1] return address.

Device Memory Used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)

Range

Return address
The following data is stored at the addresses starting from the [F1] return address.

Operation Example
MES READ ($u0000, 10, 0)

The above macro searches the database on the PC specified in network table No. 10.
The search is performed according to the settings on the [Read] and [Search condition] tab windows for MES setting 
No. 0. When the search is completed normally, a return value of “0” and the obtained data are stored at the addresses 
starting from the return address of $u0000.

Supplementary information
• The execution type of the macro can be set using $s514. For details, refer to page 4-21.
• The result of the macro execution is stored in the device memory address $s515.

-40: The [Read] tab window setting is not made in the specified MES setting number, or any setting error is found.
For details on other error numbers, refer to page 4-21.

• The returned value will not be placed at the [F1] return address immediately. Monitor the [F1] return address using an 
event timer macro, etc.

• If settings are not configured on the [Search condition] tab window for the specified MES setting number, all records are 
extracted as the results of the search.

• If an error occurs when writing the result (return value, data retrieved by a search) of accessing database, the result and 
log data is not output to the TSi unit.

Internal PLC1 - 8 Constant
F1
F2
F3

Value
F0 MES READ
F1 Return address
F2 0 to 99: Network table number
F3 0 to 255: MES setting No.

Return address Value
n Execution result

Normally finished: 0
Error: Other than 0

n+1 Number of retrieved records
The number of records that match the search conditions is stored.
If no records are found, 0 is stored. The maximum number of records is set on the [Read] tab window in 
the MES settings.

n+2 - Obtained data 1
The retrieved data is stored in the format specified on the [Read] tab window in the MES settings.

: Obtained data 2
: Obtained data 3
: :
: Obtained data m (maximum number of records)

MES setting No. 0
Network table No. 10
Return address
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MES DEL (F1, F2, F3)
Function: Deleting records from the database

This macro is used to search the database according to the settings on the [Search condition] tab window for MES setting 
No. [F3]. The search is performed via V-Server at the location specified in table No. [F2]. The records that match the 
conditions are deleted. The result is stored at the [F1] return address.

Device Memory Used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)
Range

Operation Example
MES DEL ($u0000, 10, 0)

The above macro searches the database of the PC specified in network table No. 10 and deletes the retrieved data. The 
search is performed according to the settings on the [Search condition] tab window for MES setting No. 0.
When the data deletion is completed normally, a return value of “0” is stored at the return address of $u0000.

Supplementary information
• The execution type of the macro can be set using $s514. For details, refer to page 4-21.
• The result of the macro execution is stored in the device memory address $s515.

-40: The [Search condition] tab window setting is not made in the specified MES setting number, or any setting error is 
found.

• For details on other error numbers, refer to page 4-21.
• If an error occurs when writing the result (return value, data retrieved by a search) of accessing database, the result and 

log data is not output to the TSi unit.

Internal PLC1 - 8 Constant
F1
F2
F3

Value
F0 MES DEL
F1 Return address Return value

0: Normal termination
-1: Ended in error

F2 0 to 99: Network table number
F3 0 to 255: MES setting No.

MES setting No. 0
Network table No. 10
Return address
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MES UPDATE (F1, F2, F3)
Function: Updating the database

This macro is used to search the line set on the [Write] tab window for MES setting No. [F3]. The search is performed 
based on the specified search conditions via V-Server at the location specified in table No. [F2], and then the database is 
updated. The result is stored at the [F1] return address.

Device Memory Used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)
Range

Operation Example
MES UPDATE ($u0000, 10, 0)

The above macro searches the database on the PC specified in network table No. 10 and updates the database. The 
search is performed according to the settings on the [Write] and [Search condition] tab windows for MES setting No. 0.
When the data update is completed normally, a return value of “0” is stored at the return address of $u0000.

Supplementary information
• The execution type of the macro can be set using $s514. For details, refer to page 4-21.
• The result of the macro execution is stored in the device memory address $s515.

-40: Settings are not configured on the [Write] or [Search condition] tab window for the specified MES setting number, or 
any setting error is found.
For details on other error numbers, refer to page 4-21.

• The returned value will not be placed at the [F1] return address immediately. Monitor the [F1] return address using an 
event timer macro, etc.

• This macro command cannot be executed when “Update” is set on the [Search condition] tab window.
• If an error occurs when writing the result (return value, data retrieved by a search) of accessing database, the result and 

log data is not output to the TSi unit.

Internal PLC1 - 8 Constant
F1
F2
F3

Value
F0 MES UPDATE
F1 Return address Return value

0: Normal termination
-1: Ended in error

F2 0 to 99: Network table number
F3 0 to 255: MES setting No.

MES setting No. 0
Network table No. 10
Return address
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System Device Memory ($s)
The system device memory related to MES macros are shown below.

$s514, 515
Device memory related to MES macros and Ethernet macros (SEND/EREAD/EWRITE).
Executed with respect to the port specified with $s512.

• $s514: Set whether a macro wait request is on or off.
- [0]: No wait

During the execution of a macro command, the execution of the next macro command takes place before the 
completion of the current one.

- Other than [0]: With wait
During the execution of a macro command, the next macro command is put on hold and is executed after the 
completion of the current command.

* In the case of successive accesses to the same port on one single macro sheet, specify a value other than “0” (with wait).
If “0” (no wait) is specified, a macro command issued afterward will not be accepted.

• $s515: Store the macro execution result.
When $s514 is set to “0”, the issue of a macro command is stored. When $s514 is set to “1”, the response returned for the 
command is stored.

Addresses Description Remarks
$s512 Selection from two Ethernet ports

0: LAN
1: CUR-03

→ TSi

$s514 Macro  Wait request → TSi

$s515 Macro  Wait request execution result TSi →

Code Description Solution
0 Normal -

200 - 2000 Communication error Refer to the TS2060 Hardware Specifications or the TS1000 Smart 
Hardware Specifications.

-30 Timeout Check whether an error has occurred on the destination TSi unit.
-31 Number of words for sending 

exceeded
Use the macro editor to check the number of words for sending.

-32 The specified table is not used. Check the network table settings.
-33 The send command cannot be used. Use the macro editor to check the macro command.
-34 The specified table is in use. Check whether system device memory address $s514 is set.

If it is not to be set, reduce the number of communications.
-35 Processing impossible due to 

insufficient memory
Check the memory availability of the counterpart device.

-40 Setting data error Check that [Write], [Read], and [Search condition] settings are 
configured for the specified MES setting number.
Check that the set data is correct.

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB

Wait request
0: No
1: YesSystem reserved (setting 0)

LSB
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4.7.4 V-Server
V-Server
Hakko Electronics V-Server is the software that enables accesses to databases.
Once V-Server is installed on a PC, no additional configuration is needed. The system requirements for V-Server are listed in 
the table below.

System requirements

Installation
1. Download the V-Server software to your PC from the Hakko Electronics website at the following URL. 

http://monitouch.fujielectric.com/site/support-e/download-index-01.html
2. Install V-Server on the PC.
3. Start V-Server.

* The message that appears at start-up indicates that V-Server is usable for one hour.
To use V-Server without this limitation, please apply for a software license and obtain a password. For details, refer to the 
TELLUS and V-Server Manual.

Item Description
PC Pentium 4, 1 GHz equivalent or higher
OS Windows 98 / Me / NT Ver.4.0 / 2000 / XP / XP64 Edition / Vista (32 bit, 64 bit) / 7 (32 bit, 64 bit) / 8 (32 bit, 

64 bit) / 8.1 (32 bit, 64 bit) / 10 (32 bit, 64 bit) / Server 2008 R2 / Server 2012
Memory Min. 256 MB
Hard disk Min. 1 GB of free disk space
Database SQL Server (Microsoft)

MSDE (Microsoft)
Oracle (Oracle Corporation)
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4.7.5 Database
Types of Databases
The following databases can be used.

• SQL Server: Microsoft
• MSDE: Microsoft
• Oracle: Oracle Corporation

This manual describes an example of configuration using Microsoft SQL Server 2012 Express Edition.

SQL Server 2012 Express Edition
Installation
1. Download SQL Server 2012 Express Edition from Microsoft’s website.
2. Double-click the downloaded executable file.
3. The [SQL Server Installation Center] window is displayed. Select [New SQL Server stand-alone installation or add features 

to an existing installation].

4. The license terms are displayed. Select the [I accept the license terms.] checkbox and click the [Next] button.

SQL Server 2012 Express Edition
This is a simplified version of SQL Server 2012. This software can be downloaded free of charge from Microsoft’s 
website.
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5. The [Product Updates] window is displayed. Proceed by following the instructions.

6. The [Install Setup Files] window is displayed and installation of setup files starts.

7. The [Feature Selection] window is displayed. Select [Database Engine Services].
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8. The [Instance Configuration] window is displayed. Select the [Named instance] radio button and proceed to the next 
screen.

9. The [Server Configuration] window is displayed. Click the [Next] button.
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10. The [Database Engine Configuration] window is displayed. Select [Mixed Mode] and enter a password.

11. The [Error Reporting] window is displayed. Click [Next] to start installation.
12. The [Complete] window is displayed when installation is finished. Click the [Close] button to exit.

The password is required when connecting to the database and configuring MES settings in V-SFT. Take care managing your 
password and do not lose it.
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13. Restart the PC.
14. From the Windows [Start] menu, click [All Programs] → [Microsoft SQL Server 2012] → [Configuration Tools] → [SQL 

Server Configuration Manager].

15. SQL Server Configuration Manager starts. Check that SQL Server (SQL Express) is running.

This completes the installation procedure.
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Creating an SQL Server Database
An SQL Server database can be created using SQL Server Management Studio Express.

Installation
1. Download SQL Server Management Studio Express from Microsoft’s website.
2. Double-click the downloaded file.
3. The [SQL Server Installation Center] window is displayed. Select [New SQL Server stand-alone installation or add features 

to an existing installation].

4. The [Product Updates] window is displayed. Proceed by following the instructions.
5. The [Installation Type] window is displayed. Select the [Add features to an existing instance of SQL Server 2012] radio 

button.

6. The [Feature Selection] window is displayed. Select the [Management Tools - Basic] checkbox.

7. Click [Next] to start installation.

Microsoft SQL Server Management Studio Express: SSMSE
An easy-to-use, graphical management tool intended for management of SQL Server 2012 Express Edition.
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8. The [Complete] window is displayed when installation is finished. Click the [Close] button to exit.

9. Restart the PC.
This completes the installation procedure.

Starting SQL server management studio express
1. From the Windows [Start] menu, click [All Programs] → [Microsoft SQL Server 2012] → [SQL Server Management Studio].

2. The [Connect to Server] window is displayed. Enter the required information and click the [Connect] button.

Item Description
Server name Select the server name of the SQL Server.
Authentication Select “SQL Server Authentication”.
Login Enter a user name. The user name “sa” is entered in this example.
Password Enter the password.
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3. SQL Server Management Studio Express starts up.

The password for “sa” was specified on the [Authentication Mode] window displayed during installation of SQL Server 2012 Express Edition 
(see page 4-26).
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Creating a new database
1. Select [Databases] and click [New Database] on the right-click menu.

2. The [New Database] window is displayed. Specify a database name and click the [OK] button.

3. A new database is created.
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Creating a new table
1. Start SQL Server Management Studio Express.

2. Select the database created in the previous section and click [New Table] on the right-click menu.

3. The table creation screen is displayed. Create a table by registering a line name and data type.

• Always set the primary key for V-Server for a database table to which data will be added.

• The following data types can be used with the MES interface function. These correspond to the data types in the MES 
settings in V-SFT.

Line Name Data Type Length Allow Nulls Primary Key
VsPrimaryKey varchar 26 bytes or more No

Database: Table V-SFT: MES settings
Line Name Data Type Length Allow Nulls Data type Length
(Arbitrary) smallint 1 word Permitted DEC-

BCD
1 word

(Arbitrary) int 2 word Permitted 2 word
(Arbitrary) Float 2 word Permitted FLOAT 2 word
(Arbitrary) varchar Arbitrary Permitted CHAR 256 bytes 

maximum
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4. When the table settings are complete, close the table. The confirmation dialog box is displayed. Click the [Yes] button.

5. Enter a name and click the [OK] button.

6. The table is created.
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Opening a table
The data saved in the database can be checked according to the following procedure.

1. Select a table and click [Edit Top 200 Rows] on the right-click menu.

2. The table is opened. The line name registered when the table was created is displayed. Data is saved in each “NULL” field.
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4.7.6 Data Source (ODBC) Settings
V-Server accesses the database via a data source (ODBC). Data source settings need to be configured to allow V-Server access 
to the database. This manual describes an example of configuration using Microsoft SQL Server 2012 Express Edition.

1. From the Windows [Start] menu, click [Control Panel] to display the Control Panel.
2. Click [Administrative Tools].

3. The [Administrative Tools] window is displayed. Double-click [Data Sources (ODBC)].

ODBC: Open DataBase Connectivity
ODBC is the interface between an application (V-Server) and the database.
Because ODBC accommodates the differences in specifications between databases, users only need to create programs 
based on the ODBC-specified procedure in order to access those databases.

V-Server

ODBC
SQL Server

Oracle

MSDE

DB1

DB2

DB3

Data source name

AAA

BBB

CCC

Database name

DB1

DB2

DB3
Links

Application

Database
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4. The [ODBC Data Source Administrator] window is displayed. Select the [System DSN] tab and click the [Add] button.

5. The [Create New Data Source] window is displayed. Select [SQL Server] and click the [Finish] button.

For 64-bit versions of Windows XP/Vista/7/8/8.1/10
The 32-bit version of ODBC must be used because V-Server is a 32-bit application.
1. From the Windows [Start] menu, click [Computer], double-click [Local Disk (C:)] → [Windows] → 

[SysWOW64].
2. Double-click the “odbcad32” application. The 32-bit version of ODBC starts up.
3. Press the [Ctrl] + [Shift] + [Esc] keys together to start Windows Task Manager and check which version of 

ODBC is running.
On the [Processes] tab, the 32-bit version is running if “odbcad32.exe *32” is shown in the list.
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6. The following window is displayed. Configure the required settings and click the [Next] button.

7. The following window is displayed.
Select the [With SQL Server authentication using a login ID and password entered by the user] radio button and specify a 
login ID and password.

Item Description
Name Specify a data source name.
Server Specify a SQL Server name.

• The data source name is used in the MES settings in V-SFT.
• The SQL Server name can be checked in SQL Server Management Studio Express.

Item Description
Login ID Enter a login ID (“sa” in this example).
Password Enter the password.

The login ID (“sa”) and password were specified on the [Authentication Mode] window displayed during installation of SQL 
Server 2012 Express Edition (see page 4-26).
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8. Click the [Next] button. The following window is displayed.

9. Select the [Change the default database to] checkbox and select a database.

10. Click the [Next] button. The following window is displayed.

11. Click the [Finish] button. The following window is displayed.

12. Click the [Test Data Source] button. When a connection has been successfully established, the following window is 
displayed.

13. Click [OK]. The previous screen reappears.

Select the database created using Microsoft SQL Server Management Studio Express (see page 4-31).
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14. Click [OK]. The data source is registered.

This completes the configuration of settings.
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4.8 E-mail Notification
4.8.1 Overview

• E-mail notifications can be sent according to the ON/OFF status of alarm bits. If a problem occurs, you can be notified of 
the fault even at a remote location.

• Supported items and ports used

• Encrypted communication using TLS 1.3/1.2 or STARTTLS is also supported (by TS SYSTEM PROGRAM Ver. 2.420 or later).

Port Item Other
LAN Alarm tracking

Alarm logging
Time order alarming

The mail server must reside on the LAN.
Not available with CUR-03.

LAN

E-mail

Error

Mail server

Alarm tracking
Alarm logging
Time order alarming
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4.8.2 Detailed Settings
To send e-mail notifications, IP address settings on the TSi unit and e-mail settings for registering the mail server and 
recipients of notification must be configured.

IP Address Settings
For information on IP address settings, refer to “TSi Unit IP Address Settings” page 4-2.

E-mail Settings
[System Setting] → [Ethernet Communication] → [E-Mail]

Item Description
SMTP IP Address Set the network IP address of the mail server.
Port Setting Set the SMTP port number of the mail server.

0 to 65535 (default: 25)

Example: Port No. 465 for SSL/TLS communication
Port No. 587 for STARTTLS communication

Certify Type Set the authentication method in accordance with the specifications of the mail server.
No authorization No authentication is performed.
POP before SMTP*1 Authentication is performed with the POP3 server. Configure the following settings.

• POP3 IP Address
• Account Name (63 one-byte characters or less)
• Password (63 one-byte characters or less)

SMTP-AUTH*2
LOGIN
PLAIN
CRAM-MD5
DIGEST-MD5 *3

Authentication is performed with the SMTP server. Configure the following settings.
• Encryption Method

- None
- SSL/TLS *4

- STARTTLS  *4
• Account Name (within 63 one-byte characters)
• Password (within 63 one-byte characters)

Sender’s Mail Address Set the sender’s mail address.
It is recommended to create a dedicated account for the TSi on the mail server and to set its 
address here.

Sender’s Name Set the sender’s name. A name consisting of both one- and two-byte characters is not valid.
It is displayed in the “Sender” field in an incoming e-mail.

Subject Set the subject.
It is displayed in the “Subject” field in an incoming e-mail.
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*1 POP before SMTP
POP before SMTP uses POP3 authentication that is performed when e-mail is received. SMTP permits the sending of e-mail from the 
authenticated IP address for a limited time.
Since authentication is disabled after a specific time has elapsed, authentication with POP3 will be required again.

In the case of authentication with POP3, a password is sent in plain text. POP before SMTP using APOP is also available. APOP allows a 
password to be sent in encrypted form. Note that the TSi only supports POP3.

*2 SMTP Authentication
Authentication is performed with the SMTP server. SMTP Authentication is classified into several authentication methods. The TSi 
supports LOGIN, PLAIN, CRAM-MD5, and DIGEST-MD5 methods.
Since the SMTP server automatically performs authentication according to the available method, users are not requested to make 
configurations.

<Automatic authentication steps>
1. Compliant with PLAIN?
2. Compliant with LOGIN?
3. Compliant with CRAM-MD5?
4. Compliant with DIGEST-MD5?
5. Authentication failure

About the authentication methods
- PLAIN

The PLAIN method sends user names and passwords in plain text (not in encrypted form).
- LOGIN

LOGIN is similar to PLAIN but it often sends information, such as USER xxxxx or PASS xxxxxx, separately (as performed with POP3). 
Because the standard specifications of LOGIN are not established, there are e-mail servers that use LOGIN in their own way.

- CRAM-MD5
With CRAM-MD5, the server sends an arbitrary character string (a challenge string) to the client. The client then performs a specific 
computing process called Message Digest 5 (MD5) by using the challenge string and password, and returns the result to the server. The 
server that receives the result also performs the same process. When both results match each other, the server judges that the client 
knows the correct password and grants authorization.

- DIGEST-MD5
DIGEST-MD5, an expanded version of CRAM-MD5, has an enhanced resistance to dictionary attacks and brute force attacks.

*3 Only “auth” mode is supported for “quality protection”. It does not support “auth-int” and “auth-conf” modes.
*4 Verified mail servers that support TLS 1.3/1.2 compliant encrypted communication

Receiver’s Mail Address 8 maximum
Register the recipient mail addresses.
Register all mail addresses to receive notifications from the TSi unit.

Add Register a new recipient address.
Change Change a registered address.
Delete Delete a registered address.

Type Mail Server Encryiption 
Method Port Mail Account (Domain)

Gmail smtp.gmail.com SSL/TLS 465 @gmail.com
STARTTLS 587

Microsoft365
outlook

smtp-mail.outlook.com
smtp.office365.com

STARTTLS 587 @outlook.jp

yahoo mail.yahoo.com SSL/TLS 465 @yahoo.co.jp
* If using Gmail, the following settings are required in the Google account security settings.

- 2-Step Verification: On
- Generate a password from [App passwords] by setting [Select app] to “Mail” and [Select device] to “Other”, and then 

inputting a device name (example: TS).
Register the 16-digit password at [E-Mail Setting] → [Password] for the TSi unit.

Item Description

16 digits
Register at [E-Mail Setting] → 
[Password] for the TSi unit.
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Buffering Area Settings
Set the recipients of e-mail notifications in the buffering area settings window. Recipients of e-mail notifications can be set for 
each sampling.
This section describes the settings required for sending e-mail notifications. For details on other settings, refer to “8. Alarm” in 
the TS Reference Manual 1.

1. Display [System Setting] → [Buffering Area Setting] → [Alarm Tracking] → [Basic Settings].

2. Select [Detail Settings], select the [Send e-mail] checkbox under [Action to Take When Bit Is ON], and then select the 
[Send to.] button to register recipients in the [Receiver’s Mail Address] window.

Message Editor
In the [Message Edit] window, register messages corresponding to error bits and select whether or not to send e-mail 
notifications.
Select the [E-Mail] icons of the messages with which you want to send e-mail notifications.

* If the display in the [Message Edit] window differs from the above screenshot, click [Display] → [Mark] → [E-Mail].

E-mail icons
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4.8.3 System Device Memory ($s)
Information on sent e-mail messages is output to system device memory ($s).

4.8.4 Notes
• The e-mail transfer of the TSi unit does not support SSL/TLS encryption. Transfer to the SMTP server that requires 

encryption is therefore impossible.
Example: Google’s Gmail

• The available languages for sending e-mails are English and Japanese. If any other languages are used, characters will get 
garbled.

$s Description
$s1005 If the TSi unit receives send requests continually, the number (0 to 16) of e-mail messages waiting to be sent is stored.

The TSi unit can keep up to 16 e-mail messages. Any more than 16 messages are discarded.
$s1006 Stores error information on e-mail messages.

Error No. Cause
0 Normal -
1 E-mail address error Incorrect recipient mail address
6 Network not connected Incorrect SMTP/POP3 server IP address

SMTP server refusal
Incorrect port number
Incorrect SSL/TLS settings
Incorrect account name/password

50 SMTP transmission error Authentication method error
Incorrect sender’s mail address
Connection lost
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4.9 FTP Server
4.9.1 Overview

The TSi can serve as an FTP server.
An FTP client tool installed on the PC can be used to access a TSi unit over Ethernet and perform reading and writing data on 
a storage device inserted into the TSi.
A standard FTP tool included with Windows is available for reading, writing, and editing files on a storage device without the 
need for installing any special tool.

4.9.2 Specifications
Functional Capabilities

Applicable Models Port Other
TS2060i
TS1100Si
TS1070Si

LAN Storage Device

Ethernet

Ethernet

FTP client tool

FTP server

FTP server

Router
TSi

TSi

Item Specifications Location of Settings
Protocol TCP/IP (Not available with CUR-03) -
User Name 1 to 12 one-byte alphanumeric characters (case-sensitive) Editor
Password 1 to 8 one-byte alphanumeric characters (case-sensitive) Editor
Port number 20, 21 (Fixed)
No. of clients *1 Maximum of 3 clients -
Input supervisory time 1 to 60 minutes (default: 15 minutes) *2 Editor
File readout size Unlimited (within the storage capacity) -
File name One-byte alphanumeric characters only -
Requirement Only operable in RUN mode (not operable in local mode) -
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*1 Clients (FTP clients)
This manual defines a client or FTP client as a PC that transmits commands for reading/writing data to an FTP server. A maximum of three 
client PCs can access a TSi unit.

*2 If no command is received from the FTP client within the time period specified for [Input Supervisory Period], the TSi unit automatically 
disconnects the client.

Compatible FTP Client Tools

Supported FTP Commands
The following commands can be used with the FTP server on the TSi unit.

Tools and Functions Computer OS/Monitouch Series
Command Prompt (included with Windows as standard) Windows XP SP3

Windows 7
Windows 8ftp.exe (included with Windows as standard)

Windows Explorer (included with Windows as standard)
FFFTP version 1.96b (freeware)
Data transfer service V9 Series

Command Name Function
cd Changing the current directory
close Closing the connection
dir Displaying the file information
ls Displaying folder and file names
put Sending a file
get Retrieving a file
delete Deleting a file
rename Renaming a file
pwd Displaying the current folder name
mkdir Creating a folder
rmdir Deleting a folder
quit Exit the FTP client tool after disconnecting the client.

Ethernet

Ethernet

FTP server

FTP client

FTP client FTP client

RouterTSi
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4.9.3 Detailed Settings
Click [System Setting] → [Ethernet Communication] → [FTP Server]. The [FTP Server Setting] window is displayed.

* If no command is received from the FTP client within the time period specified for [Input Supervisory Period], the TSi unit automatically 
disconnects the client.

4.9.4 Specifying File Paths
How to specify file paths

• Drive name
C: Inserted SD card
D: USB-A port (USB flash drive, etc.)

Item Description
Use FTP server function Select this checkbox to use the FTP server function. The FTP server function is not available unless this 

checkbox is selected.
User Name 1 to 12 one-byte alphanumeric characters (case-sensitive)
Password 1 to 8 one-byte alphanumeric characters (case-sensitive)
Input Supervisory Period 1 to 60 minutes (default: 15 minutes) *

Write enable Select this checkbox to allow the FTP client to write, delete, and edit files. When this checkbox is not selected, 
only file reading is possible. (Default: unselected)

C: \TS\JPEG\JP00000.JPG

C: \DAT0000\RECIPE\TEST\TYPE0421.CSV

Drive name Access folder name Folder name *1 Filename *1

Maximum number of characters for a path: 
255 one-byte characters (including “:”, “\”, and the file extension)

Maximum number of characters for a path: 
255 one-byte characters (including “:”, “\”, and the file extension)

*1 Maximum number of characters for a filename: 
194 one-byte characters
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4.9.5 Login
This section explains the login procedure and how to operate the FTP tools.
Prepare the TSi unit as instructed below before starting.

1. Transfer the screen program with configured FTP server settings to the TSi unit.
2. Connect your computer to the TSi unit via Ethernet.
3. Insert a storage device into the TSi unit and set the unit to RUN mode.

Explorer (or Internet Explorer)
1. Start [Explorer].

2. Enter the FTP command in the [Address] field.
Enter “ftp://user name:password@TSi IP address” and then press the [Enter] key.

* When using Explorer or Internet Explorer,
specify “ftp://user name:password@TSi IP address”.
User authentication may not be successful if only “ftp://TSi IP address” is entered.
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3. The Explorer window is displayed as follows. Login is complete.

4. Explorer allows the contents of the storage device inserted into the TSi unit to be displayed.

Contents of the storage device 
inserted into the TSi series unit
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4.9.6 Log Out
This section explains the log out procedure and how to operate the FTP tools.

Explorer (or Internet Explorer)
To log out when using Explorer, close the Explorer window.

Click the close button to log out.
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4.9.7 Checking the Connection
System Device Memory ($s)
The following describes the system device memory associated with the FTP server.

Checking the Connection State
Create a lamp to which the internal device memory $s1070-00 is assigned, and place it on the screen.
A lit lamp indicates that a client is logged in, i.e. a connection is established.

Addresses Description Remarks
$s1070 Storage of FTP information

* If two or more FTP clients log in to the FTP server, the data stored in the system memory is 
based on the status of all these FTP clients. (Even if only one FTP client is executing a 
command, bit 1 is set to ON.)

← TSi

$s1071 Number of FTP clients that are logged into the server (maximum of 3 clients) ← TSi
$s1072 Forced disconnection of FTP connection ← TSi

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB

FTP client
0: Logged off
1: Logged in

System reserved (setting: 0)

LSB

FTP client
0: Command not being executed
1: Command being executed

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB

Connection to FTP client
0 → 1: Forcibly disconnectedSystem reserved (setting: 0)

LSB

$s1070-00

Indicates that a client is logged in.
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Closing the Connection
Automatic disconnection
If no command is received from the FTP client within the time period specified for [Input Supervisory Period] in the [FTP 
Server Setting] window (click [System Setting] → [Ethernet Communication] → [FTP Server]), the TSi unit automatically 
disconnects the client.

Manual disconnection from the TSi unit
The connection with the FTP client can be forcibly disconnected by resetting (OFF to ON) bit 0 of $s1072 on the TSi unit.

Disconnection from FTP client
The FTP client is disconnected from the TSi unit when the FTP client logs out.
For details, refer to “4.9.6 Log Out” page 4-50.

$s1070-00

$s1072-00
Resetting $s1072-00 (OFF to ON) 
changes to the logged off state.

Logoff occurs.
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4.9.8 Restrictions
Number of Simultaneous FTP Client Connections
A maximum of three FTP clients can be connected to one TSi unit at the same time.
Note that requests from multiple FTP clients cannot be processed at the same time. They are processed one by one. 
Therefore, while an FTP client is transferring a large-size file, another client cannot transfer a file and must wait until the 
current file transfer is completed.

File Property Changes
Changing file properties (such as changing write permissions) is prohibited.

4.9.9 Notes
Notes on FTP Server System Design
1. In the case when an FTP client writes a recipe file to the storage device inserted into the TSi unit, the recipe file from the 

FTP client and the recipe in operation on the TSi unit must be in the same format. In the case when a recipe file is written 
from a remote location, make sure that the same format is used at the target location in advance.

2. Before using an FTP client tool, read the provided documentation to understand the functions and operational 
procedures, and also conduct a trial operation. The TSi (FTP server) may not support some functions depending on the 
type of the FTP client tool used.

Notes on File Transfer
1. If no command is sent from the FTP client within the time period specified for [Input Supervisory Period] in the [FTP 

Server Setting] window, the connection between the FTP server and FTP client will be disconnected automatically.
2. While the TSi unit is communicating with the FTP client, changing the TSi unit to local mode will disconnect them.
3. While the TSi unit is accessing a file, do not allow the FTP client to write to or delete the same file.

If the same file accessed by the TSi unit is written to or deleted, a malfunction will occur. Deleting a file from the storage 
device, even when the file is not being accessed by the TSi unit, will cause a file reading error the next time the TSi unit 
attempts to access the file.
Basically, do not execute the writing and deleting commands with respect to any files relevant to TSi unit operation.

4. When a file on the storage device has been overwritten via the FTP server, check that the data in the file is correct.
If writing to the file ends in an error, the file will be deleted from the storage device. In the event of such a deletion, repeat 
writing from the FTP client.

5. If the FTP client is down, wait until the time for [Input Supervisory Period] elapses and then retry login.
6. While the FTP client is accessing a file on the storage device inserted into the TSi unit, do not turn off power to the TSi 

unit. Doing so may corrupt data on the storage device.
7. If the TSi unit is reset or turned off while connected to an FTP client, the next action that the FTP client takes depends on 

the specifications of the FTP client tool.
With this in mind, select an FTP client tool that can detect when an FTP server goes down and can terminate safely in such 
a case.

8. Depending on the type of FTP client tool, there may be a time stamp mismatches between files on the storage device and 
the PC. If such a mismatch is found, check the configuration of the FTP client tool.
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4.10 Remote Desktop
4.10.1 Overview

• The screen of a computer at a remote location can be displayed on the TSi unit.
This function serves the purpose of remote monitoring through the TSi unit connected to, for instance, a server 
(computer) that controls an entire production line or computers that are installed in a clean room where access is limited.

• The screen of remote computers can be operated using a mouse and keyboard connected to the TSi unit. This facilitates 
data entry or referencing of manuals through the TSi unit at worksites where it is difficult to bring a computer with you.

Operating Environment
• Applicable Models

• Server (Computer)

Refer to “4.10.5 Window Configuration and Operation” page 4-66

Model Port Other Notes
TS2060i
TS1100Si
TS1070Si

LAN Not available with CUR-03

Item Description
OS Windows 7/8
Protocol TCP/IP

Example: Monitoring a server (computer) in clean room B

Ethernet

Clean 
room A Clean 

room B
Clean 

room C

Ethernet

Example: Searching for documents on a computer in the office

Office
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Required Settings
Server (Computer) Settings

•   Installing and Configuring UltraVNC page 4-56  

TSi Unit Settings
•   Registering/Deregistering the License page 4-58 

V-SFT Settings
•   Remote Desktop Table Settings page 4-59 
•   Remote Desktop Window Display Procedure

  Placement of a Display Area to Show Remote Desktop Window page 4-60 
  Switch to Show/Hide Remote Desktop Window page 4-63 
  Showing/Hiding Using a Macro Command page 4-64 

About VNC (Virtual Network Computing)
This software is developed by AT&T Laboratories Cambridge (U.K.) and designed to operate remote computer 
screens across a network.
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4.10.2 Server (Computer) Settings
Installing and Configuring UltraVNC
This section describes the settings necessary for remote desktop window display using UltraVNC as an example.

1. Access the following URL and download UltraVNC.
http://www.uvnc.com/download/index.html

2. Execute the downloaded file to start the installation process.

3. Read the license agreement and if you agree to the terms and conditions, select [I accept the agreement] option and click 
the [Next] button.

4. Check the information displayed in the window and then click the [Next] button.
5. Select the location to install UltraVNC using [Select Destination Location] and then click the [Next] button.
6. Select [UltraVNC Server] and then click the [Next] button.

7. To register UltraVNC to the start menu, specify its location and the name of the program, and then click the [Next] button.
8. Select the following checkboxes and then click the [Next] button.

Select this checkbox to register UltraVNC 
Server as a Windows service.

Select this checkbox to start or restart the 
UltraVNC service upon completion of UltraVNC 
installation.



4.10    Remote Desktop

4-57

1

2

3

4

5

6

7

8

9

10

9. Check the information displayed in the [Ready to Install] window and then click the [Install] button.

10. Check the information displayed in the window and then click the [Next] button.
11. Click the [Finish] button to complete the installation process. The UltraVNC icon is added to the taskbar of your computer.

12. Right-click on the UltraVNC icon on the taskbar to display the right-click menu and select [Admin Properties]. Configure 
the following settings and click [OK].

* When connecting from multiple TSi units, select the [Keep existing connections] under [Multi viewer 
connections].

About the UltraVNC icon
UltraVNC must be running on the connected computer in order to display the remote desktop window.
(Nothing is displayed if UltraVNC is not running.) The UltraVNC icon illuminates orange when a connection with 
the TSi unit is established.

About [VNC Password]
The password set here must be entered in V-SFT when configuring the remote desktop table (refer to Remote Desktop 
Table Settings page 4-59).
Take care managing your password and do not lose it.

Connected to the TSi unit (orange)UltraVNC running (green)
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4.10.3 TSi Unit Settings
Registering/Deregistering the License
A license must be registered in order to use the remote desktop function. A single license is provided with each TSi unit.

Registering a License
1. Switch to the Main Menu screen on the TSi unit.
2. Press the [Extended Setting] switch on the Main Menu screen. The Extended Setting screen appears.

3. Press the [Remote Desktop Key Code] switch. The Remote Desktop screen appears.

4. Enter the key code (8-digit value) using the keypad and then press the [Setting Finished] switch.
5. The Main Menu screen reappears when registration is complete.

Deregistering a License
A license can be deregistered from the TSi unit.
1. Switch to the Remote Desktop screen. For details on switching to this screen, refer to “Registering a License”.
2. Press the [Delete] switch and then press the [Execute] switch in the dialog box that appears.

3. The [Delete] switch disappears and [Not registered] appears in its place. The license is no longer registered.

For details on purchasing a “V-RemoteDT” license, contact your local distributor.
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4.10.4 V-SFT Settings
Attempting to transfer a screen program with configured remote desktop settings without registering a license on the TSi unit 
will display “Warning: 214” on the TSi unit.

Remote Desktop Table Settings
Register the computer (server) for connection.
Click [System Setting] → [Other] → [Remote Desktop Table Setting] to display the [Remote Desktop Table Setting] window.

Refer to “Registering/Deregistering the License” page 4-58.

Item Description
Local Port No. Specify the local port number of the TSi unit.

This port is used as a sending/receiving port for remote desktop window display.
(default: 8050, range: 1024 to 65533)

Computer Name Specify the name of the server (computer).
IP Address Specify the IP address of the server (computer).
Port No. Specify the port number of the server (computer). (UltraVNC default: 5900)
Password Specify the password. Typing the password shows eight asterisks.

(one-byte 254 alphanumerics maximum)
Auto-reduction Select this checkbox to use the function that zooms out to show the entire computer screen.
PC resolution When the [Auto-reduction] checkbox is selected, specify the resolution of the computer.

(800*600, 1024*768, 1152*864, 1280*1024, 1600*1200, 
specification (width: 800 to 1600, height: 600 to 1200))

Enter the password set in the [UltraVNC Server Property Page] window on the computer. (Refer to step 12 in “Installing and Configuring 
UltraVNC” page 4-56.)



4  Ethernet Communication Function

4-60

Remote Desktop Window Display Procedure
There are three ways to display a remote desktop window.

• Placement of a Display Area to Show Remote Desktop Window → page 4-60
• Switch to Show/Hide Remote Desktop Window → page 4-63
• Showing/Hiding Using a Macro Command → page 4-64

Placement of a Display Area to Show Remote Desktop Window
A display area can be placed on a screen to display the remote desktop window of a connected server (computer).
Click [Parts] → [Image Display] → [Remote Desktop Display] and place the part.

Remote Desktop Display
• Table selection

Item Description
Remote Desktop No. Click the [Select] button to display the [Remote Desktop Table Setting] window.

Specify the table number of the server (computer) that has been registered in the [Remote Desktop 
Table Setting] window.

Remote Desktop Table Settings This area summarizes the remote desktop table settings.
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• Style

• Show/Hide
Configure the show/hide settings of the remote desktop display.

Item Description
Additional Parts List Displays a list of remote desktop-related parts.

Selected: Displayed on the unit.
Unselected: Not displayed on the unit.

Connect Connect to the server (computer) and enable display of the remote desktop window.
Disconnect Disconnect from the server (computer) and disable display of the remote desktop window.
Connect/Disconnect Each press of this switch toggles between connecting to the server (computer) and 

enabling display of the remote desktop window and disconnecting from the server 
(computer) and disabling display of the remote desktop window.

Show/hide the scroll 
bars (S menu)

Each press of this switch toggles between showing and hiding the scroll bars (S menu).
However, this function is disabled when displaying the remote desktop window with 
auto-reduction.

Reduce Display/100% 
Display

Each press of this switch toggles between automatic size reduction and actual size display 
of the remote desktop window.

Adjust Position Display the window for adjusting the placement position of each part. The size of parts 
can also be changed.

Select from catalogs Set the part design from the catalog.
Parts Design Set the design and color of the part selected in the [Additional Parts List] or preview pane.
Edit Selected Parts Set the part selected in the [Additional Parts List] or preview pane.

For details, refer to the Reference Manual 1.
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• Detail

Item Description
Display Setting

Display the PC screen at startup of 
MONITOUCH

Display the screen of the connected server (computer) when the TSi unit starts up. *1

Automatic zoom out to display 
the entire computer screen at 
initial connection.

Automatically zoom out to display the entire computer screen. *2
This option is only effective for the initial connection. From the second and 
subsequent connections, the computer screen is displayed at the actual size.

Coordinate Start_X/Start_Y
Others ID (0 - 255) Set the ID.

*1 When this checkbox is deselected, use a switch to display the remote desktop window.
*2 The corresponding [Auto-reduction] checkbox in the [Remote Desktop Table Setting] window must be selected. For details, refer to 

“Remote Desktop Table Settings” page 4-59.
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Switch to Show/Hide Remote Desktop Window
A switch can be placed on a screen to show or hide the remote desktop window of a connected server (computer) at the 
specified coordinates.
Set the switch function to [Remote Desktop Show/Hide].

* Function switch setting is disabled.

Switch Function/Auxiliary Setting Item Description
Remote Desktop:
Remote Desktop Show/Hide

Each press of this switch toggles between showing and hiding the remote desktop 
window. *1

Specify with Mouse The mouse is used to specify the position where the remote desktop window is 
displayed.

Start X Specify an X coordinate as the start point where the remote desktop window is 
displayed.

Start Y Specify a Y coordinate as the start point where the remote desktop window is 
displayed.

Width Specify the width of the area where the remote desktop window is displayed.
Height Specify the height of the area where the remote desktop window is displayed.
Remote Desktop Table No. Click [Select] to specify the table number of the server (computer) that has been 

registered in the [Remote Desktop Table Setting] window.
Auto-reduction on start-up Automatically zoom out to display the entire computer screen. *2

*1 Use the REMOTEDT_CTL macro command to show/hide the scroll bars (S menu). For details, refer to “Showing/Hiding Using a Macro 
Command” page 4-64.

*2 The corresponding [Auto-reduction] checkbox in the [Remote Desktop Table Setting] window must be selected. For details, refer to 
“Remote Desktop Table Settings” page 4-59.
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Showing/Hiding Using a Macro Command
Command list

• SET_REMOTEDT  F0  F1
Function: Showing/hiding the remote desktop window
This macro command is used to show/hide the remote desktop window of the computer (server) set to remote desktop 
table number [F1], which specified in the [Remote Desktop Table Setting] window, according to the value specified for 
[F0].

Device memory used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)
Range

Operation example
Display in an area based on the specified coordinates (remote desktop table number 10)

$u00100 = 2 (W) for actual size display based on the 
specified coordinates 

$u00101 = 0 (W) for X coordinate as the start point
$u00102 = 0 (W) for Y coordinate as the start point
$u00103 = 200 (W) for width
$u00104 = 200 (W) for height
SET_REMOTEDT  $u00100 10  

Supplementary information
• The SET_REMOTEDT macro command cannot be used unless the relevant settings are configured in the [Remote 

Desktop Table Setting] window. For details on configuration, refer to page 4-59.
• This macro command is not usable as an initial macro.
• The result of macro execution is stored in $s1063.

Category Mnemonic Description Refer to

Remote Desktop
SET_REMOTEDT  F0  F1 Show/Hide page 4-64
REMOTEDT_CTL F0 F1 F2 Change the display page 4-65

Internal PLC 1 to 8 Constant
F0
F1

Value Remarks
F0 0 : Hide

1 : Actual size
2 : Actual size (based on specified coordinates)
3 : Automatically reduced display
4 : Automatically reduced display (based on specified coordinates)

F0 + 1 X coordinate as the start point Valid when F0 = 2 or 4
F0 + 2 Y coordinate as the start point
F0 + 3 Width
F0 + 4 Height

F1 0 - 255: Remote desktop table number

Code (DEC) Description
0 Normal

−1 Execution error

Start point (0, 0)
(200, 0)

Remote Desktop Display

(0, 200) (200, 200)

Remote desktop table number 10
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• REMOTEDT_CTL  F0  F1  F2
Function: Switching the display in the remote desktop window
This macro command is used to switch the display of the remote desktop window of the computer (server) set to remote 
desktop table number [F1], which specified in the [Remote Desktop Table Setting] window, according to the value 
specified for [F0].

Device memory used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)

Range

Operation example
Hiding the scroll bars (S menu) (remote desktop table number 10)

REMOTEDT_CTL  2  10  0 

Supplementary information
• The REMOTEDT_CTL macro command cannot be used unless the relevant settings are configured in the [Remote 

Desktop Table Setting] window. For details on configuration, refer to page 4-59.
• The scroll bars (S menu) cannot be displayed when the auto-reduction function is used to display the computer 

screen.
• The result of macro execution is stored in $s1063.

Internal PLC 1 to 8 Constant
F0
F1
F2

Value
F0 0 : Computer screen reduction

1 : Computer screen rotation
2 : Show/hide scroll bars (S menu)

F1 0 - 255: Remote desktop table number
F2 (F0 = 0) (F0 = 1) (F0 = 2)

0 : Actual size
1 : 1/4
2 : 1/9
3 : 1/16
4 : Auto-reduction

0 : 0°
1 : 90°
2 : 270°

0 : Hide
1 : Always displayed
2 : Automatic *

* About the automatic setting

Resolution Scroll bars (S menu)
Computer resolution > TSi unit resolution Show
Computer resolution = TSi unit resolution Hide
Computer resolution < TSi unit resolution Hide

Code (DEC) Description
0 Normal

−1 Execution error

Remote desktop table number 10
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4.10.5 Window Configuration and Operation
Window Configuration
When a connection is normally established between the TSi unit and the server (computer), the remote desktop window of 
the server is displayed on the TSi unit. When disconnecting, a [Disconnected] screen is displayed briefly and then disappears.

Example: When the [Auto-reduction] checkbox is not selected

* The scroll bars (S menu) cannot be displayed while the auto-reduction function is used.

Scroll bars
If the resolution of the server (computer) is higher than that of the remote desktop window display area, hidden parts in the 
area can be displayed by scrolling either horizontally or vertically with the relevant scroll bar.

[S] switch
Pressing this switch shows or hides the [S] menu.

[S] menu
These are special switches for operating the remote desktop window used to perform operations including rotating and 
reducing the size of the display.

Item Description Item Description
ESC Esc key entry ↓ ↓ key entry
SHFT Shift key entry Up Page-up key entry
CTRL Ctrl key entry Down Page-down key entry
ALT Alt key entry R/L OFF: Equivalent to left-clicking the mouse

ON: Equivalent to right-clicking the mouse
ENT Enter key entry Zin Window enlargement:  1/16 → 1/9 → 1/4 → 100% 

(maximum)
← ← key entry Zout Window reduction: 100% (maximum) → 1/4 → 1/9 

→ 1/16
→ → key entry Key Not used
↑ ↑ key entry Rot Window rotation: 90°, 180°, 270°

ESC SHFT CTRL ALT ENT
Up Down

R/L Zin Zout Key Rot

S

Handshaking...

S menu Scroll bars S switch
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Operation Method
The remote desktop window can be operated from the TSi unit by directly tapping on the screen and using a USB mouse and 
USB keyboard.

USB mouse
The left-click button, right-click button, and wheel of a USB mouse are usable.

USB keyboard
The language must be set for the USB keyboard on the Main Menu screen of the TSi unit.

4.10.6 System Memory
The following addresses in the system memory are used to store the data regarding the table number (set in the [Remote 
Desktop Display Setting] window) of the remote desktop window currently displayed and whether connection with the 
remote desktop is established.

4.10.7 Error
[Disconnected.] Screen
If connection between the TSi unit and a server (computer) fails or is disconnected due to a cable disconnection or an error, 
the [Disconnected.] screen appears in place of the remote desktop window. Check the cable and server (computer) and 
attempt reconnection.

Error No.
For details on error numbers that occur during data transfer, refer to the TS2060 Hardware Specifications or the TS1000 Smart 
Hardware Specifications.

When no USB keyboard is used, the on-screen keyboard can be used instead.
To use the standard Windows on-screen keyboard, click the Start menu → [All Programs] → [Accessories] → [Ease of Access] → 
[On-Screen Keyboard] to launch the on-screen keyboard.

USB mouse
USB keyboard

$s Description Value
1380 Remote desktop window display Start-up status 0 : Hidden (disconnected)

1 : Shown (connected)
1381 Remote desktop window display Connection status 0 or greater: Remote desktop table number

−1 : Disconnected
−2 : Connection failure



4  Ethernet Communication Function

4-68

4.10.8 Limitations
License Limitations

• A single license is provided with each TSi unit.
• Take care when managing key codes as they cannot be reissued.

Display Limitations
• Remote desktop window display is only available on screens (screen library) and is unavailable for overlap libraries.
• Multiple remote desktop windows cannot be displayed at the same time. If multiple display areas are concurrently placed 

and the [Display the PC screen at startup of MONITOUCH] checkbox is selected, the display area placed first takes effect.
• While a remote desktop window is displayed, attempting to bring up another window on the same screen will turn off the 

initial window and switch to the next window.
• While a remote desktop window is displayed, any change to the server (computer) resolution will forcibly turn off the 

window.
• When a remote desktop window is hidden, disconnection occurs if the specified remote desktop table number is the 

same even for a different display method.
However, the [Disconnect] switch explained in “Placement of a Display Area to Show Remote Desktop Window” page 4-60 
does not work to turn off the remote desktop window that was displayed by a switch or the macro command.

• If any part placed behind a remote desktop window is updated, the part will be displayed over the window.
• While a remote desktop window is displayed, any switches placed behind the window do not work. (However, they will 

work when the remote desktop window is hidden.)
• The display of a remote desktop window is always based on the upper left corner of the server (computer) screen as the 

start point.
• If a remote desktop window display area shows an image smaller than the area, the margin of the area turns black.
• While a remote desktop window is displayed in a display area, turning it off leaves the area in the color set in the V-SFT.
• When a remote desktop window is displayed by a switch or macro command, tuning it off will clear the window as well as 

its display area.
• When a remote desktop window is initially displayed, the image is scaled to 100%.
• Once a remote desktop window is turned off, the settings for the [S] menu will return to the defaults.
• If disconnection is performed using a switch or macro, the screen is redrawn. Any displayed overlaps also disappear. 

(However, overlaps do not disappear if the [Display Overlap during bit ON] checkbox located at [System Setting] → [Unit 
Setting] → [General Setting] is selected.)

• While a remote desktop window is displayed, switching to the Main Menu screen turns the window off.
• The scroll bars (S menu) cannot be displayed while the screen of a connected server (computer) is displayed using the 

auto-reduction function.
• The auto-reduction function of the TSi unit can display a range of 800*600 (SVGA) to 1024*768 (XGA).
• During auto-reduction display, if the H/V aspect ratio of the remote desktop display area on the TSi unit is 4:3, the display 

can be matched to the size of the remote desktop window. (In all other cases, blank parts of the display area appear filled 
black.)

Other Limitations
• The SET_REMOTEDT macro command for displaying the remote desktop window is not usable as an initial macro.
• When the remote desktop window display function and the touch switch emulation of the RGB display function are used 

at the same time, a USB mouse cannot be used for the remote desktop window.
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4.11 Web Server
4.11.1 Overview

The internal device memory of the TSi unit, device memory of connected equipment (PLC1 to PLC8), and contents of memory 
cards can be monitored using a web browser on a computer connected on the LAN.

• An SHT file can be created in V-SFT by using a table data display. Users are not required to create a file for monitoring 
purposes.

However, this SHT file is a simple file that only shows a table data display. To display titles or allow automatic updates to 
monitoring, users must make additions to the SHT file.

• It is possible to write data to the TSi unit and perform monitoring from a web browser. A CGI function (MemAcs.cgi) 
embedded in the TSi unit is used for this purpose. In this case however, users must create an HTM file.

• Screenshots of screens on the TSi unit can be saved in JPEG format to an SD card. In addition, JPEG data on a storage 
device can also be viewed in a web browser.
The operational status of machines on a production line can be checked from a separate monitoring room via a TSi unit 
on the production floor.

Applicable Models

“Monitoring Table Data Displays” page 4-71

Refer to“Memory Device Access” page 4-73

“JPEG File Display” page 4-77

Model Port Color Other Notes
TS2060i
TS1100Si
TS1070Si

LAN 32K/64K Not available with CUR-03

LAN

SD card or USB flash drive required

V-SFT Web browser
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4.11.2 Notes
Browser Settings
Be sure to deselect the [Automatically detect settings] and [Use a proxy server for your LAN] checkboxes in the LAN settings 
of your web browser.

Example: Windows 7
1) Start Internet Explorer.
2) Click the [Tools] menu and select [Internet Options].
3) Click the [Connections] tab.
4) Click the [LAN settings] button under [Local Area Network (LAN) settings].
5) Deselect the [Use a proxy server for your LAN] checkbox.

Files Types Available for Use on Web Servers
When using the web server function, the SD card in the TSi unit can be accessed from a web browser on your computer.
The files you can access from the web browser are as follows:

* The filenames of the above file types must be specified within 64 one-byte characters (0 to 9, A to Z) and with extensions three characters 
in length. Filenames and extensions that do not comply with this convention cannot be accessed from a web browser.

* SSI (Server Side Include)
This is one method of embedding dynamic information, such as the current date and time, into HTML documents.
Such embedding is described as <!--#exec cgi=“xxx.cgi”-->, <!--#echo var=“DATE_LOCAL”-->. Files with SSI are referred to as SHT/SHTM 
files.

Extension MIME Type Description
htm text/html HTML document
sht text/html SHT file (with SSI)
txt plain Text file
gif image/gif GIF image
jpg, jpe image/jpeg JPEG image
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4.11.3 Monitoring Table Data Displays
The internal device memory of the TSi unit and device memory of PLCs etc. can be monitored using a web browser.
An SHT file, which is required for monitoring in a web browser, can be created by using a table data display in V-SFT.

Creating SHT Files
Create an SHT file using the V-SFT.

Procedure
1. Place the table data display on the screen in V-SFT.

2. Click on the table data to show the handles. If multiple table data displays are required, create them one by one.
3. Right-click and select [Make Browser File].

4. The [Make Browser File] window is displayed. Enter a filename.
* The filename must be within 64 one-byte characters (0 to 9, A to Z). The file cannot be accessed if any other characters are used.

5. Two files are created in the “C:\MONITOUCH\V-SFTV6\WebServ” folder where V-SFT is installed.
- (Filename).sht: File for display in the web browser
- (Filename).txt: Table data file for table data display

6. Save the screen program.
* An SHT file needs to be used because the table data display monitoring function uses SSI. An HTM file cannot be used.
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Saving to a Storage Device
Save the SHT file, which is created in the “C:\MONITOUCH\V-SFTV6\WebServ” folder, to a storage device (SD card or USB 
flash drive) and then perform monitoring using web browser on a computer.
Files can be saved using either Windows Explorer or the storage manager.

When Using the Storage Manager
1. Click [File] → [Storage Manager] in V-SFT.
2. The [Storage Drive Select] dialog is displayed. Select the drive of the storage device.

The [Storage Manager] tab window is displayed.
3. Click [Write to Storage]. The [Write to storage] window is displayed. Select the screen program.
4. Clicking [OK] creates an access folder on the storage device.

At this point, the SHT file (.sht) and text file (.txt) created in the “C:\MONITOUCH\V-SFTV6\WebServ” folder are stored in 
the “\access folder\WEBSERV” folder on the storage device.

* In this case, all files stored in the “C:\MONITOUCH\V-SFTV6\WebServ” folder are saved to the storage device. Delete any unnecessary files.

When Using Explorer
1. Open an Explorer window in Windows.
2. Specify the storage device drive.
3. Copy the SHT file (.sht) and text file (.txt) created in the “C:\MONITOUCH\V-SFTV6\WebServ” folder to the “\access 

folder\WEBSERV” folder on the storage device.

For details on the storage manager, refer to “5 Storage Device”.

Copy



4.11    Web Server

4-73

1

2

3

4

5

6

7

8

9

10

Accessing with a Web Browser
Access the TSi unit, in which the storage device is inserted, from a web browser.

1. Start a web browser on the computer connected via Ethernet.
2. Specify the IP address of the TSi unit and the SHT file as follows. The table data display will appear in the web browser.

• In the web server function, the access folder is the root folder.
• This section assumes that the HTM file is stored in the WEBSERV folder.

4.11.4 Memory Device Access
A web browser can be used to access (read/write) to any device memory, such as the internal device memory of the TSi unit, 
PLC device memory, and temperature controller device memory. To achieve this, users must create an HTM (SHT) file with 
parameters set as shown in the table (page 4-74) to be sent to the TSi unit. Access to the desired device memory from this 
HTM (SHT) file is made possible by specifying the CGI function (MemAcs.cgi) prepared on the TSi unit.

Device Memory Access Flowchart
The procedure of device memory access is shown below.

http://(IP address)/WEBSERV/(filename).sht

CGI

Web browser

Computer

Specify the TSi unit’s IP 
address and the HTM file. 
Send access device memory 
parameters.

Display the received HTM 
file.

Receive Send the HTM file to the 
web browser.

Start CGI

Access to the internal or PLC 
device memory based on the 
parameters.

Display the access result. 
Create and output HTM file.

Receive

TSi
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CGI Function (MemAcs.cgi)
“MemAcs.cgi” is a CGI function prepared for reading/writing from/to the device memory of a device connected to the TSi unit.
The CGI function is executed according to the parameters specified in an SHT file etc.
The CGI function recognizes whether to read or write according to the received parameter values. For reading, it sends a 
monitor table to the web browser. For writing, it sends its writing result to the web browser.

Device Memory Access Parameter List
The following parameters are required in order to start the CGI function (MemAcs.cgi). Always specify the parameter name 
and parameter value correctly. MemAcs.cgi cannot recognize incorrect specifications and will not work correctly.

Parameter Name Description W R
MEM_ACSTYPE Device memory access type 0: Device memory read

1: Device memory write
MEM_MODEL Device memory model The approach to device memory is defined the same as the 

“indirect memory” approach of macros.
For details, refer to the Macro Reference Manual.MEM_TYPE Device memory type

MEM_ADDR Device memory address
Top device memory address to be accessed
(32-bit address supported)

MEM_EXP Expansion code
Only set for required models. Otherwise, set to “0”.

MEM_TRMNO PLC station number in case of the multi-drop connection
MEM_WCNT Number of words to be accessed Data length: 1 word = 1 to 128

Data length: 2 words = 1 to 64
MEM_TBL_LINE Number of lines in a table
MEM_TBL_COLMN Number of columns in a table
MEM_UPDT_TIME Update cycle (unit: second) * No updates when “0” is set.
MEM_WR_DATA Writing data

Set the number of words specified for [MEM-WCNT] with delimiter “,” (comma).
MEM_WRTYPE Writing data type 0: DEC

1: HEX
2: OCT
3: BIN

MEM_DSPTYPE Device memory display type 0: DEC
1: DEC (w/ -sign)
2: DEC (with sign +-)
3: HEX
4: OCT
5: BIN

MEM_KETA Digits for displaying the value in 
device memory

1 to 32

MEM_DCPT Decimal point for the value in 
device memory

0 to 10

MEM_DLEN Device memory data length 0: 1 word
1: 2 words

MEM_INPUT Input type 0: DEC
1: BCD
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Example of Device Memory Access
Creating HTM Files
Create an HTM file with which the read/write parameters are set using the radio button menu or combo box, and save the file 
to the “C:\MONITOUCH\User\WebServ” folder.

Example:

Device memory cannot be accessed with just the above example. A file must be created to set all necessary parameters for 
reading (or writing) by referring to the parameter list on “Device Memory Access Parameter List” page 4-74.

Saving to a Storage Device
Save the created HTM file to a storage device. For details on saving, refer to page 4-72.

<HTML>
<BODY>

<FORM METHOD="GET" ACTION="../MemAcs.cgi">

<DT>Way to Access Memory
<DD>                    
<INPUT TYPE="radio" NAME="MEM_ACSTYPE" VALUE=0 CHECKED>read<BR>
<INPUT TYPE="radio" NAME="MEM_ACSTYPE" VALUE=1>write

<DT>Access Memory<DD>
<SELECT SIZE=1 NAME="MEM_MODEL">
<OPTION VALUE=0 SELCTED>Internal Memory
<OPTION VALUE=1>PLC Memory
<OPTION VALUE=2>Memory Card Memory
<OPTION VALUE=3>Temp. Control Memory
</SELECT>

<DT>Memory Address             
<DD>                    
<INPUT TYPE="text" SIZE=6 MAXLENGTH=20 NAME="MEM_ADDR" VALUE=100><BR>  

<INPUT TYPE="submit" NAME="submitname" VALUE="Execute">
<INPUT TYPE="reset" VALUE="Clear">

</FORM>

<BR>

<FONT SIZE=4>|<A HREF="./index.htm">Back</A>|</FONT>

</BODY>
</HTML>

Starting the entry form
Use this as is.

Radio button menu

Combo box

Key board entry

Sending the entered data
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Accessing with a Web Browser
1. Start a web browser on your computer and access the storage device inserted into the TSi unit.

2. The created HTM file is displayed.

3. Set the access device memory parameters in each entry field and press the [Write] button. The TSi unit creates the 
following HTM file and sends it to the web browser.
• Device memory access type is “0: Device memory read”

• Device memory access type is “1: Device memory write”

For details on the access method, refer to page 4-73.

The message varies 
depending on the access 
result.
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4.11.5 JPEG File Display
Screenshots of screens displayed on the TSi unit can be saved in JPEG format to the “\access folder\HDCOPY” folder on a 
storage device. Using the web server function, these JPEG files can be displayed in a web browser.

These files can be displayed with or without using an HTM file. When using an HTM file, users must create the HTM file.

Without Using an HTM File
If not using an HTM file, specify the “folder name/filename” directly from the web browser to display a JPEG file.

Enter text in the following format into the address field of the web browser.

* In the web server function, the access folder is the root folder.

Example:

http://(IP address)/(folder name)/(filename).jpg
HDCOPY

JPEG

IP address: 10.91.130.178
When displaying HD0000.jpg in the “HDCOPY” folder:
http://10.91.130.178/HDCOPY/HD0000.jpg
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Using an HTM File
If using an HTM file, a title can be displayed in addition to the JPEG file. By using the HTM refresh command, periodic updates 
can also be performed.

Creating HTM Files
Example: Display a screenshot image in the web browser and create an HTM file to be displayed while updating 
periodically.

In the HTM file example shown on the previous page, the JPEG file directory is specified as “../HDCOPY/HD0000.jpg”.
This file specification method uses a relative path. Another file specification method that can be used is the absolute path.

<HTML>
<META HTTP-EQUIV="refresh" CONTENT="5;URL=DDD.htm">

<HEAD><TITLE>JPEG Monitor</TITLE></HEAD>

<BODY>
<CENTER>
<H1>Screen0</H1> 
<P>
<IMAGE SRC="../HDCOPY/HD0000.jpg">

</P>
</CENTER>
</BODY>
</HTML>

<HTML>
<META HTTP-EQUIV="refresh" CONTENT="5;URL=CCC.htm">

<HEAD><TITLE>JPEG Monitor</TITLE></HEAD>

<BODY>
<CENTER>
<H1>Screen1</H1>
<P>
<IMAGE SRC="../HDCOPY/HD0001.jpg">

</P>
</CENTER>
</BODY>
</HTML>

JPEG file directory / filenameImage display

Title to be displayed on the top 
of the screen

File name to be 
displayed next

Update cycleAuto update command

JPEG file directory / filenameImage display

Title to be displayed on the top 
of the screen

File name to be 
displayed next

Update cycleAuto update command

Page title

AAATEST

DAT0000

BITMAP
CARD
DSP
FONT
HDCOPY
JPEG
MEMO
RECIPE
SAMPLE
SRAM
WAV
WEBSERV

HD0000.jpg
HD0001.jpg
     :

CCC.htm
DDD.htm
AAA.sht
    :

../HDCOPY/HD0000.jpg

Storage device

In the web server function, the access folder is the root folder.
This example assumes that an HTM file is stored in the “WEBSERV” 
folder.

(Access folder)

Move to the folder one level higher

Filename
Specify the folder name
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Saving to a Storage Device
Save the created HTM file to a storage device.

Accessing with a Web Browser
Start a web browser on your computer and access the storage device inserted into the TSi unit.

Enter text in the following format into the address field of the web browser.

Example:

HD0000.jpg is displayed initially. HD0001.jpg and HD0000.jpg are then repeatedly displayed in turn for five seconds each.

For details on saving, refer to page 4-72.

http://(IP address)/WEBSERV/(filename).htm

IP address: 172.16.200.108
When displaying CCC.htm in the “WEBSERV” folder:
http://172.16.200.108/WEBSERV/CCC.htm

After 5 seconds

After 5 seconds
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4.12 VNC Server
4.12.1 Overview

• The TSi supports the VNC server function. This means that the screen of the TSi unit can be monitored and remotely 
operated with ease from a PC on the network. Settings can also be configured to allow monitoring only.

• The TSi unit to be remotely operated is referred to as the “server” and the PC that performs remote operations is referred 
to as the “client”.

• Simultaneous access from multiple clients is prohibited. All connections are 1:1.

• VNC client software (VNC viewer) must be installed on the VNC client.
• The TSi employs password authentication. When a client accesses a TSi unit, a password must be entered.

The password is to be registered in the screen program using V-SFT.
• Remote operations on the display of the TSi unit can be performed on all RUN mode, Main Menu, and error screens.
• If a network camera is connected to the TSi unit, the network camera image can also be displayed on the VNC client.

4.12.2 Specifications
TSi Unit (Server)

Restrictions
• The function is available only when the TSi color setting is 64k or 32k colors.
• The connection between the TSi and VNC client is 1:1.

If the TSi receives connection requests from multiple VNC clients, the currently connected client takes priority.
• When the screen program is in portrait orientation, the display on the VNC client remains in the landscape orientation 

without being rotated.
• The following operation cannot be performed on the TSi unit when a VNC client is connected:

- Main Menu screen → [I/O Test] → [Switch Check] → [Adjust]
• When the Main Menu screen is displayed while a VNC client is connected, a light blue rectangle blinks at the bottom right 

of the screen.

LAN

VNC server: TS2060i VNC client: PC

VNC client software

VNC client
software

VNC: Virtual Network Computing

Item Description Remarks
Port used LAN Not available with CUR-03.
Port number 5900 Fixed
Number of client connections 1 If the server receives connection requests from multiple clients, the 

currently connected client takes priority.
Authentication method Password authentication
Number of registered users A maximum of 2 users Remote operation permitted: 1 user

Remote monitoring only: 1 user
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4.12.3 Setting Procedure
1. Connect the TSi unit and the VNC client device to the network.

For details on VNC client device settings, refer to the relevant device manual.

2. Register VNC server settings to the screen program using V-SFT and transfer the screen program to the TSi unit.
Register the [User Name] and [Password] from [System Settings] → [Ethernet Communication] → [VNC Server].

3. VNC client settings
- Install the VNC viewer software.

4. Start the VNC viewer and perform remote monitoring and operation.

4.12.4 V-SFT Settings
VNC Server Settings
Register the [User Name] and [Password] from [System Setting] → [Ethernet Communication] → [VNC Server Setting].

“4.2 TSi Unit IP Address Settings” page 4-2

“4.12.4 V-SFT Settings” page 4-81

“4.12.5 VNC Client Settings/Operations” page 4-82

“Connecting to the VNC Server” page 4-82

Item Description
Use VNC server function Select this checkbox to use the VNC server function.
Allow remote operation Select this checkbox to register a user who is allowed remote operations.

User Name Register a user name. Up to 16 one-byte alphanumeric characters
Password Register a password. Up to 8 one-byte alphanumeric characters and symbols

Only remote monitor Select this checkbox to register a user who is allowed only remote monitoring.
User Name Register a user name. Up to 16 one-byte alphanumeric characters
Password Register a password. Up to 8 one-byte alphanumeric characters and symbols
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4.12.5 VNC Client Settings/Operations
VNC Viewer Software
VNC viewer software must be installed on the VNC client in order to perform remote monitoring and operation of the TSi unit 
from the VNC client. Install the software in advance.

* For details on the system requirements of each software, visit the software’s website. The method for obtaining the software differs 
depending on the client device. Obtain the software by referencing the specifications of the relevant device.

* Communication may be unstable depending on the OS version of the client, VNC viewer version, and operating environment. Always 
perform tests in the usage environment.

Connecting to the VNC Server
This section explains connecting to the VNC server from a PC on the network using Ultra VNC as an example.

Ultra VNC
Install Ultra VNC on the PC and connect the TSi unit and PC to the network in advance.
1. Start the Ultra VNC application via Windows Start menu → [UltraVNC] → [UltraVNC Viewer].
2. Enter the IP address of the TSi unit into the [VNC Server] field and click [Connect].

3. Enter a password on the user authentication screen and click [Log On]. The VNC viewer screen is displayed.

Software OS Remarks
Ultra VNC Windows 2000 / XP / Server 2003 / Vista / 7 / 8 Free software
Tight VNC Windows XP (32 bit)
Simple Remote Android Free software 

Hakko Electronics
(dedicated to MONITOUCH)iOS 13.2 or Later

LAN

IP192.168.0.10 IP192.168.0.20

VNC server

Ultra VNC

Set to 0 when using the forced 
disconnection function ($s1681) from 
the TSi unit.
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4. Operating the VNC viewer screen will change the display on the TSi unit as well.
* If logged on with the password for [Only remote monitor], remote operations are not allowed. The viewer screen changes to reflect 

operations performed on the TSi unit.

Keyboard Entry
If remote operations are permitted from the VNC client, the following keyboard entry can be performed in addition to 
operations on the viewer screen.

• Entry screens: numerical and text entry

4.12.6 System Device Memory ($s)
The following describes the system device memory associated with the VNC server function.

Address Description Remarks
$s1674 VNC client status

0: Disconnected
1: Connected

← TSi

$s1681 VNC access
0: Permitted
Other than 0: Prohibited (forcible disconnection if client is connected)

→ TSi
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5.1 Overview
5.1.1 Connections

The SD card interface and USB-A port are provided on the TS unit as standard features. Connecting commercially available SD 
cards and USB flash drives (referred to hereafter as storage devices) enables them to be used for a variety of functions 
including screen program transfer, saving of logging data, and saving of screenshot images.

Applicable Models

• TS2060i (use of storage devices is not available with TS2060)

• TS1100Si / TS1070Si / TS1070

Model Storage Device Connection Port
TS2060i SD card / SDHC card Built-in SD card socket

USB flash drive USB-A
TS2060 Not available -
TS1100Si
TS1070Si
TS1070S

USB flash drive USB-A

Enlarged viewSD card orientation

USB flash drive

Back

Front

USB flash drive

TS1100Si TS1070Si /TS1070S
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5.1.2 Storage Device Specifications
Supported Storage Devices
The following storage devices can be used.

Notes on Handling Storage Devices
• When inserting an SD card into the unit, make sure to insert it in the correct orientation. Failure to do so may damage the 

SD card or the slot on the unit.
• Only remove a storage device when the Main Menu screen is displayed or after pressing the [Storage Removal] switch.
• Do not turn off power to the unit when a storage device is being accessed. Doing so may destroy data on the SD card.
• Make a backup copy of storage devices at regular intervals.
• If a disk error occurs and data read/write operation is disabled, execute ScanDisk on Windows and try to restore the disk. 

If the disk cannot be restored, format the storage device. If you format the device, data on the device is completely lost. 
(For details on scanning the disk or Windows operations, refer to the Windows help information.)

• The number of write cycles for a storage device is limited. Consequently, frequent writing at short intervals may shorten 
the service life of storage devices. When using a storage device to save trend/alarm data, take the monitoring interval into 
consideration. Be sure to avoid constantly writing to a storage device with the CYCLE macro command.

• Note that the amount of the data to be written should not exceed the capacity of the storage device. In particular, when 
using functions to write data from the TS unit to a storage device, such as backing up trend/alarm data, saving screen 
programs, saving screenshot images, or transferring recipe data, always consider the capacity limit of the storage device. 
Note that the amount of free space on a storage device can be checked with system device memory.

• If a screen program that uses storage device functions loaded onto the TS unit, be sure to insert the relevant storage 
device before running the screen program.

Type Capacity File System
SD card Max. 2 GB FAT, FAT32
SDHC card 4 - 32GB FAT32
USB flash drive Max. 32GB FAT, FAT32
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5.2 Access Folders
5.2.1 Access Folders

• Access folders are folders which are accessed regularly in RUN mode.
An access folder is created when a screen program is written using storage manager.
Access folders are also created automatically when a formatted storage device is connected to the TS unit.

• The access folder name is specified in the screen program.
Location of setting: [System Setting] → [Other] → [Storage Setting] → [Access Folder Name]

• If creating access folders with names differing by each screen program, multiple screen programs can be saved in 
respective folders as long as there is sufficient capacity on the storage device.

“Storage Device Settings” page 5-4

DAT0000

DAT0001

DAT0002

BITMAP

SRAM

CARD
DSP
FONT
HDCOPY
JPEG
MEMO

RECIPE
OPELOG

SAMPLE
SCRN
SNAP

WEBSERV

MSG

Storage device

Access folder

Access folder
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5.2.2 Storage Device Settings
Settings including the storage connection target, access folder name, and other storage-related items are configured in the 
[Storage Setting] window.
[System Setting] → [Other] → [Storage Setting] 

*1 These are recognized as uppercase characters. If inputting lowercase characters on the editor screen, they are converted into uppercase 
characters when [OK] is clicked, and are recognized as uppercase characters on MONITOUCH.

*2 Screenshot images are saved in BIN format if this checkbox is not selected. These files can be converted to BMP files using the storage 
manager in V-SFT-6.

Item Description
Storage Connection Target Select the location of the storage device for access in RUN mode.

Built-in Socket
USB Port

Access Folder Name Set a different folder name for each screen program. (default: DAT0000)
32 one-byte characters or less (not case-sensitive) *1 

If the same folder name already exists, data will be overwritten.
Range of Patterns to be 
Saved to storage

Store pattern data on the storage device.

Range of Messages to be 
Saved to storage

Store messages on the storage device.

Range of Screens to be Saved 
to storage

Store screens on the storage device.

Store Manual Font Setting to 
storage

Store manual font settings for gothic fonts on the storage device.

Store 3D Parts in storage Store images for 3D parts on the storage device.
Store Windows Font in 
storage

Store Windows fonts on the storage device.

Format Buffering Area 
Automatically

Select this checkbox when storing trend and alarm history data on a storage device.
For details, see “7 Trend” and “8 Alarm” in TS Reference Manual 1.

Store HDCOPY Macro in JPEG 
Format *2

Enabled when [Edit Model Selection] → [Color] is set to 128 colors, 16-tone monochrome, or monochrome.
Store screenshot images as JPEG files.

Use Password When 
Transferring Screen to 
storage from Display

Password: Maximum of 6 one-byte numeric characters
A password can be set for when transferring data from the TS unit to a storage device on the Main Menu → 
Storage Transfer screen. This setting is valid even if no password is set.
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5.2.3 Folder Configuration
The following table lists the folder names and names of files in each folder.

Access folder (DAT0000)

*1 File type (JPEG/BIN) can be selected using [Storage Setting] for 128 colors, 16-tone monochrome, and monochrome display
*2 Filename: 64 or less one-byte numerals or uppercase alphabetic characters
*3 When using the web server: TS ← storage device
*4 TS ⇔ storage device for the BIN file directly under the SAMPLE folder
*5 Refer to “13.2 Memory Card Function” in TS Reference Manual 1.

Automatic upload (DSPDEF)

Folder Name Description Filename Transfer Direction Refer to
BITMAP Pattern data BMP0000.BIN to BMP1023.BIN TS ← storage device page 5-12
CARD Recipe data using the 

memory manager function
MCMHEAD.BIN
MCMxxxx.BIN

TS ⇔ storage device *5

DSP Screen program DSP0000.BIN TS ⇔ storage device page 5-7
FONT Gothic fonts and 

multi-language fonts
xxxxxx.FTD TS ← storage device page 5-12

HDCOPY Screenshot images *1 HD0000.JPG to HD9999.JPG
HD000~yy.JPG to HD999~yy.JPG
(arbitrary filename).JPG *2

TS → storage device *3 page 5-17

JPEG JPEG files JP00000.JPG to JP32767.JPG
(arbitrary filename).JPG *2

TS ← storage device page 5-15

MEMO Memo pad data MEM0000.BIN to MEM0007.BIN TS ⇔ storage device page 5-18
MSG Message files MSGxxyyy.BIN

MSGxxyyy.TXT
TS ← storage device page 5-12

page 5-14
OPELOG Operation log files OPELOG_hhmmss.BIN TS ⇔ storage device page 5-16
RECIPE Recipe data REC0000.CSV to REC9999.CSV

(arbitrary filename).CSV *2
TS ⇔ storage device page 5-16

SAMPLE Trend sampling
Data sampling
Alarm tracking
Alarm logging

SMPxxxx.BIN
SMPxxxx.CSV
(arbitrary filename).CSV *2

TS → storage device *4 page 5-16

Title file SMHxxxx.CSV TS ← storage device
SCRN Header file SCHEADER.BIN TS ← storage device page 5-12

Screen file SC0000.BIN to SC9999.BIN
Component parts
(Macro blocks)

MCR0000.BIN to MCR1023.BIN

Component parts
(messages)

MSG0000.BIN to MSG0011.BIN

3D part file 3D0001.BIN to 3D1023.BIN
Windows font file
(for screen creation)

WFS0000.BIN to WFS4095.BIN

Windows font file (messages) WFM0000.BIN to WFM4095.BIN
SNAP Network camera

BANNER snapshot images
VD00000.JPG - VD32767.JPG TS → storage device *3 page 5-17

SRAM SRAM backup data SRM0000.BIN TS ⇔ storage device page 5-18
WEBSERV Files accessible from a web 

browser
*.SHT, *.HTML, *.TXT etc. TS ← storage device page 4-69

DSPDEF Description Filename Transfer Direction Refer to
DSP File for automatic uploading DSPDEF.bin TS ← storage device page 5-9
Other folders Same as the access folder
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5.3 Function Descriptions
5.3.1 List of Functions

The following table lists the functions used by storage devices. For details, refer to the corresponding reference.
Function Refer to

Saving and transferring screen programs page 5-7
Automatically uploading screen programs page 5-9
Reduction of screen program data size Storing pattern (bitmap) data page 5-12

Storing screen data
Storing 3D parts
Storing Windows fonts
Storing gothic fonts
Storing message data page 5-12, page 5-14

Storing JPEG files page 5-15
Recipe data page 5-16, “15 Recipes” in TS Reference Manual 1
Storing trend sampling/data sampling data page 5-16, “7 Trend” in TS Reference Manual 1
Storing alarm tracking/alarm logging data page 5-16, “8 Alarm” in TS Reference Manual 1
Memory manager function “13.3 Memory Card Function” in TS Reference Manual 1
Operation logs page 5-16, “2 Operation Log”
Saving screenshot images page 5-17, Macro Reference Manual
Saving network camera images (BANNER) page 5-17, “1.2 Network Camera”
Memo pad data backup page 5-18, “13.1 Memo Pad” in TS Reference Manual 1
SRAM data backup page 5-18, TS2060 Hardware Specifications or TS1000 Smart 

Hardware Specifications
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5.3.2 Screen Program Transfer
Screen programs can be transferred between the TS unit and a storage device.
Because multiple screen programs can be saved on a storage device, the screen program for display can be switched as 
required.
This section describes how to read and write data between a PC and a storage device. For details on reading and writing 
between a storage device and the TS unit, refer to the TS2060 Hardware Specifications or the TS1000 Smart Hardware 
Specifications.

PC → Storage Device Writing
1. Start V-SFT.
2. Click [File] → [Storage Manager]. The window for specifying a drive is displayed.
3. Specify the drive where the storage device is inserted and click [OK]. The [Storage Manager] window *1 is displayed.

*1 Storage manager
The storage manager is an application that facilitates writing of TS screen programs to a storage device, and importing of data from a 
storage device for conversion into other file formats. For details, refer to “5.4 Storage Manager” page 5-19.

4. Click [Storage Setting] → [Write to Storage]. The [Write to storage] window is displayed.
Configure the following settings.

Item Description
Write Data Being Edited Write the screen program that is open (being edited) in V-SFT.

A

B

C

DSP
DSP0000.bin

DSP
DSP0000.bin

DSP
DSP0000.bin

Storage device
Access folder name

Multiple screen programs can be stored using different access folder names.

Screen program B
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5. When the settings are complete, click [OK]. A “DSP0000.BIN” file is saved to “(access folder)\DSP” on the storage device. 
The “DSP0000.BIN” file contains the screen program, system program, fonts, I/F driver etc.

Storage Device → PC Reading
1. Start V-SFT.
2. Click [File] → [Storage Manager]. The window for specifying a drive is displayed.
3. Specify the drive where the storage device is inserted and click [OK]. The [Storage Manager] window is displayed.
4. Check that “DSP0000.BIN” exists in the “DSP” folder in the access folder, and select the file.
5. Right-click on the file and select [Put BIN File Back].

6. The window shown below is displayed. Specify the folder to save in and the filename and click [Save].

Path of Screen Data File to Be 
Converted

Select the screen program for writing to the storage device from the [Open] button.
[Screen Data File (*.V8)]

DSP0000.BIN File Comment Add a comment to the screen program file (DSP0000.BIN) written to the storage device.
This comment can be checked via the file’s [Property] window.

Automatic Upload (This is not for screen program transfer.)_
Do Not Overwrite Port No. 
Table/FROM Backup Area

Select this checkbox to prevent existing values in the station number table or existing values in the 
FROM area from being changed when transferring a screen program from a storage device.

Item Description
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5.3.3 Automatically Uploading Screen Programs
When a storage device is inserted and the power is turned on, the screen program is automatically uploaded.
This allows the screen program to be easily updated without bothering the operator.

PC → Storage Device Writing
1. Start V-SFT.
2. Click [File] → [Storage Manager]. The window for specifying a drive is displayed.
3. Specify the drive where the storage device is inserted and click [OK]. The [Storage Manager] window *1 is displayed.

*1 Storage manager
The storage manager is an application that facilitates writing of TS screen programs to a storage device, and importing of data from a 
storage device for conversion into other file formats. For details, refer to “5.4 Storage Manager” page 5-19.

For the recommended capacity of a storage device, refer to “5.1.2 Storage Device Specifications” page 
5-2.

Data1 Data2
Loading from Storage. 50

120
350

DSPDEF

DAT0000

DSP
DSPDEF.bin

Power OFF Power ON

Insert a storage device
and turn DIP switch 1 ON.

When the power is turned 
on, the screen program is 
automatically transferred.

Storage device

Folder for automatic uploading

Transfer 
complete
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4. Click [Storage Setting] → [Write to Storage]. The [Write to storage] window is displayed.
Configure the following settings.

5. When the settings are complete, click [OK]. A “DSPDEF.BIN” file is saved to “DSPDEF\DSP”. The “DSPDEF.BIN” file contains 
the screen program, system program, fonts, I/F driver etc.

Operation on the TS Unit
After storing data on the storage device, import the data into the TS unit according to the following procedure.

1. Turn off the TS unit.
2. Set DIPSW1 on the TS unit to ON.
3. Insert the storage device into the TS unit.
4. Turn on power to the TS unit. After a “Data Loading” message, a “Loading from Storage. Do not power off the unit.” 

message is displayed, and then the screen program saved to the storage device is written.
When transfer is complete, the RUN screen (or Main Menu screen) is displayed automatically.

* When both an SD card and a USB flash drive have a DSPDEF folder, the USB flash drive takes priority.

Item Description
Write Data Being Edited Write the screen program that is open (being edited) in V-SFT.
Path of Screen Data File to Be Converted Select the screen program for writing to the storage device from the [Open] button.

[Screen Data File (*.V8)]
DSP0000.BIN File Comment Add a comment to the screen program file (DSP0000.BIN) written to the storage 

device. This comment can be checked via the file’s [Property] window.
Automatic Upload Create an automatic upload file.

System Program Transfer Select this checkbox when uploading system program files together with the screen 
program.

Run after System Program 
Transfer

Automatically switch MONITOUCH to RUN mode after automatic upload is complete.

Do Not Overwrite Port No. Table/FROM Backup 
Area

Select this checkbox to prevent existing values in the station number table or existing 
values in the FROM area from being changed when transferring a screen program 
from a storage device.
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Notes on Write Operations
• When using the “DSPDEF” screen program for automatic uploading, only one type of data can be stored per storage 

device.
• If the storage device is removed after automatic uploading and the power is turned off and on again, the message “Insert 

Storage in TS.” is displayed and the TS unit does not start correctly. Insert the storage device or set DIPSW1 to OFF, and 
then turn the power off and back on.

• Once automatic uploading has been performed, the screen program that was written to the TS unit (including I/F drivers, 
fonts, etc.) is overwritten by the screen program that was automatically uploaded. Note that even if the storage device is 
removed and DIPSW1 is set to OFF again, it is not possible to restore the state before to the upload.
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5.3.4 Reducing Screen Program Data Size
Part of the screen program data, such as patterns and messages, can be stored to a storage device. This can reduce the size of 
the actual screen program data.

• Screen
• Pattern files (bitmap)
• Messages (BIN files, TXT files *1)
• 3D parts
• Windows fonts
• Gothic fonts (manual setting fonts)
*1 Messages can be saved to a storage device as a BIN file or TXT file. For details on saving a TXT file, refer to “5.3.5 Storing 

Messages (TXT Files)” page 5-14.

File Location and Filename

PC → Storage Device Writing
1. Click [System Setting] → [Storage Setting].

The [Storage Setting] window is displayed.
2. Select the items to save to the storage device. When the settings are complete, click [OK] and save the screen program 

file.

3. Click [File] → [Storage Manager]. The window for specifying a drive is displayed.
4. Specify the drive where the storage device is inserted and click [OK]. The [Storage Manager] window is displayed.

Item Filename Directory
Patterns BMPxxxx.BIN (xxxx: 0000 to 1023) (Access folder)\BITMAP
Messages (BIN) MSGxxyyy.BIN

(xx: Language number 00 to 16)
(yyy: Message group number 000 to 127)

(Access folder)\MSG

Header SCHEADER.BIN (Access folder)\SCRN
Screen Screen SCxxxx.BIN (xxxx: 0000 to 9999)

Component parts
(macro blocks)

MCRxxxx.BIN (xxxx: 0000 to 1023)

Component parts
(sampling messages)

MSGxxxx.BIN (xxxx: 00 to 11)

3D parts 3Dxxxx.BIN (xxxx: 0 to 1023)
Windows fonts Graphics WFSxxxx.BIN (xxxx: 0 to 4095)

Message WFMxxxx.BIN (xxxx: 0 to 4095)
Gothic fonts and multi-language fonts xxxxxx.FTD (Access folder)\FONT

Select items to save.
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5. Click [Storage Setting] → [Write to Storage]. The [Write to storage] window is displayed.

6. If the screen program is currently being edited, select the [Write Data Being Edited] checkbox.
If the screen program is not the one currently opened with V-SFT, deselect the [Write Data Being Edited] checkbox and 
select the relevant screen program from the [Open] button.

7. When the settings are complete, click [OK]. The file is saved to the access folder.

Operation on the TS Unit
Connect a storage device to the TS unit. When opening a screen program on the TS unit, the storage device will automatically 
be referred to for showing the screen.

• If screen data is not stored correctly on the storage device or a storage device is not connected to the TS unit, the TS unit 
will operate as if there is no screen.
If calling a screen using a switch with [Screen Change-over] selected for [Function], a short intermittent beep will sound 
and the request will not be processed. If using a [Read Area] from the PLC to specify a screen, the screen will not 
changeover. (If immediately after power-on, the “Screen No. Error” screen will be displayed.)

• Screen data stored in a storage device takes longer to display than data stored in the MONITOUCH flash memory.
• If 3D parts are not stored correctly on the storage device or the storage device is not connected to the TS unit, 3D parts 

will not be displayed.
• If Windows fonts are not stored correctly on the storage device or the storage device is not connected to the TS unit, 

Windows fonts will not be displayed.
• If patterns are not stored correctly on the storage device or the storage device is not connected to the TS unit, patterns 

will not be displayed.
• When both BIN files (MSGxxyyy.BIN) and TXT files (MSGxxyyy.TXT) coexist in the “MSG“ folder on the storage device, 

reference to TXT files takes priority.

Notes on File Storage
• Up to 512 KB of screen data can be saved to a storage device per screen. The per screen data size can be viewed at [Tool] 

→ [List of Memory Use]. However, the size of the screen data that was selected for storage at [System Setting] → [Other] 
→ [Storage Setting] cannot be viewed on the [List of Memory Use] tab window. We recommend checking the data size 
before configuring [Storage Setting].

• For the restoration of the screen data in the “SCRN“ folder to the original data file (.V8), the “DSP0000.BIN“ file in the 
“DSP“ folder is required. However, if data information of “DSP0000.BIN“ in the “DSP“ folder and “SCHEADER.BIN“ in the 
“SCRN“ folder do not match, the compilation of files from these folders does not take place, and thus the screen program 
is created with screen data in the “SCRN“ folder omitted. For details on the conversion procedure, refer to “BIN File 
Conversion” page 5-21.

• Gothic fonts can be stored on a storage device only when manual font settings are made. The maximum font size that can 
be stored is 2 MB.
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5.3.5 Storing Messages (TXT Files)
Messages (in TXT file format) can be stored on a storage device to reduce the size of the screen program.
Since the messages are in TXT file format, they can be edited even without V-SFT.

* Message files can be stored in BIN and TXT file formats. For details on storing BIN files, refer to “5.3.4 Reducing Screen Program Data Size” 
page 5-12.

File Location and Filename

PC → Storage Device Writing (For TXT Files)
1. Click [System Setting] → [Storage Setting].

The [Storage Setting] window is displayed.
2. Select the [Range of Messages to be Saved to storage] checkbox and specify the range of messages to be stored.

When the settings are complete, click [OK] and save the screen program file.

3. Create files in TXT file format.
Filename: MSGxxyyy.txt (xx: Language number 00 to 16, yyy: Message group number 000 to 127 *1)

*1 TXT files must be created in accordance with the message group numbers specified in the [System Setting] → [Storage 
Setting] window.
Any TXT file with a number not within the specified range will not be recognized.

4. Save “MSGxxyyy.TXT“ files to the “MSG“ folder under the access folder.

Operation on the TS Unit
Connect the storage device to the TS unit. When the screen program is displayed, the stored messages are displayed 
accordingly.

* When both BIN files (MSGxxyyy.BIN) and TXT files (MSGxxyyy.TXT) coexist in the “MSG“ folder on the storage device, 
reference to TXT files takes priority.

Item Filename Directory
Messages (TXT format) MSGxxyyy.TXT

(xx: Language number 00 to 16)
(yyy: Message group number 000 to 127)

(Access folder)\MSG
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5.3.6 Storing JPEG Files
JPEG files can be displayed on the TS unit. Always store JPEG files on a storage device.

JPEG File Location and Filename

Storing Files on a Storage Device
Either Windows Explorer or the storage manager can be used to store files.

Windows explorer
1. Select the JPEG file in Windows Explorer.
2. Execute [Copy] from the right-click menu.
3. Open the storage device drive using Windows Explorer and paste the file.

Storage manager
1. Store the JPEG file to be used in “\MONITOUCH\User\Jpeg” on the PC in advance.
2. Click [File] → [Storage Manager] and write to storage using [Write to Storage].

Operation on the TS Unit
Insert the storage device into the TS unit. The JPEG file on the storage device is displayed in RUN mode.

Filename Directory
JPxxxxx.jpg (xxxxx: 00000 to 32767)
xxxxxxx.jpg (64 or less one-byte characters or 32 or less two-byte characters)

(Access folder)\JPEG

“5.4 Storage Manager” page 5-19

DAT0000
JPEG
JP00000.JPG
JP00001.JPG
JP00002.JPG

Displaying a JPEG file stored on the storage device on the screen.

Copy

Paste
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5.3.7 Transferring Recipe Data
Recipe files (CSV) created on a computer can be stored on a storage device and read or written using a macro or a switch with 
[Recipe] set for [Function].

5.3.8 Storing History Data
History data of trend sampling and alarm tracking can be saved.
If the stored sampling data is converted to a CSV file by using the macro command, you can edit the data easily using 
application software such as Excel.

5.3.9 Operation Logs
Screen operation history records (operation logs) can be output to a storage device. In the event of an error, these stored logs 
allow previous operations to be examined in order to determine the cause of the error.

Refer to “15 Recipes” in the TS Reference Manual 1.

Read Write

DAT0000
RECIPE

REC0000.csv
REC0001.csv
REC0002.csv

Recipe

Storage target folder

“7 Trend” and “8 Alarm” in the TS Reference Manual 1

DAT0000
SAMPLE
SMP0000.BIN
SMP0000.CSV

201604
20160411
20160415

Trend

Refer to “2 Operation Log”.

1 4

2 5

3 6

MENUDAT0000
OPELOG

20160515
OPELOG_181000.BIN
OPELOG_132505.BIN

20160514



5.3    Function Descriptions

5-17

1

2

3

4

5

6

7

8

9

10

5.3.10 Saving Screenshot Images
Screenshot images can be saved to a storage device as JPG files using a macro command.
When it is difficult to connect a printer on the factory floor, screenshot images can be saved to a storage device and printed 
later from a PC.

5.3.11 Saving Network Camera Images
When using a sensor manufactured by BANNER, the currently displayed image can be saved to a storage device as a JPEG file 
by double-tapping the display area. (Snapshot function)

Refer to the Macro Reference Manual.

DAT0000
HDCOPY
HD0000.JPG
HD0001.JPG
HD0002.JPG

500

230

HDCOPY
Macro command

MONITORING

Refer to “1.2 Network Camera”.

DAT0000
SNAP
VD00000.jpg
VD00001.jpg
VD00002.jpg

PASS POWER
READY

FAIL ERROR
TRIGGER

Ethernet
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5.3.12 Saving Memo Pad Data
Data from the memo pad function can be saved to a storage device as BIN files. These files can be converted to BMP files 
using the storage manager in V-SFT.

Memo Pad Data Location and Filename

Operation on the TS Unit
Insert the storage device into the TS unit. When using the memo pad in RUN mode, the memo pad data is automatically 
stored on the storage device.

* When the [Store Area for Memo Pad] at [System Setting] → [Unit Setting] → [SRAM/Clock] is configured, memo pad data 
is stored in SRAM even when a storage device is inserted into the unit.

Timing of Saving
The timing of writing memo pad data to a storage device is as follows.

• When switching the memo pad display using a switch with [+ Block], [− Block], or [Block Call] set for [Function]
• When the screen is changed
• When switching between RUN and STOP (on the Main Menu screen)

5.3.13 SRAM Data Backup
A backup copy of SRAM data can be saved to a storage device to guard against a case in which data may be lost when 
replacing the SRAM battery.

Refer to “13.1 Memo Pad” in the TS Reference Manual 1.

Filename Directory
MEMxxxx.BIN (xxxx: 0000 to 0007) (Access folder)\MEMO

DAT0000
MEMO
MEM0000.BIN
MEM0001.BIN
MEM0002.BIN

MEM0000.BMP
MEM0001.BMP
MEM0002.BMP

Storage deviceMessage board

Convert in storage 
manager in V-SFT-6

Refer to the TS2060 Hardware Specifications or the TS1000 Smart Hardware Specifications.
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5.4 Storage Manager
The storage manager is an application that facilitates writing of data used by the TS unit to a storage device, and importing of 
data from a storage device for conversion into other file formats.

5.4.1 Starting and Ending
Starting
1. Start V-SFT.
2. Click [File] → [Storage Manager]. The window shown below is displayed.

3. Specify the drive where the storage device is inserted and click [OK]. The [Storage Manager] window is displayed.

Ending
1. Click the [X] button on the corner of the [Storage Manager] tab.

2. The screen editing window reappears.
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5.4.2 Writing
The procedure for writing data to a storage device is explained below.
Always use the storage manager to write the data in the following table to a storage device. Other files can be copied using 
Windows Explorer.

Writing Procedure
1. Click [Storage Setting] → [Write to Storage].

2. The [Write to storage] window is displayed.

*1 Station number table
The station number of a counterpart device can be changed in RUN mode when connecting to the following models.
• PLC: Mitsubishi QnH (Q) series (Ethernet) (1 : n connection only)
• PLC: Mitsubishi QnA series (Ethernet) (1 : n connection only)
• PLC: OMRON SYSMAC CS1/CJ1 (Ethernet Auto) (1 : n connection only)
• PLC: OMRON SYSMAC CS1/CJ1 DNA (Ethernet) (1 : n connection only)
• Temperature controller: Fuji Electric F-MPC04P (loader)
• Temperature controller: Fuji Electric F-MPC04S (UM03)

*2 FROM backup area
The FROM backup area is where a backup copy of the data in the PLC or internal device memory can be stored. To retain the data, use the 
macro commands “FROM_RD” and “FROM_WR”. For details on macros, refer to the Macro Reference Manual.

3. When the settings are complete, click [OK]. A BIN file is written to each of the folders under the access folder.

Data Extension Remarks
Screen program .V8 Including screens/component parts/3D parts/Windows fonts/gothic 

fonts/pattern data
SRAM backup data .RAM
Text file .BIN

Item Description
Write Data Being Edited Write the screen program that is open (being edited) in V-SFT.
Path of Screen Data File to Be 
Converted

Select the data for writing to the storage device from the [Open] button.
File extensions: [*.V8], [*.RAM], [*.TXT]

DSP0000.BIN File Comment Add a comment to the screen program file (DSP0000.BIN).
This comment can be checked via the file’s [Property] window.

Automatic Upload Create an automatic upload file.
System Program Transfer Select this checkbox when uploading system program files together with the screen program.
Run after System 
Program Transfer

Automatically switch MONITOUCH to RUN mode after automatic upload is complete.

Do Not Overwrite Port No. 
Table/FROM Backup Area *1 *2

Select this checkbox to prevent existing values in the station number table or existing values in 
the FROM area from being changed when transferring a screen program from a storage 
device.
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5.4.3 BIN Files
Files with the extension “.BIN” are stored under access folders. The storage manager can be used to convert BIN files and 
check file information.

BIN File Conversion
All BIN files can be restored to their original state.
1. Select a file from an access folder.
2. Right-click on the file and select [Put BIN File Back].

3. The window shown below is displayed. Specify the folder to save in and the filename and click [Save].

4. A converted file is created.

Notes
• Note that BIN files in the “BITMAP“, “MSG“, and “SCRN“ folders are required to convert “DSP0000.BIN“ into a V8 file. If 

these files are missing, the V8 file will be created without pattern data and 3D parts.

File Folder Extension After Conversion File Type
DSP0000.BIN DSP .V8 Screen program
BMPxxxx.BIN BITMAP .BMP Pattern file
MSGxxyyy.BIN MSG .TXT Message
HDxxxx.BIN HDCOPY .BMP Screenshots

(128 colors, 16-tone 
monochrome, and monochrome)

MEMxxxx.BIN MEMO .BMP Memo pad
MCMHEAD.BIN CARD .MCD Memory card mode
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BIN File Properties
Information on each BIN file can be checked before conversion.

1. Select a file from an access folder.
2. Right-click on the file and select [Property]. Information on the file is displayed.

• DSP0000.BIN
The file type or system program version of the file can be checked on the [Detail] tab window.

• BMPxxxx.BIN
A bitmap image is displayed.

• MSGxxyyy.BIN
Information on the file is displayed.
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5.4.4 Storage Copy
Copy the data on the storage device.

1. Click [Storage Setting] → [Storage Copy].

2. Specify the storage device drive and click [OK].

3. The following dialog box is displayed. Click [OK].

4. The following dialog box is displayed.
Remove the storage device from the PC and insert another device for saving the copied data. Click [OK].

5. The following dialog box is displayed. Click [OK].

6. When copying is complete, the following dialog box is displayed.
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5.4.5 Storage Device Backup
A backup of data on a storage device can be created.
Any folder can be selected for saving the data.

1. Click [Storage Setting] → [Storage Backup].

2. When the [Copy Target Folder] window is displayed, click [Open] and specify the copy target folder.

Example: When saving in the “Backup” folder in the D drive:

3. Click [OK]. The following dialog box is displayed.

4. Click [OK]. The data on the storage device is copied to the copy target. When copying is complete, the following dialog is 
displayed.

5. Use Windows Explorer to check that the data was copied correctly.

* When copying data from a storage device to the hard disk drive, it can also be copied and pasted using Windows 
Explorer.
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5.5 System Device Memory ($s)
Information about the status and the free space of the storage device inserted into the TS unit is stored in system device 
memory ($s).
 

Addresses Description SD USB-A Device Type
$s497 Storage device error state

*1 *1

← TS

$s498 Free space on storage device (kB)
*1 *1$s499

$s500 [Storage Removal] switch status
*1 *1

$s780 Bitmap file status
*1 *1

$s1030 Storage device error state  $s497 reference -
$s1031 Free space on storage device (kB) -
$s1032
$s1033 [Storage Removal] switch status  $s500 reference -
$s1035 Storage device error state  $s497 reference -
$s1036 Free space on storage device (kB) -
$s1037
$s1038 [Storage Removal] switch status  $s500 reference -
$s1050 Background processing flag

Value JPEG
4 Card not mounted
5 Format error
6 Card size too small
7 Different card type

12 Card write error
15 Disk error (open failure)
16 Card read error

0: Switch OFF (storage removal prohibited)
1: Switch ON (storage removal permitted)

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB LSB

System reserved (“0” setting)

0: File present
1: No file present

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB LSB

Reserved for system (set to “0”) 0: File format matches
1: File format does not match

Sampling data backup
0: Not processed, 1: Being processed

Hard copy macro
0: Not processed, 1: Being processed

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB LSB

System reserved (“0” setting)
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*1 Information on the specified drive is stored at [System Setting] → [Other] → [Storage Setting] → [Storage Connection Target].

$s1051 Background processing completion flag
When processing has been completed (when $s1050 turns OFF), this turns ON.
When the operation has been verified, the user must clear it to zero.

← TS$s1052 Background processing error flag
If an error occurs at the time when processing has been completed (when $s1050 
turns OFF), this turns ON.
When the operation has been verified, the user must clear it to zero.

Addresses Description SD USB-A Device Type

Sampling data backup
0: Not completed, 1: Completed

Hard copy macro
0: Not completed, 1: Completed

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB LSB

System reserved (“0” setting)

Sampling data backup
0: Normal, 1: Error

Hard copy macro
0: Normal, 1: Error

15 14 13 12 11 10 09 08 07 06 05 04 03 02 01 00
0 0 0 0 0 0 0 0 0 0 0 0 0 0

MSB LSB

System reserved (“0” setting)
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6.1 Overview
6.1.1 Fonts

• Select a base language (font) first and then edit the screen using text that can be displayed in the selected font.

• A maximum of 16 languages can be used on the same screen just by switching the text for display.

• Use “Windows fonts” to display two or more languages on a single screen or display Windows-type characters on the 
screen.

For details on font types and supported languages, refer to “6.1.2 Font Types” page 6-2.

For details, refer to “6.1.3 Language Selection” page 6-5.

Japanese (Gothic) TTF Chinese (Simplified) TTF

Example: Registration of screen program “ABC.V8” in three languages

Japanese Chinese (Simplified)Korean

Japanese

English

Chinese (Simplified)

Korean
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6.1.2 Font Types
Fonts are generally divided into three types: bitmap fonts, Gothic fonts and stroke fonts.
Because the mixed use of fonts is not permitted on the TS unit, select one font type in the [System Setting] → [Multi-language 
Setting] → [Font Setting] window.

*1 Only supported on the TS2060i.

Type Size Specification 
Method Features Image

Bitmap font XY magnification 
factor 
specification

Font data designed in sizes of 
16 × 16 dots and 32 × 32 dots 
(two-byte characters).
This font type occupies less 
memory but is not suitable if 
a smoother-line typeface is 
required.

Gothic font 
and stroke 
font *1

Point 
specification

Since the font data of each 
point size is transferred to the 
unit, the required capacity is 
larger than that of bitmap 
fonts while the displayed 
typeface has smoother lines.

In the case of gothic fonts, 
depending on the function 
assigned to the part or item, 
some limitations, such as 
automatic or manual setting 
for fonts, may apply.

- Gothic font

- Stroke font
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Supported Language List
The following table lists the fonts and corresponding languages supported by the TS.

*1 Bitmap fonts, gothic fonts and stroke fonts cannot be used together.
*2 For ISO code support, select [System Setting] → [Multi-language Setting] → [Font Setting], and select the [ISO Code] checkbox when 

selecting the respective font.
*3 Only supported on the TS2060i.

Font Setting *1 Supported Language Supported Character Code
Bitmap font Japanese Japanese, English JIS level-1 and level-2 + 

ANK code
Japanese 32 JIS level-1 + ANK code
English/Western Europe English, Icelandic, Irish, Italian, Dutch, 

Swedish, Spanish, Danish, German, 
Norwegian, Portuguese, Finnish, Faroese, 
French

ISO-8859-1: Latin1
(Extended ASCII code)

Chinese (Traditional) Chinese (traditional), English BIG5 code (A141 to C67E) + ASCII 
code

Chinese (Simplified) Chinese (simplified), English GB2312 code (A1A1 to FEFE) + 
ASCII code

Korean Hangul, English KS code (A1A2 to C8FE) + 
ASCII code

Central Europe Croatian, Czech, Hungarian, Polish, 
Hrvatska (Croatian), Romanian, Slovakian, 
Slovene

CP1250 code
ISO code *2
(ISO-8859-2: Latin2)

Cyrillic Russian, Ukrainian, Kazakh, Bulgarian, 
Uzbek, Azerbaijani

CP1251 code
ISO code *2
(ISO-8859-5: Latin5)

Greek Greek CP1253 code
ISO code *2
(ISO-8859-7: Latin7)

Turkish Turkish CP1254 code
ISO code *2
(ISO-8859-9: Latin9)

Baltic Estonian, Latvian, Lithuanian CP1257 code
Gothic font Gothic Japanese, English JIS level 1 + level 2 + ANK code

Gothic (IBM Extended 
Character)

Japanese, English JIS level 1 + level 2 + IBM extended 
code (FA40 to FC4B) + ANK code

English/Western Europe HK 
Gothic

English, Icelandic, Irish, Italian, Dutch, 
Swedish, Spanish, Danish, German, 
Norwegian, Portuguese, Finnish, Faeroese, 
French

ISO-8859-1: Latin1
(Expanded ASCII code)

English/Western Europe HK 
Times

Stroke Font *3 Japanese stroke Japanese, English JIS X 0201
JIS X 0208
NEC special characters
IBM extensions
NEC selection of IBM extensions

English/Western
Europe stroke

English, Icelandic, Irish, Italian, Dutch, 
Swedish, Spanish, Danish, German, 
Norwegian, Portuguese, Finnish, Faeroese, 
French

CP1252 code

Chinese (Traditional) stroke Chinese (traditional), English BIG5 code (A141 to F9FE) + ASCII 
code

Chinese (Simplified) stroke Chinese (simplified), English GB2312 code (A1A1 to F7FE) + 
ASCII code

Korean stroke Hangul, English KS code (A1A1 to FDFE) + ASCII 
code

Central Europe stroke Croatian, Czech, Hrvatska (Croatian), 
Hungarian, Polish, Romanian, Slovakian, 
Slovene

CP1250 code

Cyrillic stroke Russian, Ukrainian, Kazakh, Bulgarian, 
Uzbek, Azerbaijani

CP1251 code

Greek stroke Greek CP1253 code
Turkish stroke Turkish CP1254 code
Baltic stroke Estonian, Latvian, Lithuanian CP1257 code
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Checking Fonts on Main Menu Screen
The font name is displayed in the position shown below on the Main Menu screen.

Font Names
Font names are displayed in the [Font Setting] window and on the Main Menu screen as listed below:

*1 When the [ISO Code] checkbox is selected in the [Font Setting] window, “CP” disappears from the Main Menu screen.

Font Setting Window Main Menu Screen
Bitmap font Japanese JAPANESE

Japanese 32 JAPANESE 32
English/Western Europe ENGLISH
Chinese (Traditional) CHINESE(TRAD.)
Chinese (Simplified) CHINESE(SIMP.)
Korean KOREAN
Central Europe Central Euro. CP *
Cyrillic Cyrillic CP *
Greek Greek CP *
Turkish Turkish CP *
Baltic Baltic CP

Gothic font Gothic HA Gothic
Gothic (IBM Extended Character) HA Gothic(IBM)
English/Western Europe HK Gothic HK Gothic
English/Western Europe HK Times HK Times

Stroke Font Japanese stroke JAPANESE STROKE
English/Western Europe stroke ENGLISH STROKE
Chinese (Traditional) stroke CHINESE(TRD) ST
Chinese (Simplified) stroke CHINESE(SIM) ST
Korean stroke KOREAN STROKE
Central Europe stroke Cent.Eur. STROKE
Cyrillic stroke Cyrillic STROKE
Greek stroke Greek STROKE
Turkish stroke Turkish STROKE
Baltic stroke Baltic STROKE

Multi-language screen (with multiple fonts selected) MULTI LANG

Font name
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6.1.3 Language Selection
• The language for display can be selected. There are two methods for selecting the language: storing all required fonts on 

the unit and then selecting the language, or storing fonts on a storage device and then selecting the language. (The 
TS2060 does not support use of storage devices.)

• The text for display can be changed even when using a single font, such as German ↔ Italian or Japanese ↔ English. 
Using only one font reduces the space required by the screen program.

• When using a Windows font, it is possible to change only the text. The text for display can be changed using a single font.

• To change the language in the RUN mode, use a switch with [Function] set to “Language changeover” or use the 
“CHG_LANG” macro command.

• The following methods are available for language editing.

For details on settings, refer to “6.2 Setting Procedure” page 6-6.

For details on languages that are supported by each font, refer to “Supported Language List” page 6-3.

For details on settings, refer to “6.2 Setting Procedure” page 6-6.

For details, refer to “6.2.4 Language Selection” page 6-18.

For details, refer to “6.2.3 Language Editing” page 6-12.

For details, refer to “6.4 Convenient Editing Procedures” page 6-24.

Japanese Chinese (Simplified)Korean

Screen program transfer
(required fonts are transferred)

Language 1: Japanese
Language 2: Korean
Language 3: Chinese (Simplified)

Switch function or macro 
used for language selection

Buongiorno Guten Morgen
German Italian

GermanItalianLanguage 1: English/Western Europe
Language 2: English/Western Europe
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6.2 Setting Procedure
This section describes the procedure for configuring settings that allow changing languages that use different fonts when in 
RUN mode.
(The procedure is explained assuming that the setting for Language 1 has been completed.)

1. Font Setting Window
Refer to “6.2.1 Method of Storing Fonts on the Unit” page 6-6
Refer to “6.2.2 Method of Storing Fonts on a Storage Device (Not Available with TS2060)” page 6-8

2. Editing of each language → Refer to page 6-12.
3. Language selection using the switch function or “CHG_LANG” macro command → Refer to page 6-18.

6.2.1 Method of Storing Fonts on the Unit
Font Setting Window
1. Click [System Setting] → [Multi-language Setting] to display the [Font Setting] window.

2. Set a value for [Interface Language]. (Example: set “3” to allow changing between three languages.)

3. Select the desired font type on the [Font] tab window. Under the [Font], select languages to be displayed.
• Example 1: Changing between Japanese, Chinese (Simplified), and Korean

Language 1: Japanese 32
Language 2: Chinese (Simplified)
Language 3: Korean TTF

• Example 2: Changing the displayed text using a single font

• Changing between German and Italian
Language 1: English/Western Europe
Language 2: English/Western Europe

• Changing between Japanese and English
Language 1: Japanese 32
Language 2: Japanese 32
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4. Select a language number for [Initial Interface Language] so that the corresponding language is displayed when a screen 
program is transferred.

5. Select the checkboxes of the required fonts on the [Transfer Font Setting] tab window. More fonts selected for transfer 
results in less capacity available for the screen program. Deselect the checkboxes of any unused fonts.

This completes the necessary settings.

• Example 1

This checkbox for Language 1 
is selected because Language 1 
is always transferred.

• Example 2
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6.2.2 Method of Storing Fonts on a Storage Device 
(Not Available with TS2060)
Font Setting Window
1. Click [System Setting] → [Multi-language Setting] to display the [Font Setting] window.
2. Set a value for [Interface Language].

Example: Set “3” to allow changing between three languages.
3. Select the desired font type on the [Font] tab window. Under the [Font], select languages to be displayed.

• Example: Changing between Japanese, Chinese (Simplified), and Korean
Language 1: Japanese 32
Language 2: Chinese (Simplified)
Language 3: Korean TTF

4. Select a language number for [Initial Interface Language] so that the corresponding language is displayed when the unit 
is changed to RUN mode.

5. Deselect the checkboxes of fonts on the [Transfer Font Setting] tab.

This completes the necessary settings.

This checkbox for Language 1 
is selected because Language 
1 is always transferred.
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Writing Font Files to a Storage Device
To perform a multi-language selection using a storage device, you need to store the font file for Language 2 and later on a 
storage device, and then insert the storage device into the TS unit.
Storing Procedure
The procedure for storing font data for Language 2 and later are described below.

Step 1 With the screen program open, click [System Setting] → [Other] → [Storage Setting]. The [Storage Setting] 
window is displayed.

Step 2 Decide a folder name and enter it into the [Access Folder Name] field. (Maximum of 32 one-byte numerals or 
uppercase alphabetic characters)
This folder name serves to identify which fonts stored on the storage device belong to what screen programs 
on the TS unit.

Step 3 Save the screen program.
Step 4 Insert the storage device into the computer.
Step 5 Click [File] → [Storage Manager]. The following window is displayed.

Specify the drive where the storage device is inserted and click [OK].

Step 6 The storage manager is displayed. Click [Storage Setting] → [Write to Storage].

About the storage manager
The storage manager is an application that facilitates writing of data used on the TS unit to a storage device, 
and importing of data from a storage device for conversion into other file formats.
For details, refer to “5.4 Storage Manager”.

Default: DAT0000
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Step 7 The [Write to storage] window is displayed.
If the screen program is currently being edited, select the [Write Data Being Edited] checkbox.
If the screen program is not the one currently opened in V-SFT, deselect the [Write Data Being Edited] 
checkbox and select the [*.V8] file to write to the storage device by clicking the [Open] button under [Path of 
Screen Data File to Be Converted].

Step 8 Click [OK].
The font files are saved to the “FONT” folder in the access folder (default: DAT0000) on the storage device.

or



6.2    Setting Procedure

6-11

1

2

3

4

5

6

7

8

9

10

Font Filenames
The following font files are stored in the “FONT” folder in the access folder (default: DAT0000) on the storage device.

Inserting this storage device into the TS unit, to which a multi-language screen program has been transferred, enables the 
multi-language selection function.

Font Filename
Japanese Fnt_jpn.ftd
Japanese 32 Fnt_jpn2.ftd
English/Western Europe Fnt_eng.ftd
Chinese (Traditional) Fnt_twn.ftd
Chinese (Simplified) Fnt_chn.ftd
Korean Fnt_kor.ftd
Central Europe Fnt105.ftd
Cyrillic Fnt106.ftd
Greek Fnt107.ftd
Turkish Fnt109.ftd
Baltic Fnt110.ftd
Gothic Fnt006.ftd, Fnt0062.ftd
Gothic (IBM Extended Character) Fnt012.ftd, Fnt0122.ftd
English/Western Europe HK 
Gothic

Fnt008.ftd, Fnt0082.ftd

English/Western Europe HK Times Fnt009.ftd, Fnt0092.ftd
Japanese stroke FNT020.FTD
English/Western Europe stroke FNT021.FTD
Chinese (Traditional) stroke FNT022.FTD
Chinese (Simplified) stroke FNT023.FTD
Korean stroke FNT024.FTD
Central Europe stroke FNT025.FTD
Cyrillic stroke FNT026.FTD
Greek stroke FNT027.FTD
Turkish stroke FNT028.FTD
Baltic stroke FNT029.FTD

* Fonts other than the language 1 font are stored 
on the storage device.
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6.2.3 Language Editing
This section explains the multi-language editing procedure assuming that the version of Microsoft Windows on the PC used is 
capable of editing the required foreign languages. There are three methods for editing languages.

Directly Edit Items
By specifying the interface language number on the [Language] changing menu, text for Language 2 and later can be edited 
on the screen in the same way as Language 1.

• The interface language number can also be changed using the [Display Language] drop-down menu.

Checking the layout
After editing, always check the layout of each language for problems using the [Language] changing menu.
Character properties can be set for each language.
The point size and color settings can be changed for specific languages.

Language 1 Language 2

* Character properties (text 
size and color) can be set for 
each language.

• [View] → [Display Environment]• [View] → [Display Change]
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Editing in the [Multi-language Edit] Window
Display the text in the screen program edited using Language 1 in the [Multi-language Edit] window and directly enter the 
desired text in another language.
Text can be copied and pasted between the [Multi-language Edit] window and Excel (pasted as “Unicode text” in Excel).

Editing location: [Home] → [Registration Item ] → [Multi-language]

* The [Multi-language Edit] window can be used to register up to 1000 lines (No. 0 to 999) per sheet.
When batch copying over 1000 lines (from the second sheet onwards) for editing in Excel, use the following procedure.

Example: Example: Batch copy of languages 1 to 4, numbers 0 to 4647 (4648 rows) in the [Multi-language Edit] window

1) Click [Edit] → [Block Copy]. The [Copy] window is displayed.
Specify target languages and start/end line numbers to copy, and click the [OK] button.

2) Select a cell in Excel and paste.

3) After editing in Excel, select the multi-language columns for Language 2 through 4 by dragging and copy them.

4) Click [Edit] → [Block Paste] in the [Multi-language Edit] window in V-SFT to display the [Paste] dialog. Select the 
languages for pasting and the starting row number, and click [OK].

This completes the editing.
After editing, always check the layout of each language for problems using the [Language] changing menu.
For details, refer to page 6-12.

Language 1 cannot be edited in the [Multi-language Edit] window. To edit Language 1, edit it directly in the 
item settings.

Language 1 cannot be pasted (edited) to the [Multi-language Edit] window. To edit Language 1, edit it directly 
in the item settings.

Target 
languages

Line No.

[Multi-language Edit] window

Default: Last line No.

Excel

All text in numbers 0 to 
4647 (4648 rows) of 
languages 1 to 4 are 
pasted.

* If text cannot be pasted correctly, click [Paste Special] and select [Paste As: 
Unicode Text] to paste. Default: Unicode text

* If text cannot be pasted correctly, click [Paste Special] and select [Paste As: 
Unicode Text] to paste. Default: Unicode text

Language 2 onwards
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Export / Import
Export and import can be performed by compiling all languages in a text file per language.
Using this function allows text to be imported after undergoing translation and editing by viewing multiple languages side by 
side on an Excel spreadsheet.

Outputting a File for Each of the Languages for Switching
Export procedure

1. Select [System Setting] → [Multi-language Setting] to display the [Font Setting] window and click the [Import/Export] tab.

2. Configure the settings as shown below and click [Export].

3. The [Save As] window is displayed.
Enter a filename and click [Save] to output text files.

4. Start Excel and drag and drop the exported text into the Excel window to open it.

5. Register the text in square brackets in column B.

6. After editing, click [File] → [Save As].
Select “Unicode Text (*.txt)” for [Save as type] and save the file using the same filename.

This completes the necessary settings.

Language 1 cannot be pasted (edited) to the [Multi-language Edit] window. To edit Language 1, edit it directly 
in the item settings.

Do not edit column A. Also, do not delete any square brackets in column B. If these are edited or deleted, file 
import will end in failure.

To export to CSV files instead 
of Unicode text files, select 
“*.csv” for [File format].

Language 1

Language 2
Language 3
Language 4

The same number of files 
are created as there are 
languages.

Test_3.txt Drag and drop

Example:

A:

Language 3
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Import procedure

1. Click [System Setting] → [Multi-language Setting] to display the [Font Setting] window.

2. Display the [Export/Import] tab and click the [Import] button.

3. The [Open] window is displayed.
Select “Unicode text (*.txt)” for [Save as type] and open each file one at a time.

This completes the file importing process.
After editing, always check the layout of each language for problems using the [Language] changing menu.
For details, refer to page 6-12.

Be sure to save the files for languages 1 to 4 in the same place and using the original filenames. If any file is 
renamed or the Language 1 file is edited or deleted, file import will end in failure.
The Language 1 file cannot be imported.

Language 1

Import languages 2 to 4 in order.Language 2
Language 3
Language 4
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Outputting All Languages to a Single File
Export procedure

1. Select [System Setting] → [Multi-language Setting] to display the [Font Setting] window and click the [Import/Export] tab.

2. Configure the settings as shown below and click [Export].

3. The [Save As] window is displayed.
Enter a filename and click [Save] to output text files.

4. Start Excel and drag and drop the exported text into the Excel window to open it.

5. Register the text in square brackets in column C, D, and E (red frame).

6. After editing, click [File] → [Save As].
Select “Unicode Text (*.txt)” for [Save as type] and save the file using the same filename.

This completes the necessary settings.

Language 1 cannot be pasted (edited) to the [Multi-language Edit] window. To edit Language 1, edit it directly 
in the item settings.

Do not edit the first to fifth rows (header) and columns A/B (language 1). Also, do not delete any square 
brackets from column C, D, or E. If these are edited or deleted, file import will end in failure.

To export to CSV files instead 
of Unicode text files, select 
“*.csv” for [File format].

Languages 1 to 4 One file is created.

Test.txt Drag and drop

Example:

A:

Languages 1 to 4

Language 2 Language 3 Language 4
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Import procedure

1. Click [System Setting] → [Multi-language Setting] to display the [Font Setting] window.

2. Display the [Export/Import] tab and click the [Import] button.

3. The [Open] window is displayed.
Select “Unicode text (*.txt)” for [Save as type] and open the file.

This completes the file importing process.
After editing, always check the layout of each language for problems using the [Language] changing menu.
For details, refer to page 6-12.

Languages 1 to 4
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6.2.4 Language Selection
There are two ways to change the language.
Use either a switch function or macro command.

Switch Function
The interface language can be changed using a switch with the function [Language changeover].
Each time a [Language changeover] switch is pressed, the interface language switches in the specified order beginning from 
the [Initial Interface Language]. A desired language can also be displayed by specifying its number with an external command.

Location of Settings
Switch settings window → [Function] → [Function] → [Language changeover]

Redraw Timing
When the interface language is switched, the screen is redrawn. The following actions also take place at the same time.

• Open macro, close macro (screen, multi-overlap library)
• Cycle macro (screen)
• $T device memory zero clear (screen)
• Screen interrupt command transfer (PLC type: universal serial) (screen)

Prevent execution of these operations when redraw occurs by selecting the checkboxes as required.
Location of settings: [Screen Setting] → [Screen Setting] → [Show/Hide Item] → [Redraw the screen]

Item Description
Fixed Display the interface language of the specified language number.

Language 1 to 16
Auto Change Change the interface language in the specified order beginning from the [Initial Interface Language] set in 

the [Font Setting] window. Languages that are not selected in the window will not be displayed.
Device Designation Display the interface language of the number stored at the specified device memory.

0: Language 1
1: Language 2
2: Language 3

15: Language 16

If a nonexistent language number is specified for display, an error beep sounds and no action takes place.
The number of interface languages can be checked at [System Setting] → [Multi-language Setting] → [Font 
Setting] window.

:
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SYS (CHG_LANG) Macro Command
The “SYS (CHG_LANG)” macro command can be used to change the interface language.
This command is useful when changing the language using the ON macro of a switch or an external command.

Setting Example
Example: Changing the language by switching the screen

1. Configure the switch ON macro as shown below.

2. Set the function of each switch to “Language changeover: 1”.

This completes the necessary settings.

Detail
Device used

: Setting enabled (indirect designation disabled)  : Setting enabled (indirect designation enabled)
Range

Editing procedure
For details on macro editing, refer to the Macro Reference Manual.

The language is switched over when the screen is changed after the macro command has been executed.
For switching the language on the same screen, use the “RESET_SCRN” macro command.
For details on macro commands, refer to the Macro Reference Manual.

• “Japanese” switch ON macro • “Korean” switch ON macro

Internal Device PLC1 to PLC8 Devices Memory card Constant
F1

Value Remarks
F1 0: Language 1

1: Language 2

15: Language 16

Although the setting range for [Interface Language] in the 
[System Setting] → [Multi-language Setting] → [Font Setting] 
window and [Display Language] in the [Display Environment] 
window is “1” to “16”, the range for “CHG_LANG” is “0” to “15”.

Which language do you prefer?

Japanese Korean

Screen No. 0 Screen No. 1

With either switch, the 
interface language can be 
switched over when screen 
No. 1 is displayed.

Language 1: Japanese
Language 2: Korean

“MOV” macro command
0: Language 1 (Japanese)

“MOV” macro command
1: Language 2 (Korean)

:
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6.3 Detailed Settings
6.3.1 Font Setting

Set the number of languages and fonts for display on the TS unit. Display the following window by clicking [System Setting] 
→ [Multi-language setting].

*1 The available combinations of language selections for the Main Menu screen and [Font] are shown below.
(Only the fonts selected on the [Transfer Font Setting] tab window can be set as the font that can be set on the Main Menu screen.)

Item Description
Local Mode *1 Select the interface language for the Main Menu screen of MONITOUCH. Selectable languages vary with the 

[Font] setting. The interface language can also be selected on the Main Menu screen of MONITOUCH.
Japanese, English, Chinese (Traditional), Chinese (Simplified), Korean

Font Select a font type from [Bitmap font], [Stroke font] and [Gothic font].
Setting Set the languages to use.
Interface Language Set the number of interface languages (1 to 16).

Example: Specifying “5” means Languages 1 to 5 can be set.
Initial Interface Language Select the language to be displayed after changing to RUN mode (1 to 16).

Main Menu screen Font
Japanese, English Japanese

Japanese 32
Gothic
Gothic (IBM Extended Character)

Chinese (Traditional), 
English

Chinese (Traditional)

Chinese (Simplified), 
English

Chinese (Simplified)

Korean, English Korean
English English/Western Europe

English/Western Europe HK Gothic
English/Western Europe HK Times
Central Europe
Cyrillic
Greek
Turkish
Baltic
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6.3.2 Transfer Font Setting

Item Description
Transfer Font Setting Select the checkboxes of the fonts required on the TS unit.

* More fonts selected for transfer results in less capacity available for the screen program. If capacity is 
insufficient, do not select unnecessary fonts.

Font Memory (Used) Displays the total memory size used for the currently selected fonts for transfer.
Font Memory (Available) Displays the memory space still available for fonts.
Screen Memory (Used) Displays the size of the screen program currently being created.
Screen Memory (Available) Displays the space available for the screen program.
Calculate Memory Recalculate the volume of data from the current settings.

Gothic font

Stroke Font

Bitmap font
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6.3.3 Import and Export

Item Description
Export Use this button when editing text for a language other than Language 1 in another application.

For details, refer to page 6-14.
File format Select the type of the file to be exported.
Generate files by language. Set the file creation method used in exporting.

• Selected
The same number of files are created as there 
are languages.

• Unselected
One file is created.

Output strings with [ ]. Selected
Add square brackets to text in output files.

Unselected
Delimit output with commas.
When a file is opened in Excel, some text like the following will not be imported correctly.

Output multiline strings into 
single line.

Set how multiple lines of text located on a switch or lamp are output.

Selected
Lines of text are output in one cell with the line feed code “\n”.

Unselected
Text is output line by line in separate cells.

Import Use this button to import an exported file.
For details, refer to page 6-14.

Language 1

Language 2
Language 3
Language 4

Languages 1 to 4

Leading zeros dropped
Not recognized as a 
character string

Characters on V-SFT Output File
(Standard cell format)

0123 123
+BK #NAME?

Switch Checkbox Output Result
Selected [Error \n Screen]

Unselected [Error]
[Screen]
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6.3.4 Manual Font Settings (When a Gothic Font is Selected)
There are two types of Gothic fonts: one is an automatic setting type and the other is a manual setting type, for which you 
need to set the size manually.
While text and text on switches is displayed using the size specified for the particular item, items that use fonts of the manual 
setting type, which are mainly character and message displays, the font sizes must be specified in their respective setting 
windows, [Char. Display] and [Message Display].

Multi-language selection
• Note that the setting for [ 1-Byte] of each point size of Language 1 (e.g. Gothic) affects the setting of 

Language 2 (e.g. English/Western Europe HK Gothic). Be aware that change one setting also changes the 
other setting.

• About automatic fonts
When multi-language selection is used, the font of the automatic setting type selected for Language 1 will 
automatically be transferred to the TS unit together with the screen program. However, the automatic 
setting type font is not recognized in Language 2 and later.
For Language 2 and later, regard their fonts as those of the manual setting type and set the [Manual Font 
Setting] tab window as necessary.

12 point fonts do not require 
setting.
They are transferred 
automatically.

All settings made for Language 1 also apply to Language 2.
Any changes to the settings for Language 1 affect that for Language 2.

Language 1 Language 2
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6.4 Convenient Editing Procedures
6.4.1 Multi-language Batch Change

Overview
Item properties (text color etc.) for multiple languages from language 1 to 16 can easily be changed at once.

Setting Example
The procedure is explained with an example shown below.

Example: Changing the switch properties on screen numbers 1 and 2 
Text color: black to orange, text property: standard to boldface

1. Select [Tool] → [Multi Language] → [Multi Language Batch Change] to display the [Multi Language Batch Change] 
window.

2. Click the [Select] → [Detail] button under [Range Setting] and specify a screen range of 1 to 2. Click the [Select] → [Detail] 
button under [Target Item] and select the [Switch] checkbox.

3. Select the [Target] checkbox under [Font Setting].

4. In the [Setting on Changes] area, select the [Color] checkbox and select orange. Also select the [Property] checkbox and 
select boldface.

5. Review the settings made in the previous steps, and click [OK].

The settings are updated.

Screen No. 1

Screen No. 2

Screen No. 1

Screen No. 2

Batch 
change
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6.4.2 Multi-language Batch Copy
Overview
If exactly the same text, such as text on switches and item numbers, as language 1 is to be used, it can be easily copied at 
once.

Setting Example
The procedure is explained with an example shown below.

In this example, the text and characters on the switches placed on all screens in language 1 are copied to screens in language 
2.

Language 1: Japanese 32
Language 2: English/Western Europe

1. Select [Tool] → [Multi Language] → [Multi Language Batch Copy] to display the [Multi Language Batch Copy] window.

2. Select [All] under [Range Setting] and set the target items to [Select] → [Detail] → [Text] and [Switch].

3. In the [Font Setting] area in the [Multi Language Batch Copy] window, select [Language 1] for [From] and [Language 2] for 
[To].

4. Batch copy in this example targets all properties. In the [Setting on Changes] area, select the [All] checkbox.

5. Review the settings made in the previous steps, and click [OK].

The settings are updated.

Language 1 Language 2 Language 2

Batch copy

• Before copying • After copying
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6.4.3 Multi-language Reordering
Overview
Interface languages from language 1 to language 16 can be reordered easily.

Setting Example
The procedure is explained with the settings shown below as an example.

1. Select [Tool] → [Multi Language] → [Rearrange Language Order] to display the [Rearrange Language Order] window.

2. Select the language number using the pull-down menus next to [Language 1], [Language 2], and [Language 3].

3. Review the settings made in the previous steps, and click [OK].

The settings are updated.

Language 1: Japanese 32
Language 2: English/Western Europe
Language 3: Chinese (Simplified)

→
→
→

Language 1: English/Western Europe
Language 2: Chinese (Simplified)
Language 3: Japanese 32

Language 1: Japanese 32

Language 2:
English/Western Europe

Language 3: Chinese (Simplified)

Language 1: English/Western Europe

Language 2:
Chinese 
(Simplified)

Language 3: Japanese 32
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7.1 Overview
“Tag editing” is a function used to assign names (tags) to PLC or internal device memory ($u, $L, etc.) used on the TS unit and 
use these names for screen program creation. Tags can be divided into three general types: device memory designated tags, 
variable designated tags, and array designated tags.

7.1.1 Tag Types
Device Designation
Assign a tag name to a PLC device memory or internal device memory, and set the device memory for the part or item using 
the assigned name.

Variable Designation
Assign a tag name to a variable in the variable area of the TS unit, and set the device memory variable for parts and items 
using the assigned names. This is useful for specifying a working area for TS internal processing, such as for macro and 
password functions etc.

For details on the procedure for editing tags, refer to “7.2 Editing Tags” page 7-3.

For details on the editing procedure, refer to “7.2 Editing Tags” page 7-3.

Variables
A “variable” is an area that stores data temporarily. This area is used for temporarily storing data, such as a default value or 
calculated value. The capacity of the variable area is 4096 words for both single words and double words, respectively.
For details, refer to ““Tag” Variable Capacity” page 7-20.

D100
D101

556
600

M0M1

ON Hz

s

Tags
Alarm 1
Frequency
Acceleration 
time

M0

D100

D101

Device memory
Alarm 1

Example: In the [Tag Database Edit] window, register PLC device memory addresses “M0”, “D100” and “D101” with names “Alarm 1”, 
“Frequency” and “Acceleration Time”, respectively.

[Tag Database Edit] window

Set device memory addresses for parts using tags.
Lamp device memory: “Alarm 1” (M0)
Numerical data display device memory: “Frequency” (D100), “Acceleration time” (D101)

Frequency
Acceleration time

Tags

Alarm 1

Frequency

Acceleration time

SRAM

$L
$LD

DRAM

$u/$s/$T/$P

Example: Variable area in the TS unit

“Tag” variable

Use this variable area.
(No device is allocated. The variable is 
identified by a name given freely.)

TS
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Array Designation
The array format can be specified for the tag. If there is multiple data of the same type, they can be registered at one time. 
This makes data management and maintenance easier.
For example, when allocating 10 variables that have the same properties (DEC, 1 word) without using the array format, 10 
variables must be registered individually as shown below.

When registering one tag with 10 elements in the array format, 10 variables can be secured in the same way as shown above. 
If there is multiple data of the same type, the array format can be used to make configuration easier.

In the case of the bit variable:

7.1.2 Importing Tags
Tags or system labels registered in PLC software can be imported using V-SFT and used as tags.

7.1.3 Operation and Scaling Functions (For Numerical Data Display)
• Operation and scaling functions can be used with respect to tags.

By setting these functions to tags, it is possible to register and edit only tags when there is a need for such operations on 
tags that are used in multiple locations and items, thereby contributing to reduction of work hours.

For details on the editing procedure, refer to “7.2.3 Configuring Arrays” page 7-6.

Data 1

Data 2

Data 3

Data 10

Dec

Dec

Dec

Dec

ID0
ID1

ID9

Data 1
Data 2

Data 10

1 word

1 word

1 word

1 word

[Tag Database Edit] window Data  10 pcs.

ID0 Data [10] 
Data [0]
Data [1]
Data [2]

Data [9]

“Data [2]” is automatically 
assigned here.

[Tag Database Edit] window Data [10] = DEC, 1 word

Error 1

Error 2

Error 3

Error 4

Error 5
ID0 Error [5] 

[0] [1] [4] 
[Tag Database Edit] window Error (5) = 1 bit each

“Error [2]” is automatically assigned here.
Array

For details, refer to the following.
• “MITSUBISHI ELECTRIC” page 7-11
• Siemens

- “Model S7” page 7-15
- “Model S7-200” page 7-18
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7.2 Editing Tags
Click [Home] → [Registration Item ] → [Tag Database], specify a group number, and register tags in the [Tag Database Edit] 
window.
There are three ways to edit tags.
Refer to the following.

7.2.1 Direct Registration in the [Tag Database Edit] Window
This section describes the procedure for registering “D100” and “D101” (word device memory) and “M0” (bit device memory) 
of the PLC1 device memory using tags.

1. Click the [Tag] field and register a tag name.

2. Click the [Type] field and select a data type from the list.

* To register the same type of data at once with consecutive device memory addresses, use the array format.

3. Click the [Device] field and set a device memory address.

4. Click the [Comment] field and enter a comment describing the tag.

5. To register a new device memory address using a tag, select another ID number and repeat steps 1 to 5.

This completes the necessary settings.
Tags can be specified in the settings window of each part.

“7.2.1 Direct Registration in the [Tag Database Edit] Window” page 7-3

“7.2.2 Editing in a CSV File” page 7-4

“7.5 Importing Tags” page 7-11

For details, refer to “7.2.3 Configuring Arrays”.

• Word designation: • Bit designation:

(Bit device)

(Word Device)
* -xx is the manually entered part of the bit.

xx: 00 - 15, 00 - 31
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7.2.2 Editing in a CSV File
The data registered in the [Tag Database Edit] window for a screen program can be exported to a CSV file. The CSV file can be 
edited on a PC and then imported back into the screen program. In the example below, changes are made to the data 
registered with ID No. 0 in the [Tag Database Edit] window using Excel.

• Tag: Frequency_setup → Run_status
• Device: D100 → D105
• Comment: Inverter Port No. 1 → ON: RUN, OFF: STOP

1. Click [Edit] → [Tag Export].

2. Enter an arbitrary filename in the window, select “Csv File (*.csv)” for the [Save as type] field, and click [Save].

3. Open the CSV file in Excel, edit each field for ID number 0, and save the file.

4. Open the [Tag Database Edit] window and click [Edit] → [Tag Import].

5. Select the CSV file saved in step 3, select “Csv File (*csv)” for the [Files of type] field, and click [Open].

This completes the necessary settings.

For details on the data in CSV files, refer to “CSV File Configuration” page 7-5.

File types

* IDs that already have tags are overwritten with the imported data.



7.2    Editing Tags

7-5

1

2

3

4

5

6

7

8

9

10

CSV File Configuration
A CSV file opened in Excel is formatted as shown below.

*1 Data that includes unusable characters cannot be imported. Refer to “Detailed Settings” (page 7-7).

Column Item Description Remarks
A ID 0 - 65535 Numbers within square brackets [ ]: Element No. 0 to 4095 with the use of arrays 1-byte
B Tag *1 Within 70 one-byte characters 1-byte / 2-byte
C Type 0: Bit device memory

1: Word Device memory
2: Double-word device memory
3: Bit variable

4: Integer variable
5: Double-word integer variable
6: Real number variable
7: Real number device memory

1-byte

D Array Setting 0: Not used, 1: Used 1-byte
E No. of 

Elements
1 - 4096 1-byte, only 

when “1” is 
specified for [D. 
Array Setting]

F Address

Example: Specifying PLC1 Mitsubishi D100

1-byte

• 1:1 connection
Word designation: PLC1 [D00100]
Bit designation: PLC1 [D00100-00]

• 1:n connection (port No. 0)
Word designation: PLC1 [0:D00100]
Bit designation: PLC1 [0:D00100-00]

Example: Specifying internal device memory $u100
Word designation: $u00100, bit designation: $u00100-00

Example: Specifying File No. 0, Record No. 0, and Data No. 100
Word designation: [0:0] #0100, bit designation: [0:0] #0100-00

 

Example: Specifying PLC1 Fuji Electric T-link TI00
Word designation: PLC1 [TI00], bit designation: PLC1 [TI00-00]

Common device memory: CW/CB/MW/MB/VW 1-byte, only 
when the 
general-purpose 
FL-Net is 
designated as 
PLC1

G Comment Within 130 one-byte characters 1-byte / 2-byte

[Tag Database Edit] data exported to a CSV file

The number of elements in an array 
must be the same as the number 
shown in [No. of Elements].

* Do not change the header 
information enclosed in the 
red dotted frame. Otherwise, 
the data in the CSV file cannot 
be correctly imported into the 
screen program.

Device memory + address
PLCNo.1 - 8

PLCx [xxxxx]PLC device memory

Device memory + address
xxxxxInternal device memory: 

$u/$T/$s/$L/$LD

Record No. 0 to 4095

[xx:xxxx] #xxxx

File No. 0 to 15 Data No. 0 to 4096
Memory card device

Device memory + address
PLCx [xxxxx]I/O device memory

PLCNo.1 - 8

Device memory + address
PLCx [xxxxx]

PLCNo.1 - 8

Example:
• Specifying CW100

Word designation: PLC1 [CW0100], bit designation: PLC1 [CW0100-00]
• Specifying MW100 (port No. 1)

Word designation: PLC1 [1:MW0100], bit designation: PLC1 [1:MW0100-00]
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7.2.3 Configuring Arrays
This section describes the procedure when “5” is specified for [No. of Elements] for the PLC1 device memory “D200”, and “3” 
for the integer variable in the array format.

1. Select the [Array] checkbox and specify the number for the [No. of Elements] field.

2. Double-click on the ID number and enter a description in the [Comment] field of the [Detail Setting] window.

This completes the necessary settings.
Tag arrays can be specified in the settings window of each part.

7.2.4 Importing Tags
Tags or system labels registered in PLC software can be imported using V-SFT and used as tags.

• A maximum of 4096 elements can be set.
• If the bit variable is specified in the array format, 1 word is occupied in the variable area even if “16” 

or a smaller number is specified for the number of elements.
For details, refer to “Tag Settings” page 7-20.

• Tag [n] (n: number of elements in the array)

 D200 to D204 are used.
 3 words are used in the variable area.

Total [0] (= D200)

Total [1] (= D201)
Total [2] (= D202)
Total [3] (= D203)
Total [4] (= D204)

* The [Detail Setting] window can also be displayed from the [Tag Database Edit] tab or by 
right-clicking and selecting [Detail Setting].

* Manually enter a value for [n].

For details, refer to “7.5 Importing Tags” page 7-11.
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7.3 Detailed Settings
[Tag Database Edit] Window
The [Tag Database Edit] window consists of 256 groups, and 256 lines can be registered per group. Accordingly, a maximum of 
65536 lines can be registered in total.

Location of settings: [Home] → [Registration Item ] → [Tag Database]

Item Description
ID Line No. 0 to 65535
Tag *1 Specify a tag name. Max. 70 one-byte characters (two-byte characters allowed, 

one-byte/two-byte/uppercase/lowercase are treated as different characters.)
Type, Device Specify the data type for the tag.

Array Use an array.
For details on setting arrays, refer to “7.2.3 Configuring Arrays” page 7-6.

No. of Elements When [Array] is checked, specify the number of elements to be used in the array. Max. 4096
Comment Enter a description for the tag. Max. 130 one-byte characters (two-byte characters allowed, 

one-byte/two-byte/uppercase/lowercase are treated as different characters.)
Status of Use If a tag is used as device memory in the screen program, “In use” is indicated.

Click a cell indicating “In use” to show where the tag is set.
Double-click the indicated location field to jump to that location.

Conversion *2 Set alarm, operation and scaling settings. These settings are used for numerical data display parts.
For details, refer to “ Conversion Settings” page 7-8.

No.  256

No.  65280

No.  0

No.255

No.  1

No.  512

[Tag Database Edit] window

Acceleration time word device memory
Frequency word device memory

Alarm bit device memory

Group No. 0
Group No. 1

Group No. 255

Group No. 2

Double-click to jump to the 
location used.

Filter
Click

Device memory Type Data Type
PLC device memory
Internal device memory
Memory card
I/O device memory
Common device memory

Bit 1-bit data
Word 1-word data
Double-word Double-word data
Real number 32-bit single precision real number format

Variable Bit variable 1-bit data
Integer variable 1-word data
Double-word integer variable Double-word data
Real number variable 32-bit single precision real number format
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*1 If an unavailable character is used, the following message box will appear. In this case, perform registration again.

*2 Not supported if [Type] is set to “Bit” or “Bit Variable”.

Conversion Settings
Operation and scaling functions can be used with respect to device memory addresses of tags. Configure the following 
settings.

•  Applicable items:
-  Numerical data display

Item *1 Description
Input Type (BCD, DEC, FLOAT) Select the code to use when reading data from device memory.
Display Format Select the format for displaying on the screen.
Alarm *2 Select this checkbox to display data in a different color when it exceeds or falls short of a 

specific range.
When “Entry Target” is selected for [Function], the range of values that can be entered 
using a keypad can be set.

Minimum Set the minimum value used to trigger an alarm.
Use offset value 
designation device

Set the device memory address and code used for storing an offset value for the 
minimum value.

Char. Color Set the color for text.
Background Set the background color of text.

Maximum Set the maximum value used to trigger an alarm.
Use offset value 
designation device

Set the device memory address and code used for storing an offset value for the 
maximum value.

Char. Color Set the color for text.
Background Set the background color of text.
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*1 For details, refer to “5.1 Numerical Display” in the TS Reference Manual 1.
*2 The alarm setting uses the values before operation and scaling.

Numerical data display
1. Display the settings window for the numerical data display and select the tag with [Conversion] settings at [Contents] → 

[Device to Display].
2. Select the [Use tag operation/scaling/alarm] checkbox.

Operation Select this checkbox to perform an operation on the value of the device memory address 
specified in [Contents].

Scaling Select this checkbox to display data after automatically converting the data read from the 
PLC ([Range before Scaling]) to the specified range ([Range after Scaling]).

Range before Scaling Specify the data to be read from the PLC
Range after Scaling Specify the range of data to be shown on MONITOUCH.

Item *1 Description

Multiplier or divisor (constant)Offset value
(constant)

“×” or “/” (÷)

Device memory specified in [Contents]

MONITOUCH

(Range before scaling) (Range after scaling)

4000

100

00

PLC

Settings are grayed out and the [Conversion] 
settings are displayed.
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7.4 Tag Status List
The tag status list of the entire screen program can be searched and the total word count of tag variables can be checked.

The procedure of searching only for tags currently in use is explained as an example.

1. Click [Tool] → [Search] → [Tag Use] to display the [Tag Use] window.

2. Click the [ ] filter button next to [Status of Use].
Only select the [In use] checkbox and click [OK].

The necessary settings have been completed.
The search results are displayed. Selecting a tag displays the location of use.

For details, refer to “Checking the Capacity of “Tag” Variable” page 7-20.

Text search is 
possible.

Double-click to jump to 
the location of use.
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7.5 Importing Tags
Tags or system labels registered in PLC software can be imported using V-SFT and used as tags.

Manufacturers of supported PLCs
• “MITSUBISHI ELECTRIC” page 7-11
• Siemens

- “Model S7” page 7-15
- “Model S7-200” page 7-18

MITSUBISHI ELECTRIC
Global labels registered in Simple Project (with labels) or Structured Project in MITSUBISHI ELECTRIC’s software GX Works2 
can be registered as system labels in the software MELSOFT Navigator. These system labels can be exported in CSV file 
format. When such CSV files are imported using V-SFT, system labels in the files can be used as tags in V-SFT.

* For details on using PLC software, refer to the relevant PLC manual.

Supported PLC Models

* Importing using V-SFT is allowed provided that [PLC1] and a 1:1 connection mode are set in the [System Setting] 
→ [Hardware Setting] window. Importing is not possible for PLC2 and subsequent PLCs.

When whole program compiling is executed in GX Works2, device memory addresses registered with global 
labels will be reassigned to global labels. If there are global labels with no PLC device memory addresses 
assigned, addresses of such labels will be assigned according to the automatic assignment setting made in GX 
Works2.
Therefore, assigning PLC device memory addresses to global labels is recommended.

Manufacturer PLC Model
MITSUBISHI ELECTRIC QnH (Q) series link

QnH (Q) series CPU
QnU series CPU
Q00J/00/01 CPU
QnH (Q) series (Ethernet)
QnH (Q) series (Ethernet ASCII)
QnU series (built-in Ethernet)
QnH (Q) series (CC-LINK)
L series link
L series (built-in Ethernet)
FX3U/3UC/3G series CPU
FX3U/3UC/3G series link (A protocol)
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Procedure
This section describes the steps to import “Device A” data registered in the system label list into a screen program.

* The following table lists the types of data that can be imported using V-SFT and the data types after importing.

*1 No other types of data can be imported using V-SFT.
*2 With the PLC model QnH (Q) series (CC-LINK), data of the type “Retentive Timer” cannot be imported.

1. Start MELSOFT Navigator.
2. Right-click [DeviceA] under [System Label List], and then click [System Label List] → [Export].

MITSUBISHI ELECTRIC “System Label”
Data Type for Tags in V-SFT

Data Type *1 Length
Bit 1 bit Bit
Word [Signed] 1 word Word
Word [Unsigned] 1 word
Timer 1 word
Counter 1 word
Retentive Timer *2 1 word
Double Word [Signed] 2 words Double-word
Double Word [Unsigned] 2 words
Time 2 words
FLOAT [Single Precision] 2 words Real number

Structure
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3. A message dialog box is displayed. Click the [Yes] button.

4. The [Select Export Destination Folder] window is displayed.
Select “CSV” for [Save as type] and click [Save].

5. Open the destination folder. Check that the CSV file with the same name in the system label list is created.
(Example: DeviceA.csv)

6. Open the screen program in V-SFT. Click [Home] → [Registration Item] → [Tag Database] to display the [Tag Database 
Edit] window.

7. Click [Edit] → [Tag Import].

8. The [Open] window is displayed. Select “MELSOFT Navigator File (*.csv)” for [Files of type]. Select the desired CSV 
filename (e.g. “DeviceA.csv”) and click [Open].

* The dotted line frame indicates the structure. A structure name with a period is added to the top of 
each label name.

Structure.Elements_1

Structure name
Period

Label name

File types

Device A

.CSV
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The contents of the file are registered as tags in the “tag database edit” window. Types ([Type]) are specified for individual 
device memory addresses.
This completes the import procedure.

Notes
Note the following for importing CSV files.

• If a file to be imported includes a tag that is already registered, the existing tag is overwritten. Unregistered tags are 
registered to blank ID numbers (in the [Tag Database Edit] window).

• Only device memory addresses available on the TS can be imported. For details, refer to the TS2060 Connection Manual 
or the TS1000 Smart Connection Manual.

* Periods “.” cannot be used with tags. If any system label exported from MELSOFT 
Navigator includes a period, the period is converted to an underscore “_”.
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Siemens
Supported PLC Models

* Importing using V-SFT is allowed provided that [PLC1] and a 1:1 connection mode are set in the [System Setting] 
→ [Hardware Setting] window. Importing is not possible for PLC2 and subsequent PLCs.

Model S7
When a project file (*.s7p) created in Siemens software “SIMATIC Manager (version 5.5 or 5.4)” is imported using V-SFT, names 
registered in data blocks “DBx” can be used as tags in V-SFT.

Procedure
This section describes the steps to import a project file (e.g. “test.s7p”), in which data blocks DB1 and DB2 are registered, to a 
screen program.

* The following table lists the types of data that can be imported using V-SFT and the data types after importing.

* No other types of data can be imported with V-SFT. Data types BYTE and CHAR (bytes) are imported as word device memory. If any odd 
bytes are registered in the PLC software, the data cannot be imported.

Manufacturer PLC Model Refer to
Siemens S7 page 7-15

S7-300/400 MPI
S7-300/400 (Ethernet ISOTCP)
S7-300/400 (Ethernet TCP/IP PG protocol)
S7 PROFIBUS-DP
S7-200 PPI page 7-18

For details on using PLC software, refer to the relevant PLC manual.

Siemens “DBxx”
Data Type for Tags in V-SFT

Data Type * Length
BOOL 1 bit Bit
BYTE * 1 byte Word

CHAR * 1 byte
WORD 1 word
S5TIME 1 word
DATE 1 word
INT 2 words
DWORD 2 words Double-word
DINT 2 words
TIME 2 words
TIME_OF_DAY 2 words
REAL 2 words Real number

Double-click
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1. Start V-SFT and open the screen program.
Click [Home] → [Registration Item] → [Tag Database] to display the [Tag Database Edit] window.

2. Click [Edit] → [Tag Import].

3. The [Open] window is displayed.
Specify “Siemens S7 Project File (*.s7p)” for [Files of type].
Select the desired project file (e.g. “test.s7p”) and click [Open].

4. The [Tag List] window is displayed. Select the tags to import.
• [Data Block List]: Displayed block by block (data block “DBx”)

• [Tag List]: All tags displayed_

* When specifying further search criteria, go to [Filter setting]. Only tags that match the specified data type, data block 
name, or tag name will be displayed in the [Tag List] window.

Selected: To be imported
Unselected: Not to be imported

Selected: To be imported
Unselected: Not to be imported

Filtering out “a1”

A one-byte space is treated as an OR condition.
(Case-sensitive)
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5. Click [OK].
The contents of the file are registered as tags in the “tag database edit” window. Types ([Type]) are specified for individual 
device memory addresses.
This completes the import procedure.

Notes
Note the following for importing CSV files.

• If a file to be imported includes a tag that is already registered, the existing tag is overwritten. Unregistered tags are 
registered to blank ID numbers (in the [Tag Database Edit] window).

• Device memory addresses unavailable on the TS cannot be imported.
For details on device memory addresses available on the TS, refer to the TS2060 Connection Manual or the TS1000 Smart 
Connection Manual. Data types BYTE and CHAR (bytes) are imported as word device memory. Device memory registered 
to odd bytes in the PLC software cannot be imported.

DB1

Example: Only DB1 imported

a1_DB_VAR

Tag name with “_”

Name

* Periods “.” cannot be used with tags. If any tag includes a period, the period is 
converted to an underscore “_”.
A tag name with an underscore “_” registered in a SIMATIC Manager data block 
(DBxx) is added to the top of each tag.
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Model S7-200
When a CSV file copied from the Symbol Table in the software “SIMATIC STEP 7-Micro/WIN” for Siemens S7-200 is imported 
using V-SFT, the contents in the file can be used as tags.

* For details on using PLC software, refer to the relevant PLC manual.

Procedure
1. Start the software “SIMATIC STEP 7-Micro/WIN” for Siemens S7-200.
2. Open [Symbol Table].

3. Select all columns under [Symbol], [Address], and [Comment]. Right-click and select [Copy] from the right-click menu.

4. Start Excel. Paste the copied data to the worksheet from cell A1.

Only device memory addresses available on the TS can be imported. For details, refer to the TS2060 Connection 
Manual or the TS1000 Smart Connection Manual. Double-word device memory are imported as word device 
memory.

Device memory: VD → VW, ID → IW, QD → QW, MD → MW, SMD → SMW, SD → SW

Select all.

Tags Device memory Comment

[Tag Database Edit] in V-SFT

* The first row on the Excel sheet corresponds to tag ID No. 0. The copied data on the 
worksheet is imported from its first row to the [Tag Database Edit] window. (65536 
maximum)
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5. Click [File] → [Save As]. The [Save As] window is displayed.
6. Enter a filename. Select “CSV” for [Save as type] and click [Save].
7. Open the screen program. Click [Home] → [Registration Item] → [Tag Database] to display the [Tag Database Edit] 

window.
8. Click [Edit] → [Tag Import].

9. The [Open] window is displayed. Select the CSV file saved in step 6. Specify “Siemens S7-200 File (*.csv)” for [Files of type] 
and click [Open].

The contents of the file are registered as tags in the “tag database edit” window. Types ([Type]) are specified for individual 
device memory addresses.
This completes the import procedure.

Notes
Note the following for importing CSV files.

• IDs that already have tags are overwritten with the imported data.
• Device memory addresses unavailable on the TS cannot be imported. If an unavailable device memory address is 

included, the row is left blank.
For details on device memory addresses available on the TS, refer to the TS2060 Connection Manual or the TS1000 Smart 
Connection Manual. Note that double-word device memory are imported as word device memory.

Device memory: VD → VW, ID → IW, QD → QW, MD → MW, SMD → SMW, SD → SW

File types
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7.6 Notes
Tag Settings
Tags cannot be specified for the following items.

• [Screen Setting] → [PLC Device Transfer]
• Device memory map (transfer source device memory, transfer destination device memory 1, transfer destination device 

memory 2, control device memory)
• Modbus device memory table

“Tag” Variable Capacity
When “tag” variables are registered in the [Tag Database Edit] window, the variable area in the MONITOUCH is used. Since the 
capacity of the variable area is limited, check the word count currently used, and be careful not to exceed the capacity.

Capacity of Variable Area

Checking the Capacity of “Tag” Variable
Check the capacity when the “tag” variables are registered as shown below.

2 words are occupied in the variable area.

= 4096

= 4096

Bit variable

Integer variable

Double-word 
integer variable

Real number variable

Variable Area

Word

Word

Variable Type Data Type Capacity
Bit variable * 1-bit data 4096 word
Integer variable 1-word data
Double-word 
integer variable

Double-word data 4096 word

Real number 
variable

32-bit single precision real 
number format

* If the bit variable is specified in array format, 1 word is occupied in the variable 
area even if “16” or a smaller number is specified for the number of elements.

For details on status list operations, refer to “7.4 Tag Status List”.

The value is indicated in red when it exceeds the maximum value. If the tag indicated in red is used on the 
screen, the message “Error: 46” appears and the unit will not run. Set a value smaller than the maximum.

Integer variable “1” + bit variable “1”

Two words are used per double-word integer variable
Example: A total of four words are used when two 

double-word integer variables are 
registered
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8.1 Overview
• The TS unit contains device memory map numbers 0 to 31 (32 total) with respect to a single logical port. 128 addresses 

can be registered to a single device memory map and batch transfer of addresses can be performed between each 
equipment.

No. 0
No. 1

No. 30
No. 31

No. 0
No. 1

No. 126
No. 127

No. 0
No. 1

No. 30
No. 31

No. 0
No. 1

No. 126
No. 127

No. 0
No. 1

No. 30
No. 31

No. 0
No. 1

No. 126
No. 127

Data

PLC2

PLC8

PROGRAMMER

F A C T O R Y

A C E

PLC1

PLC1 device memory map Device memory

Device memory

Device memory

PLC2 device memory map

PLC8 device memory map

Device memory map

Registration of PLC1 
device memory

Registration of PLC2 
device memory

Registration of PLC8 
device memory



8  Device Memory Map

8-2

• Functions that use device memory maps
- Periodical reading

Data in device memory addresses registered on a device memory map is periodically transferred to other equipment. 
(“8.3 Periodical Reading” page 8-7)

- Periodical writing
Data in other equipment is periodically transferred to device memory addresses registered on a device memory map. 
(“8.7 Control Device” page 8-12)

- Synchronized reading
Data in device memory addresses registered on a device memory map is transferred to other equipment when the 
relevant bit turns ON. (“8.4 Synchronized Reading” page 8-8)

- Synchronized writing
Data in other equipment is transferred to device memory addresses registered on a device memory map when the 
relevant bit turns ON. (“8.6 Synchronized Writing” page 8-11)

- Macros (TBL_READ, TBL_WRITE)
Data in device memory addresses registered on a device memory map is transferred using the “TBL_READ” and 
“TBL_WRITE” macro commands. (“8.8 TBL_READ/TBL_WRITE” page 8-13)“8.9 System Device Memory” page 8-14

No. 0
No. 1

1:#PV
 1:#SV

D500
D501

45
60

1:#PV
1:#SV

45
60

MJ2 MJ1

PLC2PLC1 Data

Periodical reading/synchronized reading/TBL_READ

Periodical writing/synchronized writing/TBL_WRITE

PLC2 device memory map number 0
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8.2 Editing Device Memory Maps
8.2.1 Starting

1. Click [System Setting] → [Device Memory Map] → [PLCn].
The [Device Memory Map: PLCn] window is displayed.

2. Select a device memory map number and click [OK].
The [Device Memory Map Edit] window is displayed.

A device memory map has numbers 0 to 31 (32 total) with respect to a single logical port and 128 addresses can be 
registered to each device memory map.

8.2.2 Quitting
Click the close button.

8.2.3 Comment Settings
A comment can be set to each device memory map.
1. With the device memory map displayed, click [Edit] → [Comment]. The [Comment Setting] window is displayed.

2. Enter a comment and click the [OK] button. The comment is displayed.
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8.2.4 Editing the Device Memory Map
Double-click a cell to display the settings window.

1. Device memory entry
Set the device memory for transfer. If the [Device Memory Map Edit] window for PLC2 is open, register PLC2 device 
memory.
The following figure shows the list view.

2. Data type

Item Description

Word Data is handled as single-word numerical data.
Data is transferred based on the [Communication Setting] → [Code] setting of each logical port. *1

Double Word Data is handled as two-word numerical data.
Data is transferred based on the [Communication Setting] → [Code] setting of each logical port. *1

Bit Data is handled as single-word bit information.
Data is transferred as is without conversion. *2

Dummy Word
Dummy Double

The transfer source/target device memory addresses are automatically registered with consecutive numbers. 
If there is an address to be skipped, leaving it not configured (blank) will result in either a dummy word or 
double word being assigned.
When reading:

“0” is always stored in the transfer target device memory. Cannot be used for any other purpose.
When writing:

The transfer source device memory can be used for other purposes.

Device memory entry Data type Device memory map settings

* The [Device Memory Map Setting] window can also be displayed by clicking 
[Edit] → [Device Memory Map Setting] with the device memory map displayed.
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*1 When Word or Double Word is selected:
The internal device memory of the TS unit are always handled as “DEC (with sign)”.

*2 When Bit is selected:

3. Device memory map settings
Set the purpose of each device memory map.
• TBL_READ/TBL_WRITE → page 8-13
• Periodical reading → page 8-7
• Synchronized reading → page 8-8
• Periodical writing → page 8-10
• Synchronized writing → page 8-11

BCD

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0

MSB LSB

DEC 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
0 0 0 0 0 0 0 0 0 0 0 0 1 0 1 0

MSB LSB

DEC
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
0 0 0 0 0 0 0 0 0 0 0 0 1 0 1 0

MSB LSB

BCD
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0

MSB LSB

Code

Transfer source 
PLC

TS internal device 
memory

Transfer target 
PLCm

Bit status

Communication 
setting

Communication 
setting

Communication 
setting

Reading

BCD

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
0 0 0 0 0 0 0 0 0 0 0 1 0 0 0 0

MSB LSB

DEC

DEC
BCD

Code

Transfer source 
PLC

TS internal device 
memory

Transfer target 
PLCm

Bit status
Communication setting

Communication setting

Reading



8  Device Memory Map

8-6

8.2.5 Permitting Interruption
Interruption can be permitted by right-clicking on the relevant device memory map number and selecting [Enabling 
Interruption] on the menu.
When interruption is permitted, an asterisk mark (*) is shown next to the device memory map number. Switch output, cycle 
reading, trend/alarm reading operations can be performed during device memory map processing.

Operation for the following settings
Reading group 0 (numbers 0 to 7)
↓
Switch output, cycle reading, trend/alarm reading
↓
Reading group 1 (numbers 8 to 15)

Group 0

Group 1
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8.3 Periodical Reading
Data in a device memory address registered on a device memory map is transferred to the targeted address at the timing set 
for [Reading Cycle].

Settings
Settings required for periodical reading

• “Editing Device Memory Maps” (page 8-3)
• “Device Memory Map Settings”

Item Description
Function Periodical reading

Reading Cycle

Set the cycle for periodical data reading.

Target Device 1
Target Device 2 Set the device memory address for storing the read data.

Control Device Disabled when [Periodical Reading] is selected.

PLC2 PLC1

MJ1 MJ2

Data

Transferred at 5 second intervals

PLC2 device memory map number 0

Disabled when [Periodical Reading] 
is selected

[High-speed Reading] 
checkbox

Reading Cycle
Setting Range Unit

Unselected 1 - 3600 1s
Selected 1 - 3600 100ms
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8.4 Synchronized Reading
Data in a device memory address registered on a device memory map is transferred to the targeted address when the 
relevant bit changes from 0 to 1.

D100
D101

D200
D201
D202
D203

0
0

D100
D101

D200
D201
D202
D203

216
250

PLC2 PLC1

MJ1 MJ2

Data

Transfer

PLC2 device memory map number 0

Control device memory ON

Verification device memory ON

PLC1

Control Device

Transfer target 
device memory

PLC1

Control Device

Transfer target 
device memory

Data transfer
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Settings
Settings required for synchronized reading

• “Editing Device Memory Maps” (page 8-3)
• “Device Memory Map Settings”

Item Description
Function Synchronized reading
Target Device 1
Target Device 2 Set the device memory address for storing the read data.

Control Device
Set the device memory address that serves as the trigger for synchronized reading.
Four words are used for an address common to device memory map numbers 0 to 31.
For details, refer to “Control Device” page 8-12.
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8.5 Periodical Writing
Data in a source device memory address is transferred to the address registered on the device memory map at the timing set 
for [Writing Cycle].

Settings
Settings required for periodical writing

• “Editing Device Memory Maps” (page 8-3)
• “Device Memory Map Settings”

Item Description
Function Periodical writing

Periodical Writing

Set whether to perform periodical data writing.

Source Device 1
Source Device 2 Set the device memory address of the source data to transfer.

Control Device Disabled when [Periodical Writing] is selected.

PLC2 PLC1

MJ1 MJ2

Data

Transferred at 5 second intervals

PLC2 device memory map number 0

Disabled when [Periodical Writing] 
is selected

[High-speed Reading] 
checkbox

Reading Cycle
Setting Range Unit

Unselected 1 - 3600 1s
Selected 1 - 3600 100ms
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8.6 Synchronized Writing
Data in a source device memory address is transferred to the address registered on the device memory map when the control 
device memory changes from 0 to 1.

Settings
Settings required for synchronized writing

• “Editing Device Memory Maps” (page 8-3)
• “Device Memory Map Settings”

Item Description
Function Synchronized writing
Source Device 1
Source Device 2 Set the device memory address for storing data from the transfer source.

Control Device
Set the device memory address that serves as the trigger for synchronized writing.
Four words are used for an address common to device memory map numbers 0 to 31.
For details, refer to “Control Device” page 8-12.

41003 200

D100

D200
D201
D202
D203

200

D100

D200
D201
D202
D203

200

PLC2 PLC1

MJ1 MJ2

Data

Writing
&

Verification device 
memory ON

Transfer

PLC2 device memory map number 0

Control device memory ON

PLC1

Transfer source 
device memory

Control Device

PLC2 PLC1
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8.7 Control Device
This type of device memory is used when synchronized reading or synchronized writing is performed.
Four consecutive words are used from control device memory n.
The control device memory can be changed via [System Setting] → [Device Memory Map] → [PLCn] → [Device Memory Map: 
PLCn] → [Edit]  → [Device Memory Map Setting].

Reading/Writing Command Device Memory (Control device memory n, n + 1)
One bit is assigned to each device memory map.
Reading and writing for the specified device memory map is executed according to the change in bit status from 0 to 1.

Reading/Writing Verification Device Memory (Control device memory n + 2, n + 3)
One bit is assigned to each device memory map.
The turning ON (0 → 1) of the command device memory is recognized, and when the reading/writing finishes, the 
corresponding bit of the verification device memory turns ON (0 → 1).
Also, when the turning OFF (1 → 0) of the command device memory is recognized, the verification bit of the corresponding 
device memory map number turns OFF (1 → 0).

• Synchronized reading
Only one address needs to be successfully read among the addresses registered on the device memory map for the 
verification device memory to turn ON.
If no addresses were successfully read, the verification bit does not turn ON.

• Synchronized writing
Regardless of whether writing succeeds or fails, the verification bit turns ON after writing is finished.

Control Device Description Device Memory Type
n

Command device memory for reading/writing → TS
n+1
n+2

Verification device memory for reading/writing ← TS
n+3

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
31 30 29 28 27 26 25 24 23 22 21 20 19 18 17 16

n

Device memory map numbers 0 to 15

Device memory map numbers 16 to 31

n + 1

Bit number

Bit number

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
31 30 29 28 27 26 25 24 23 22 21 20 19 18 17 16

n + 2

Device memory map numbers 0 to 15

Device memory map numbers 16 to 31

n + 3

Bit number

Bit number
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8.8 TBL_READ/TBL_WRITE
Data in device memory addresses registered on a device memory map is transferred at once using the “TBL_READ” and 
“TBL_WRITE” macro commands.

Settings
Settings required for device memory map transfer

• “Editing Device Memory Maps” (page 8-3)
• Device memory map settings
• Macros (TBL_READ/TBL_WRITE)

Device Memory Map Settings

Macros
Register a switch ON macro, interval timer etc. For details on macro commands, refer to the Macro Reference Manual.

• TBL_READ
Transfers data in device memory addresses registered on a device memory map to device memory of other equipment.

• TBL_WRITE
Transfers data from other equipment to a device memory address registered on a device memory map.

Item Description
Function TBL_READ/TBL_WRITE

* Transfer is possible using a macro even for device memory maps selected for other functions.
Control Device Disabled when TBL_READ/TBL_WRITE is selected.

Disabled when TBL_READ/TBL_WRITE 
is selected
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8.9 System Device Memory
This section explains the system device memory addresses of the TS that are related to device memory maps.

*1 When controlling a device memory map using $s762, $s763, or $s764, set [PLC Properties] → [Detail] → [System memory ($s) V7 
Compatibility] to [Yes] for PLC2. In this case, $P2:493/494/495 cannot be used.

$Pn:493, 495
These system device memory addresses can be used to temporarily stop periodical reading/synchronized reading or 
periodical writing/synchronized writing set in the device memory map.

• Example: Periodical reading
When PLC2 device memory is accessed by a macro, macro completion is delayed when periodical reading of the device 
memory map is executed (as shown in figure A). To avoid this, periodical reading can be stopped temporarily using 
$P2:493 (as shown in Figure B).

$Pn
(n=1 - 8) $s*1 Description Device Type

493 762
(PLC2)

Device memory map reading prohibition flag
0: Periodical reading/synchronized reading executable
Other than 0: Periodical reading/synchronized reading stopped

→ TS494 763
(PLC2)

Device memory map TBL_READ/TBL_WRITE macro forced execution
Macro operation setting when a port is not communicating

0: Do not execute the macro with respect to all ports
Other than 0: Execute the macro with respect to connected ports

495 764
(PLC2)

Device memory map writing prohibition flag
0: Periodical writing/synchronized writing executable
Other than 0: Periodical writing /synchronized writing stopped

$Pn:493 $Pn:495
- 0: Periodical reading/synchronized reading is 

always executed.
- 0: Periodical writing/synchronized writing is 

always executed.
- Other than 0: Periodical reading/synchronized reading is 

stopped.
- Other than 0: Periodical writing/synchronized writing is 

stopped.

PLC_CTL $u100 2
PLC_CTL $u110 2
PLC_CTL $u120 2

PLC_CTL $u300 2

T

t

PLC_CTL $u100 2
PLC_CTL $u110 2
PLC_CTL $u120 2

PLC_CTL $u300 2

T+t

T T

$P2:493=1
PLC_CTL $u100 2
PLC_CTL $u110 2
PLC_CTL $u120 2

PLC_CTL $u300 2
$P2:493=0

$P2:493=1
PLC_CTL $u100 2
PLC_CTL $u110 2
PLC_CTL $u120 2

PLC_CTL $u300 2
$P2:493=0

t

Device memory map
Periodical reading

Figure A

Macro A executionMacro A execution

Periodical reading of PLC2
device memory map

TS unit communication cycle

Macro B executionMacro B execution

Periodical reading of PLC2
device memory map

Device memory map
Periodical reading

TS unit communication cycle

• TEL_READ
• TEL_WRITE
• PLC_CTL
• When using PLC2 device 

memory with MOV, BMOV, 
BSET, BCLR, BINV etc.

Figure B
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9.1 Overview

• PLC ladder programs can be written and monitored via the TS unit.

Example: USB connection

For details on the configuration procedure, refer to .
• USB connection: “9.3 Ladder Transfer via USB” page 9-9
• Ethernet connection: “9.4 Ladder Transfer via Ethernet (TSi Only)” page 9-14
• Serial connection: “9.5 Serial Ladder Transfer (TS2060i/TS2060 Only)” page 9-19

• The ladder transfer function is only available when the PLC targeted for connection is registered as [PLC1]. 
In addition, [Hardware Setting] → [PLC Properties] → [Communication Mode] must be set to [1:1].
This function cannot be used for 1:n connections (multi-drop), multi-link communication, or multi-link2 
communication.

• Simultaneous ladder communication with multiple PLCs by one computer is not possible. Be sure to specify 
the ladder transfer port of the PLC to communicate with using the “LadderComOp“ ladder transfer tool.

USB-AUSB-miniB

USB cable

Computer

PLC ladder 
software

Ladder program, monitor, etc.

TS unit

PLC

Serial 
RS-232C/422
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9.1.1 Operating Environment
Ladder Transfer Ports

Supported PC Operating Systems
Windows 2000 / XP / Vista / 7 / 8 / 8.1 / 10

Required Applications

Supported PLC Models

PLC models that support the ladder transfer function are listed below.

Model Applicable Ports
TS2060i USB-B / LAN / MJ1 / MJ2
TS2060 USB-B / MJ1 / MJ2
TS1100Si / TS1070Si USB-B / LAN
TS1070S USB-B

Connection Method Application
USB connection

V-SFT Ver. 6 / LadderComOp Ver. 2
Ethernet connection
Serial connection V-SFT Ver. 6

• The ladder transfer function is only available when the PLC targeted for connection is registered as [PLC1]. 
In addition, [Hardware Setting] → [PLC Properties] → [Communication Mode] must be set to [1:1].
This function cannot be used for 1:n connections (multi-drop), multi-link communication, or multi-link2 
communication.

• For details on compatible PLC models, refer to the TS2060 Connection Manual or the TS1000 Smart 
Connection Manual.

Manufacturer PLC Name Shown in Editor Connection CPU/Port
TS Port

MJ1, MJ2 USB B *1 Built-in LAN *2

MITSUBISHI 
ELECTRIC

A series CPU *3

A2A, A3A
A2U, A3U, A4U
A2US(H)
A1N, A2N, A3N
A3V, A73
A3H, A3M
A0J2H
A1S(H), A1SJ(H)
A2S(H)
A2CCPUC24
A1FX

 *4

QnH (Q) series CPU Q02(H), Q06H

QnU series CPU
Q00UJ, Q00U, Q01U
Q02U, Q03UD, Q04UDH
Q06UDH, Q10UDH, Q13UDH 
Q20UDH, Q26UDH

Q00J/00/01 CPU Q00J, Q00, Q01
QnH (Q) series CPU
(Multi CPU) Q02(H), Q06H

Q170MCPU
(Multi CPU) Q170M

FX series CPU
FX1/2 *3 × × ×

FX0N
FX2N/1N
series CPU FX2N, FX1N, FX2NC

FX1S series CPU FX1S
FX-3U/3UC/3G
series CPU FX-3U, FX-3UC, FX-3G
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*1 Ladder communication is only available in RUN mode. Ladder communication cannot be performed on the Main Menu screen.
*2 Only supported on theTSi.
*3 Connection with the TS1000 Smart not possible.
*4 Only supported for the TS2060i unit with DUR-00 installed. This also uses both MJ1 and MJ2 so the dedicated “V6-CP-A” cable is 

required.
*5 The following messages may be displayed at the top left of the screen on the TS unit during access (mainly when transferring a large 

amount of data, such as programs) to the Siemens S7-200 PPI and S7-300/400 MPI. The TS unit automatically returns to normal operation 
after access is complete.
- PLC1  Access denied by Loader
- PLC1  In Reset Service

OMRON
SYSMAC C

All ports
× ×

SYSMAC CS1/CJ1/CJ2

Panasonic
FP Series
(RS232C/422)

FP0 tool port
FP2 tool port
FP2SH tool port
FPΣ tool port
FP-e tool port
FP-X tool port
FP0H tool port

FP7 Series (RS232C/422) All ports

Yokogawa 
Electric

FA-M3
Tool port on CPUFA-M3R

FA-M3V x x x

Fuji Electric

SPB (N mode) & 
FLEX-PC CPU

FLEX-PC CPU port
× ×NJ-B16 RS-232C port

NW0Pxx CPU port
MICREX-SX 
SPH/SPB/SPM/SPE/SPF CPU

NP1Px-xx (SPH)
NW0Pxx (SPB)

Allen-Bradley SLC500 SLC5/03 or later, Channel 0 × ×

Siemens *1 *5
S7-200PPI S7-200 PPI port *1 *5 *1 *5 *1 *5

S7-300/400MPI S7-300/400 MPI port *1 *5 × *1 *5

SAMSUNG SECNET

N70 COM port
(RS-422)

× ×

N70 α COM port 
N700 COM port
(RS-422)
N700 α TOOL port
N7000 COM port
(RS-422)
N7000 α COM1
NX70 TOOL port
NX700 TOOL port

FATEK 
AUTOMATION FACON FB series Programming port on CPU

RS Automation N7/NX Series 
(70/700/750/CCU)

N70 COM port
(RS-422)

× ×

N70 α COM port 
N700 COM port
(RS-422)
N700 α TOOL port
N7000 COM port
(RS-422)
N7000 α COM1
NX70 TOOL port
NX700 TOOL port

Manufacturer PLC Name Shown in Editor Connection CPU/Port
TS Port

MJ1, MJ2 USB B *1 Built-in LAN *2
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9.2 LadderComOp Ver. 2
The “LadderComOp” ladder transfer tool is required when connecting the TS unit and PC via USB or Ethernet in order to 
monitor or write PLC ladder programs.

9.2.1 LadderComOp Installation

Acquiring the LadderComOp Software
• On the V-SFT Ver. 6 CD-ROM, or download the latest update from our website.
• Download “LadderComOp.exe” from our website.

Installation
If installing LadderComOp during V-SFT Ver. 6 installation, perform the procedure below from step 1.
If installing LadderComOp after downloading “LadderComOP.exe” from our website, perform the procedure below from step 
2.

1. After V-SFT Ver. 6 has been installed or updated, the following dialog box is displayed.
Click the [Yes] button.

2. Click the [Next] button.

3. Select the location to install the tool and click the [Next] button.

Our website URL: http://www.monitouch.com

Installation location (default)
Windows Vista/7/8/8.1/10: MONITOUCH
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4. Click the [Install] button.

5. Installation of LadderComOp starts.

6. The following window is displayed. Install the LadderComOp driver.
This window is display three times so click the [Install] button each time.

7. Installation of the driver starts.

The following window is displayed during installation.
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8. The following window is displayed when LadderComOp installation is complete. Click the [Finish] button.

9. The following message is displayed on the PC’s task bar when installation is complete.

10. Open the Device Manager on the PC.
If installation was successful, “LadderComOp2” is displayed in the Device Manager.

This completes the installation procedure.

If installation was not successful, a yellow exclamation mark (!) is displayed under [Other devices] in the Device 
Manager.
If this happens, uninstall LadderComOp and then reinstall it.
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9.2.2 LadderComOp Ver. 2 Detailed Settings

Item Description
1. Icon Clicking this icon and selecting [About LadderComOp] opens a window that displays the version of 

LadderComOp.
2. PC A total of two COM ports on the PC are used.

• Used Port
Select the COM port to use for ladder transfer from the list.
Range: COM1 to COM256
(COM port numbers that are already assigned on the PC are not shown in the list.)
The COM port number set here needs to be set in each relevant PLC programming software.*

* The range of usable COM port numbers depends on the PLC programming software.
For details, refer to the relevant PLC manual.
Example:
Panasonic FPWIN GR, COM1 to 15
(COM1 to 5 for Ver. 2.2 or earlier)

• Virtual Port
An unassigned COM port number is selected automatically.

3. MONITOUCH Select the connection method to use between the PC and TS unit.
• USB

No settings are required.
• Ethernet

IP address: Set the local IP address of the TSi unit (built-in LAN port).
Port No: Set the port number of the TSi unit.

Set the same port number as set under [Hardware Setting] → [Ladder Transfer].
Range: 1024 to 65533 (default: 1024)

4. ONLINE/OFFLINE Turn ladder transfer ON or OFF between the PC and TS unit.
• ONLINE

Establish a connection between the PC and TS unit and enable ladder transfer mode.
• OFFLINE

Disconnect the PC and TS unit.

2.

1.

3.

4.
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Item Description
5. Connected to the MITUBISHI A 

series CPU. (A)
Always select this checkbox when using a MITSUBISHI ELECTRIC A series CPU.

6. Hide/END • Hide
Display an icon in the task tray when a connection is established.
LadderComOp is added to the task tray.
* The [Add in the task tray] checkbox is automatically selected.
- The task tray tool tip indicates “Transferring...”.

- Right-click on the icon in the task tray to display a menu.

• END
Display an icon in the task tray when a connection is not established.
Disconnect the PC and TS unit and close the [Ladder Transfer Setting] window.

6.
5.

Right-click
Return

Display the [Ladder Transfer Setting] window.
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9.3 Ladder Transfer via USB

The TS unit and PC can be connected via USB to monitor or write PLC ladder programs through the TS unit.

9.3.1 Setting Procedure
V-SFT and LadderComOp configuration is required. Refer to the following for the setting procedure.

• V-SFT Ver. 6 settings → “V-SFT Ver. 6 Settings” page 9-9
• LadderComOp settings → “LadderComOp Settings” page 9-11
• PLC programming software settings → “PLC Programming Software Settings” page 9-12

V-SFT Ver. 6 Settings
This section describes the settings for ladder transfer using the MITSUBISHI QnU series CPU as an example.

[Ladder Transfer Setting] window
1. Click [Communication Setting] → [Hardware Setting] to display the [Hardware Setting] window.

For details on supported PLC models, refer to “Supported PLC Models” page 9-2.

The ladder transfer function is only available when the PLC targeted for connection is registered as [PLC1]. In 
addition, [Hardware Setting] → [PLC Properties] → [Communication Mode] must be set to [1:1].
This function cannot be used for 1:n connections (multi-drop), multi-link communication, or multi-link2 
communication.

USB-AUSB-miniB

USB cable

PC

PLC ladder 
software

Ladder program/monitor, etc.

TS unit

PLC

Serial 
RS232C/422
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2. Click [Ladder Transfer] to display the [Ladder Transfer Setting] window.

3. Select the [Use Ladder Transfer] checkbox and set the port to which the computer is connected (the ladder transfer port) 
to [USB B].

* Be sure to use a different ladder transfer port for each PLC.

4. Click the [OK] button to complete the necessary settings. Transfer the screen program to the TS unit.

Notes on ladder transfer via USB
Observe the following when transferring screen programs over a USB cable.

• Switch to the Main Menu screen on the TS.
(Ladder communication is enabled only in RUN mode.)

• Set LadderComOp Ver. 2 to [OFFLINE] mode.
(For details on this setting, refer to “9.2.2 LadderComOp Ver. 2 Detailed Settings” page 9-7.)
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LadderComOp Settings
When using the ladder transfer function via USB/Ethernet, the dedicated “LadderComOp” tool must be installed on the PC. 
For details on the LadderComOp installation procedure, refer to “9.2.1 LadderComOp Installation” page 9-4.

[Ladder Transfer Setting] window
1. From the Windows [Start] menu, click [Programs] → [V-SFT V6] → [LadderComOp] → [Ladder Transfer Setting].

2. The [Ladder Transfer Setting] window is displayed.

3. Select the COM port to use for ladder transfer from the [Used Port] list under [PC].
* This port must match the COM port used in the PLC programming software.

4. Select [USB] under [MONITOUCH].

5. Click the [ONLINE] button.
The display above the ladder transfer settings changes to the connected state.

This completes the LadderComOp settings.
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PLC Programming Software Settings
Set the COM port number configured in the [Ladder Transfer Setting] window of LadderComOp to the following window of 
the relevant PLC programming software to enable access to the PLC.

MITSUBISHI ELECTRIC GX Developer/GX Works2

OMRON CX-Programmer
Be sure to select “SYSMAC WAY” for [Network Type].
[Network Settings] dialog → [Driver] → [Port Name]
For [Baud Rate], specify the same value between the TS unit and the PLC.

Panasonic “FPWIN GR”
[Communication Settings] dialog → [Port No.]
For [Baud Rate], specify the same value between the TS unit and the PLC.

Yokogawa Electric “Wide Field2”
[Environmental Settings] dialog → [Communication Settings] → [COM Port No.]

Example: [Ladder Transfer Setting] window, COM port number 9

For [Transmission speed], 
specify the same value as 
the baud rate between the 
TS unit and the PLC.
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Fuji Electric SX-Programmer Expert (D300win)

For [Baud rate], specify the same 
value as the baud rate between 
the TS unit and the PLC.
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9.4 Ladder Transfer via Ethernet (TSi Only)
The TSi unit and PC can be connected via Ethernet to monitor or write PLC ladder programs through the TSi unit.

9.4.1 Setting Procedure
V-SFT and LadderComOp configuration is required. Refer to the following for the setting procedure.

• V-SFT Ver. 6 settings → “V-SFT Ver. 6 Settings” page 9-14
• LadderComOp settings → “LadderComOp Settings” page 9-16
• PLC programming software settings → “PLC Programming Software Settings” page 9-17

V-SFT Ver. 6 Settings
This section describes the settings for ladder transfer using the MITSUBISHI QnU series CPU as an example.

[Ladder Transfer Setting] window
1. Click [System Setting] → [Hardware Setting] to display the [Hardware Setting] window.

For details on supported PLC models, refer to “Supported PLC Models” page 9-2.

The ladder transfer function is only available when the PLC targeted for connection is registered as [PLC1]. In 
addition, [Hardware Setting] → [PLC Properties] → [Communication Mode] must be set to [1:1].
This function cannot be used for 1:n connections (multi-drop), multi-link communication, or multi-link2 
communication.

Ethernet

PC

PLC ladder 
software

Ladder program/monitor, etc.
TSi unit

PLC

Serial 
RS232C/422
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2. Click [Ladder Transfer] to display the [Ladder Transfer Setting] window.

3. Select the [Use Ladder Transfer] checkbox and set the port to which the computer is connected (the ladder transfer port) 
to [Built-in LAN].

* This port is also used in the LadderComOp settings.
Be sure to use a different ladder transfer port for each PLC.

This completes the necessary settings. Transfer the screen program to the TS unit.
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LadderComOp Settings
When using the ladder transfer function via USB/Ethernet, the dedicated “LadderComOp” tool must be installed on the PC. 
For details on the LadderComOp installation procedure, refer to “9.2.1 LadderComOp Installation” page 9-4.

[Ladder Transfer Setting] window
1. From the Windows [Start] menu, click [Programs] → [V-SFT V6] → [LadderComOp] → [Ladder Transfer Setting].

2. The [Ladder Transfer Setting] window is displayed.

3. Select the COM port to use for ladder transfer from the [Used Port] list under [PC].
* This port must match the COM port used in the PLC programming software.

4. Select [Ethernet] under [MONITOUCH] and set the IP address of the TSi unit and the port number to use in ladder transfer.
* The port number must match the ladder transfer port number specified in the [Hardware Setting] window of 

V-SFT Ver. 6.

5. Click the [ONLINE] button.
The display above the ladder transfer settings changes to the connected state.

This completes the LadderComOp settings.
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PLC Programming Software Settings
Set the COM port number configured in the [Ladder Transfer Setting] window of LadderComOp to the following window of 
the relevant PLC programming software to enable communication with the PLC.

MITSUBISHI ELECTRIC GX Developer/GX Works2

OMRON CX-Programmer
Be sure to select “SYSMAC WAY” for [Network Type].
[Network Settings] dialog → [Driver] → [Port Name]
For [Baud Rate], specify the same value between the TSi unit and the PLC.

Panasonic “FPWIN GR”
[Communication Settings] dialog → [Port No.]
For [Baud Rate], specify the same value between the TSi unit and the PLC.

Yokogawa Electric “Wide Field2”
[Environmental Settings] dialog → [Communication Settings] → [COM Port No.]

Example: [Ladder Transfer Setting] window, COM port number 9

For [Transmission speed], 
specify the same value as 
the baud rate between the 
TSi unit and the PLC.
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Fuji Electric SX-Programmer Expert (D300win)

Siemens “STEP 7-Micro/WIN”
[Set PG/PC Interface] dialog → [PC/PPI cable (PPI)] → [Properties].

Siemens SIMATIC Manager

For [Baud rate], specify the same 
value as the baud rate between 
the TSi unit and the PLC.

The baud rate between the TSi unit and 
the PC is fixed to 115 Kbps.

Set [Connection to:] in the range of 
COM1 to 8.
[Transmission rate:] does not need to be 
changed.
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9.5 Serial Ladder Transfer (TS2060i/TS2060 Only)

The TS2060 unit and PC can be connected using a “V-CP” screen program transfer cable to monitor or write PLC ladder 
programs through the TS2060 unit.

* The TS2060i unit with DUR-00 installed must be used when using the MITSUBISHI A series CPU. Use Hakko 
Electronics’ “V6-CP-A” cable to connect the TS2060i unit and a computer.

Executing Screen Program Transfer and Ladder Transfer Using the MJ1 Port
Use the MJ1 port when using the ladder transfer function and performing screen program transfer over a single cable.
Screen program transfer and PLC programming software transfers cannot be performed at the same time. Communication of 
either software is cut off in order to perform transfers.
Screen program transfer is only possible on the Main Menu screen. For details, refer to   [Ladder Communication is not Used 
in Local Mode] settings page 9-21 .

Executing Screen Program Transfer Using the MJ1 Port and Ladder Transfer Using the 
MJ2 Port (TS2060i + DUR-00)

Screen program transfer and PLC programming software transfers can be performed using separate COM ports and cables.
Screen program transfer and PLC programming software transfers cannot be performed at the same time.

For details on supported PLC models, refer to “Supported PLC Models” page 9-2.

The ladder transfer function is only available when the PLC targeted for connection is registered as [PLC1]. In 
addition, [Hardware Setting] → [PLC Properties] → [Communication Mode] must be set to [1:1].
This function cannot be used for 1:n connections (multi-drop), multi-link communication, or multi-link2 
communication.

COM
MJ1/MJ2

PC

PLC ladder 
software

Ladder program/monitor, etc.
TS2060 unit

PLC

Serial 
RS232C/422

V-CP

MJ1MJ2 COM1
TS2060

Computer (PC)
PLC

1:1 communication cable

CPU port

Communication between the PLC programming
software and PLC

Communication between the editor and TS2060 unit

Communication between the TS2060 unit and PLC

V-CP PLC software
V-SFT

MJ1CN1 COM1

COM2MJ2

 TS2060i + DUR-00
Computer (PC)

PLC 1:1 communication cable
CPU port

Communication between the PLC programming
software and PLC

Communication between the editor and TS2060 unit

Communication between the TS2060 unit and PLC

V-CP PLC software
V-SFT

V-CP
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Communication with the MITSUBISHI ELECTRIC A Series CPU 
(TS2060i with DUR-00 Installed Only)
Use Hakko Electronics “V6-CP-A” cable to connect the TS2060 unit and PC.

9.5.1 Setting Procedure
V-SFT configuration is required. Refer to the following for the setting procedure.

• V-SFT Ver. 6 settings → “V-SFT Ver. 6 Settings” page 9-20
• PLC programming software settings → “PLC Programming Software Settings” page 9-23

V-SFT Ver. 6 Settings
This section describes the settings for ladder transfer using the MITSUBISHI QnH (Q) series CPU as an example.

[Ladder Transfer Setting] window
1. Click [System Setting] → [Hardware Setting] → [Ladder Transfer]. The [Ladder Transfer Setting] window is displayed.

MJ1CN1 COM1

MJ2

Computer (PC)
PLC 1:1 communication cable

CPU port

Communication between the PLC programming
software and PLC

Communication between the editor and TS2060 unit

Communication between the TS2060 unit and PLC

V6-CP-A PLC software
V-SFT

 TS2060i + DUR-00
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2. Select the [Use Ladder Transfer] checkbox and set the port to which the computer is connected to [MJ1] or [MJ2].

3. Click the [OK] button to complete the necessary settings. Transfer the screen program to the TS2060 unit.

[Ladder Communication is not Used in Local Mode] settings
Selecting the [MJ1] or [MJ2] connection port allows the [Ladder Communication is not Used in Local Mode] checkbox setting 
to be selected in the [Detail Setting] window.

Whether screen program transfer and ladder transfer can be performed in a particular state of the TS2060 unit differs 
depending on the combination of this setting and the modular jack function.

• MJ1: Ladder transfer

• MJ1: Not connected, MJ2: Ladder transfer

• MJ1: Not connected/other than ladder transfer, MJ2: Ladder transfer

[Ladder Communication is not 
Used in Local Mode] TS2060 Unit State Screen Program Transfer Ladder Transfer

Selected
RUN

Local mode

Unselected
RUN

Local mode * *

[Ladder Communication is not 
Used in Local Mode] TS2060 Unit State Screen Program Transfer Ladder Transfer

Selected
RUN

Local mode

Unselected
RUN

Local mode

[Ladder Communication is not 
Used in Local Mode] TS2060 Unit State Screen Program Transfer Ladder Transfer

Selected
RUN

Local mode

Unselected
RUN

Local mode
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* Switching to Local mode
Press the [SYSTEM] → [F1] switch to display the Main Menu screen.
[Editor:---] (ladder transfer mode) is displayed at the lower left of the screen. In this case, screen program transfer using 
the MJ1 port cannot be performed.
(Refer to the table below.)

Switching between [Editor:---] and [Editor:MJ1] is performed using a function switch.
Press and hold the [F2] switch for three seconds.

Indication Screen Program Transfer Ladder Transfer
Editor:---

Editor:MJ1

Press for three seconds.
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PLC Programming Software Settings
Set the COM port number to enable communication with the PLC.

MITSUBISHI ELECTRIC GX Developer/GX Works2

OMRON CX-Programmer
Be sure to select “SYSMAC WAY” for [Network Type].
[Network Settings] dialog → [Driver] → [Port Name]
For [Baud Rate], specify the same value between the TS2060 unit and the PLC.

Panasonic “FPWIN GR”
[Communication Settings] dialog → [Port No.]
For [Baud Rate], specify the same value between the TS2060 unit and the PLC.

Yokogawa Electric “Wide Field2”
[Environmental Settings] dialog → [Communication Settings] → [COM Port No.]

Fuji Electric SX-Programmer Expert (D300win)

Siemens “STEP 7-Micro/WIN”
[Set PG/PC Interface] dialog → [PC/PPI cable (PPI)] → [Properties].

For [Transmission speed], specify the same 
value as the baud rate between the TS2060 
unit and the PLC.

For [Baud rate], specify the same 
value as the baud rate between 
the TS2060 unit and the PLC.

The baud rate between the TS2060 unit 
and the PC is fixed to 115 Kbps.
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Siemens SIMATIC Manager

Set [Connection to:] in the range of 
COM1 to 8.
[Transmission rate:] does not need to be 
changed.
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9.6 Notes

Screen Program Transfer
• When transferring a screen program via USB cable while executing the ladder transfer function via USB, always perform 

the following.
- Switch to the Main Menu screen on the TS.

(Ladder communication is enabled only in RUN mode.)
- Set LadderComOp Ver. 2 to [OFFLINE] mode.

(For details on this setting, refer to “9.2.2 LadderComOp Ver. 2 Detailed Settings” page 9-7.)
• When using Siemens S7-200 PPI or S7-300/400 MPI, always switch to the Main Menu screen before transferring the 

screen program. (Ladder communication is enabled only in RUN mode.)

Other Notes
• The ladder transfer function can be used for up to three ports with PLC 1 to 8.
• When using a PC with user privileges enabled, perform the following in advance.

1) Log in with administrator privileges.
2) Start the LadderComOp program and set a COM port for [Used Port].

* When settings are configured initially, LadderComOp may take a few moments to exit.
Also, if a user logs in without administrator privileges, the following message is displayed and the LadderComOP software cannot 
be used.

• The following messages are displayed at the top left of the screen on the TS unit during access (mainly when transferring 
a large amount of data, such as programs) to the Siemens S7-200 PPI and S7-300/400 MPI. The TS unit automatically 
returns to normal operation after access is complete.

- PLC1  Access denied by Loader
- PLC1  In Reset Service

• The communication states of the PLC programming software and PLC when communication is performed between the 
editor and the TS unit are shown below.

• Baud rate
The baud rate used between the TS unit and the PLC is the value set in the editor for [Hardware Setting] → [PLC 
Properties] → [Baud Rate].
However, when communication (monitoring etc.) with the PLC programming software occurs with the ladder transfer 
function, the baud rate value changes to that of the PLC programming software. This baud rate is retained until power to 
the TS unit is turned off and on again.
For this reason, set the same baud rate setting for [Hardware Setting] → [PLC Properties] → [Baud Rate] as the PLC 
programming software.

• When [Use Ladder Tool] is set to [Yes], monitor registration of the TS unit and PLC communication is prohibited even if the 
PLC programming software is not running. This means that the screen display speed is slightly slower than usual.

• When transferring ladder programs when the TS unit is in RUN mode, the performance of both the TS unit and the PLC 
programming software decreases because communication between the two is performed in synchronization.

Editor PLC Programming Software
Writing to TS unit Communication stops (normal communication after writing finishes)
Reading from TS unit Normal communication
Checking with TS unit Normal communication



9  Ladder Transfer

9-26



www.monitouch.com

890-1, Kamikashiwano-machi, Hakusan-shi, Ishikawa, 
924-0035 Japan
Tel +81-76-274-2144
E-mail support@hakko-elec.co.jp


	TS2060 TS1000 Smart Reference Manual 2
	Record of Revisions
	Preface
	TS Types and Model Names
	Available Functions
	Notes on Safe Usage of MONITOUCH
	Contents
	1 Image Display
	1.1 JPEG Display
	1.1.1 Overview
	JPEG File Display
	Network Camera Image Display

	1.1.2 Detailed Settings
	Operation Select
	Style
	Show/Hide
	Detail

	1.1.3 JPEG File Location

	1.2 Network Camera
	1.2.1 Overview
	1.2.2 System Requirements
	Applicable Models
	Available Network Cameras or Sensors

	1.2.3 Required Settings
	V-SFT Settings
	Network Camera Settings

	1.2.4 Detailed Settings
	Device Setting
	Manufacturer: AXIS and Panasonic
	BANNER

	Contents
	Style
	Show/Hide
	Detail

	1.2.5 AXIS Settings (Example: AXIS 214PTZ)
	Access from the Computer
	Network Camera Settings
	Checking and changing the IP address
	HTTP settings
	Basic authentication settings
	Checking and registering user names and passwords

	Operating the Camera Lens from the TSi Unit
	With basic authentication
	Without basic authentication


	1.2.6 Panasonic (Example: BB-HCM580)
	Access from the Computer
	CD-ROM
	Web browser (Microsoft Internet Explorer)

	Network Camera Settings
	Checking and changing the IP address
	Authentication settings
	Registering and changing the settings of general users
	Changing guest user settings

	Checking and Registering User Names and Passwords
	Administrator
	General users

	Image Display Settings

	1.2.7 BANNER (Example: PresencePLUS P4 OMNI)
	Access from the Computer
	Sensor Settings
	Port number setting
	RUN


	1.2.8 Restrictions
	All Manufacturers
	AXIS and Panasonic
	BANNER



	2 Operation Log
	2.1 Overview
	2.1.1 Operation Log
	Operation Overview
	Operation Log Viewer
	Log Storage


	2.2 Using the Operation Log Viewer
	2.2.1 Conceptual Operation
	2.2.2 Setting Procedure

	2.3 Applicable Items
	2.3.1 Applicable Items and Saving
	Applicable Items and Timing of Saving
	Saved Items (Titles)
	Start
	Transfer
	Mode Changeover
	Screen Changeover
	Language Changeover
	Switch
	Data Display Update (Numerical Display, Character Display)
	Storage Writing Error
	Log Destruction



	2.4 Detailed Settings
	2.5 Operation Log Viewer
	Showing/Hiding Logs
	Showing/Hiding Items and Changing Width (No. of Characters) and Date/Time Format

	2.6 Log Data
	2.6.1 Output Timing
	SRAM
	Storage Device

	2.6.2 Details of Output (File Type)
	SRAM
	Storage Device

	2.6.3 Importing Log Data to Computer (Conversion to CSV Files)
	File Conversion Procedure


	2.7 System Device Memory

	3 Security
	3.1 Overview
	Security
	Screen Security Levels
	Item Security Levels
	Showing/Hiding Items
	Prohibiting Switch Operations

	Login, logout
	Login
	Logout


	3.2 Security Settings
	3.3 Security Level Settings
	Screen Settings
	Location of settings

	[Show/Hide] Settings in the Settings Window of Each Part
	Applicable items
	Location of settings

	[Interlock] Settings in the [Switch] Settings Window
	Location of settings


	3.4 Login/Logout
	Location of Settings

	3.5 System Device Memory ($s)

	4 Ethernet Communication Function
	4.1 Preface
	4.1.1 List of Functions

	4.2 TSi Unit IP Address Settings
	4.2.1 Setting Using the V-SFT Editor
	4.2.2 Setting the IP Address via the Main Menu
	4.2.3 Ethernet Terminology
	IP Address
	Notation
	Unusable IP addresses

	Port No.
	TSi port numbers

	Default Gateway
	Subnet Mask
	Unusable subnet masks



	4.3 Screen Program Transfer
	4.3.1 Transfer Procedure
	Downloading (PC ® TSi)


	4.4 PLC Communication
	4.5 Transferring Data Between TSi Units (Macro)
	4.6 DLL Communication
	4.7 MES Interface Function
	4.7.1 Overview
	4.7.2 System Configuration
	Required Settings
	TSi
	Server PC


	4.7.3 TSi Unit Settings
	Network Table Editing
	MES Settings
	Common settings
	[Write] tab window
	[Read] tab window
	[Search condition] tab window

	Macros
	MES macro command list
	MES CHECK (F1, F2, F3)
	MES WRITE (F1, F2, F3)
	MES READ (F1, F2, F3)
	MES DEL (F1, F2, F3)
	MES UPDATE (F1, F2, F3)

	System Device Memory ($s)
	$s514, 515


	4.7.4 V-Server
	V-Server
	System requirements

	Installation

	4.7.5 Database
	Types of Databases
	SQL Server 2012 Express Edition
	Installation

	Creating an SQL Server Database
	Installation
	Starting SQL server management studio express
	Creating a new database
	Creating a new table
	Opening a table


	4.7.6 Data Source (ODBC) Settings
	For 64-bit versions of Windows XP/Vista/7/8/8.1/10


	4.8 E-mail Notification
	4.8.1 Overview
	4.8.2 Detailed Settings
	IP Address Settings
	E-mail Settings
	Buffering Area Settings
	Message Editor

	4.8.3 System Device Memory ($s)
	4.8.4 Notes

	4.9 FTP Server
	4.9.1 Overview
	4.9.2 Specifications
	Functional Capabilities
	Compatible FTP Client Tools
	Supported FTP Commands

	4.9.3 Detailed Settings
	4.9.4 Specifying File Paths
	4.9.5 Login
	Explorer (or Internet Explorer)

	4.9.6 Log Out
	Explorer (or Internet Explorer)

	4.9.7 Checking the Connection
	System Device Memory ($s)
	Checking the Connection State
	Closing the Connection
	Automatic disconnection
	Manual disconnection from the TSi unit
	Disconnection from FTP client


	4.9.8 Restrictions
	Number of Simultaneous FTP Client Connections
	File Property Changes

	4.9.9 Notes
	Notes on FTP Server System Design
	Notes on File Transfer


	4.10 Remote Desktop
	4.10.1 Overview
	Operating Environment
	Required Settings
	Server (Computer) Settings
	TSi Unit Settings
	V-SFT Settings


	4.10.2 Server (Computer) Settings
	Installing and Configuring UltraVNC

	4.10.3 TSi Unit Settings
	Registering/Deregistering the License
	Registering a License
	Deregistering a License


	4.10.4 V-SFT Settings
	Remote Desktop Table Settings
	Remote Desktop Window Display Procedure
	Placement of a Display Area to Show Remote Desktop Window
	Switch to Show/Hide Remote Desktop Window
	Showing/Hiding Using a Macro Command


	4.10.5 Window Configuration and Operation
	Window Configuration
	Scroll bars
	[S] switch
	[S] menu

	Operation Method
	USB mouse
	USB keyboard


	4.10.6 System Memory
	4.10.7 Error
	[Disconnected.] Screen
	Error No.

	4.10.8 Limitations
	License Limitations
	Display Limitations
	Other Limitations


	4.11 Web Server
	4.11.1 Overview
	Applicable Models

	4.11.2 Notes
	Browser Settings
	Files Types Available for Use on Web Servers

	4.11.3 Monitoring Table Data Displays
	Creating SHT Files
	Procedure

	Saving to a Storage Device
	When Using the Storage Manager
	When Using Explorer

	Accessing with a Web Browser

	4.11.4 Memory Device Access
	Device Memory Access Flowchart
	CGI Function (MemAcs.cgi)
	Device Memory Access Parameter List
	Example of Device Memory Access
	Creating HTM Files
	Saving to a Storage Device
	Accessing with a Web Browser


	4.11.5 JPEG File Display
	Without Using an HTM File
	Using an HTM File
	Creating HTM Files
	Saving to a Storage Device
	Accessing with a Web Browser



	4.12 VNC Server
	4.12.1 Overview
	4.12.2 Specifications
	TSi Unit (Server)
	Restrictions

	4.12.3 Setting Procedure
	4.12.4 V-SFT Settings
	VNC Server Settings

	4.12.5 VNC Client Settings/Operations
	VNC Viewer Software
	Connecting to the VNC Server
	Ultra VNC

	Keyboard Entry

	4.12.6 System Device Memory ($s)


	5 Storage Device
	5.1 Overview
	5.1.1 Connections
	Applicable Models

	5.1.2 Storage Device Specifications
	Supported Storage Devices
	Notes on Handling Storage Devices


	5.2 Access Folders
	5.2.1 Access Folders
	5.2.2 Storage Device Settings
	5.2.3 Folder Configuration
	Access folder (DAT0000)
	Automatic upload (DSPDEF)


	5.3 Function Descriptions
	5.3.1 List of Functions
	5.3.2 Screen Program Transfer
	PC ® Storage Device Writing
	Storage Device ® PC Reading

	5.3.3 Automatically Uploading Screen Programs
	PC ® Storage Device Writing
	Operation on the TS Unit
	Notes on Write Operations

	5.3.4 Reducing Screen Program Data Size
	File Location and Filename
	PC ® Storage Device Writing
	Operation on the TS Unit
	Notes on File Storage

	5.3.5 Storing Messages (TXT Files)
	File Location and Filename
	PC ® Storage Device Writing (For TXT Files)
	Operation on the TS Unit

	5.3.6 Storing JPEG Files
	JPEG File Location and Filename
	Storing Files on a Storage Device
	Windows explorer
	Storage manager

	Operation on the TS Unit

	5.3.7 Transferring Recipe Data
	5.3.8 Storing History Data
	5.3.9 Operation Logs
	5.3.10 Saving Screenshot Images
	5.3.11 Saving Network Camera Images
	5.3.12 Saving Memo Pad Data
	Memo Pad Data Location and Filename
	Operation on the TS Unit
	Timing of Saving

	5.3.13 SRAM Data Backup

	5.4 Storage Manager
	5.4.1 Starting and Ending
	Starting
	Ending

	5.4.2 Writing
	Writing Procedure

	5.4.3 BIN Files
	BIN File Conversion
	Notes
	BIN File Properties

	5.4.4 Storage Copy
	5.4.5 Storage Device Backup

	5.5 System Device Memory ($s)

	6 Language Changeover
	6.1 Overview
	6.1.1 Fonts
	6.1.2 Font Types
	Supported Language List
	Checking Fonts on Main Menu Screen
	Font Names


	6.1.3 Language Selection

	6.2 Setting Procedure
	6.2.1 Method of Storing Fonts on the Unit
	Font Setting Window

	6.2.2 Method of Storing Fonts on a Storage Device (Not Available with TS2060)
	Font Setting Window
	Writing Font Files to a Storage Device
	Storing Procedure
	Font Filenames


	6.2.3 Language Editing
	Directly Edit Items
	Checking the layout

	Editing in the [Multi-language Edit] Window
	Export / Import
	Outputting a File for Each of the Languages for Switching
	Export procedure
	Import procedure

	Outputting All Languages to a Single File
	Export procedure
	Import procedure



	6.2.4 Language Selection
	Switch Function
	Location of Settings
	Redraw Timing

	SYS (CHG_LANG) Macro Command
	Setting Example
	Detail
	Device used
	Range
	Editing procedure




	6.3 Detailed Settings
	6.3.1 Font Setting
	6.3.2 Transfer Font Setting
	6.3.3 Import and Export
	6.3.4 Manual Font Settings (When a Gothic Font is Selected)

	6.4 Convenient Editing Procedures
	6.4.1 Multi-language Batch Change
	Overview
	Setting Example

	6.4.2 Multi-language Batch Copy
	Overview
	Setting Example

	6.4.3 Multi-language Reordering
	Overview
	Setting Example



	7 Tag
	7.1 Overview
	7.1.1 Tag Types
	Device Designation
	Variable Designation
	Array Designation

	7.1.2 Importing Tags
	7.1.3 Operation and Scaling Functions (For Numerical Data Display)

	7.2 Editing Tags
	7.2.1 Direct Registration in the [Tag Database Edit] Window
	7.2.2 Editing in a CSV File
	CSV File Configuration

	7.2.3 Configuring Arrays
	7.2.4 Importing Tags

	7.3 Detailed Settings
	[Tag Database Edit] Window
	Conversion Settings
	Numerical data display



	7.4 Tag Status List
	7.5 Importing Tags
	Manufacturers of supported PLCs
	MITSUBISHI ELECTRIC
	Supported PLC Models
	Procedure
	Notes

	Siemens
	Supported PLC Models
	Model S7
	Procedure
	Notes

	Model S7-200
	Procedure
	Notes



	7.6 Notes
	Tag Settings
	“Tag” Variable Capacity
	Capacity of Variable Area
	Checking the Capacity of “Tag” Variable



	8 Device Memory Map
	8.1 Overview
	8.2 Editing Device Memory Maps
	8.2.1 Starting
	8.2.2 Quitting
	8.2.3 Comment Settings
	8.2.4 Editing the Device Memory Map
	8.2.5 Permitting Interruption

	8.3 Periodical Reading
	Settings

	8.4 Synchronized Reading
	Settings

	8.5 Periodical Writing
	Settings

	8.6 Synchronized Writing
	Settings

	8.7 Control Device
	Reading/Writing Command Device Memory (Control device memory n, n + 1)
	Reading/Writing Verification Device Memory (Control device memory n + 2, n + 3)

	8.8 TBL_READ/TBL_WRITE
	Settings
	Device Memory Map Settings
	Macros

	8.9 System Device Memory
	$Pn:493, 495


	9 Ladder Transfer
	9.1 Overview
	9.1.1 Operating Environment
	Ladder Transfer Ports
	Supported PC Operating Systems
	Required Applications
	Supported PLC Models


	9.2 LadderComOp Ver. 2
	9.2.1 LadderComOp Installation
	Acquiring the LadderComOp Software
	Installation


	9.2.2 LadderComOp Ver. 2 Detailed Settings

	9.3 Ladder Transfer via USB
	9.3.1 Setting Procedure
	V-SFT Ver. 6 Settings
	[Ladder Transfer Setting] window

	LadderComOp Settings
	[Ladder Transfer Setting] window

	PLC Programming Software Settings
	MITSUBISHI ELECTRIC GX Developer/GX Works2
	OMRON CX-Programmer
	Panasonic “FPWIN GR”
	Yokogawa Electric “Wide Field2”
	Fuji Electric SX-Programmer Expert (D300win)



	9.4 Ladder Transfer via Ethernet (TSi Only)
	9.4.1 Setting Procedure
	V-SFT Ver. 6 Settings
	[Ladder Transfer Setting] window

	LadderComOp Settings
	[Ladder Transfer Setting] window

	PLC Programming Software Settings
	MITSUBISHI ELECTRIC GX Developer/GX Works2
	OMRON CX-Programmer
	Panasonic “FPWIN GR”
	Yokogawa Electric “Wide Field2”
	Fuji Electric SX-Programmer Expert (D300win)
	Siemens “STEP 7-Micro/WIN”
	Siemens SIMATIC Manager



	9.5 Serial Ladder Transfer (TS2060i/TS2060 Only)
	Executing Screen Program Transfer and Ladder Transfer Using the MJ1 Port
	Executing Screen Program Transfer Using the MJ1 Port and Ladder Transfer Using the MJ2 Port (TS2060i + DUR-00)
	Communication with the MITSUBISHI ELECTRIC A Series CPU (TS2060i with DUR-00 Installed Only)
	9.5.1 Setting Procedure
	V-SFT Ver. 6 Settings
	[Ladder Transfer Setting] window
	[Ladder Communication is not Used in Local Mode] settings

	PLC Programming Software Settings
	MITSUBISHI ELECTRIC GX Developer/GX Works2
	OMRON CX-Programmer
	Panasonic “FPWIN GR”
	Yokogawa Electric “Wide Field2”
	Fuji Electric SX-Programmer Expert (D300win)
	Siemens “STEP 7-Micro/WIN”
	Siemens SIMATIC Manager



	9.6 Notes
	Screen Program Transfer
	Other Notes



